Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: KWin refuses to enable desktop effects

  1. #1
    Join Date
    Dec 2008
    Location
    Bulgaria, Sofia
    Posts
    33

    Default KWin refuses to enable desktop effects

    Hi,

    I have a clean new installation of openSUSE 11.4, but I can't enable the desktop effects in it. My video is nVidia GTS250 and I haven't any issues with enabling desktop effects in the past.

    Code:
    ilian@linux-home:~> su
    Password: 
    linux-home:/home/ilian # cat /etc/SuSE-release
    openSUSE 11.4 (x86_64)
    VERSION = 11.4
    CODENAME = Celadon
    linux-home:/home/ilian # lspci | grep VGA
    01:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce GTS 250] (rev a2)
    linux-home:/home/ilian # uname -r
    2.6.37.6-0.5-desktop
    linux-home:/home/ilian #
    The issue now is that every time I enable any effect in System settings, in lower right corner appears a error message from KWin that the following effects could not be activated (followed are the effects I had just enabled, for example Desktop Cube), as in screenshot below

    http://img155.imageshack.us/img155/1...notworking.png

    Can anyone assist me with this issue.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: KWin refuses to enable desktop effects

    On 07/18/2011 06:06 PM, gongalov71 wrote:
    >
    > Can anyone assist me with this issue.


    i see where you tell the video, but what driver are you using?

    have you tried installing the nvidia driver?
    see here http://tinyurl.com/37v9y7m

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the BMW® of operating systems!


  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,432

    Default Re: KWin refuses to enable desktop effects

    Go to Martin’s Blog and scroll down to 'The Compositing Modes of KDE Plasma Workspaces Explained' posted in May.

  4. #4
    Join Date
    Dec 2008
    Location
    Bulgaria, Sofia
    Posts
    33

    Default Re: KWin refuses to enable desktop effects

    @DenverD I'm using the default community nouveau driver that installs by default with openSUSE. Doesn't tried the proprietary nvidia driver yet

    @john_hudson I have OpenGL and XRender compositing modes, tried to change, but no effects at all.

  5. #5
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: KWin refuses to enable desktop effects

    Quote Originally Posted by gongalov71 View Post
    @DenverD I'm using the default community nouveau driver that installs by default with openSUSE. Doesn't tried the proprietary nvidia driver yet
    Then why not just install the proprietary driver?

    You can add and enable the Nvidia repo in YaST's 'Software Repositories' from 'Community Repositories.' And when you have done that just install the drivers with YaST's 'Software Management'; the right packages will probably be already preselected to install.

  6. #6
    Join Date
    Dec 2008
    Location
    Bulgaria, Sofia
    Posts
    33

    Default Re: KWin refuses to enable desktop effects

    I've just installed the nVIDIA driver via 1-click and blacklisted the nouveau driver and installed Compiz-config-settings-manager. Now the message window is gone, but still no Cube effect, after enabling it

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: KWin refuses to enable desktop effects

    On 07/19/2011 03:06 AM, gongalov71 wrote:
    >
    > I've just installed the nVIDIA driver via 1-click and blacklisted the
    > nouveau driver and installed Compiz-config-settings-manager. Now the
    > message window is gone, but still no Cube effect, after enabling it


    i _guess_ you don't have enough video ram for the effects you wish to
    watch...is your nvidia graphics on an inserted video card in a
    tower/desktop computer or built into the motherboard of a (say) laptop
    computer?

    if the video is not on its own add in board with a good bit of fast
    video memory, the system is forced to use "shared" memory (that is,
    taken from normal RAM) and a too small quantity of much faster "video
    ram" you must expect video performance hits...

    the only way to solve such a situation is to add hardware capability,
    which is possible with a desktop, but not a laptop (afaik)..

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  8. #8
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: KWin refuses to enable desktop effects

    Quote Originally Posted by gongalov71 View Post
    The issue now is that every time I enable any effect in System settings, in lower right corner appears a error message from KWin that the following effects could not be activated (followed are the effects I had just enabled, for example Desktop Cube), as in screenshot below

    http://img155.imageshack.us/img155/1...notworking.png

    Can anyone assist me with this issue.
    Here is a different thought ... On the tab labelled 'Advanced' (I don't know what that is in Bulgarian(?)) you can specify which compositing type is to be used. It should be set to 'OpenGL' and not 'XRender'. And anyway, playing around with the different settings on that tab may be something to try.

  9. #9
    Join Date
    Dec 2008
    Location
    Bulgaria, Sofia
    Posts
    33

    Default Re: KWin refuses to enable desktop effects

    @DenverD:

    It is a desktop PC with the following specs:

    CPU: Intel Core2Duo 6750@2,66 MHz
    RAM: Corsair 2x2GB DDR2
    Video: Gigabyte GTS250 1GB DDR3; here you can see it: GIGABYTE - Graphics Card - NVIDIA - PCI Express Solution - GeForce 200 Series - GV-N250OC-1GI
    HDD: 2xSeagate 320GB and 1xWestern Digital 1TB
    DVD-RAM: LG 32x
    KBD&Mouse: Logitech K120 kit
    Speakers: Creative 5.1
    OS: Dual boot Windows 7 x86_64 with enabled Aero and openSUSE 11.4 x86_64

    @Lord_Emsworth:

    Yes, I know about the compositing type, have played with it, as I wrote above. Now it is set to OpenGL. Someone in a bulgarian forum advised to install the latest KDE 4.6.5. My current installed version is 4.6.0 as shown on the left side of the following screenshot. On the right side is shown the System setting>Desktop effects>Advanced tab:



    Oh, and I forgot to say that I installed the nvidia proprietary driver. After that the window with the message that effects can't be enabled disappeared, but when enabling for example, the Desktop Cube effect, the PC freezes totally and the only option is to press the Reset button and reboot the system. So now, I think I may try to update to the latest KDE in hope to solve the issue. What do you think about this?

  10. #10
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: KWin refuses to enable desktop effects

    Quote Originally Posted by gongalov71 View Post
    @DenverD:

    It is a desktop PC with the following specs:

    CPU: Intel Core2Duo 6750@2,66 MHz
    RAM: Corsair 2x2GB DDR2
    Video: Gigabyte GTS250 1GB DDR3; here you can see it: GIGABYTE - Graphics Card - NVIDIA - PCI Express Solution - GeForce 200 Series - GV-N250OC-1GI
    HDD: 2xSeagate 320GB and 1xWestern Digital 1TB
    DVD-RAM: LG 32x
    KBD&Mouse: Logitech K120 kit
    Speakers: Creative 5.1
    OS: Dual boot Windows 7 x86_64 with enabled Aero and openSUSE 11.4 x86_64

    @Lord_Emsworth:

    Yes, I know about the compositing type, have played with it, as I wrote above. Now it is set to OpenGL. Someone in a bulgarian forum advised to install the latest KDE 4.6.5. My current installed version is 4.6.0 as shown on the left side of the following screenshot. On the right side is shown the System setting>Desktop effects>Advanced tab:



    Oh, and I forgot to say that I installed the nvidia proprietary driver. After that the window with the message that effects can't be enabled disappeared, but when enabling for example, the Desktop Cube effect, the PC freezes totally and the only option is to press the Reset button and reboot the system. So now, I think I may try to update to the latest KDE in hope to solve the issue. What do you think about this?
    The GPU that you have is strong enough. For comparison, I have an Nvidia Geforce 6100 onboard GPU and it plays Desktop Cube without any problems. I also have a PCIe Nvidia GeForce GT 520 and this one plays the Desktop Cube without any kind of problems if at the same time I have two HD videos in fullscreen.

    One last thing I can think of is to set the 'Scale Method' to either 'Crisp' or 'Smooth', IOW to NOT 'Accurate'. The tooltip that appears when I hover over this dropdown menu informs me that 'Accurate' may "cause various troubles with drivers" and advises to fall back to Smooth if there are problems. You might already have tried that, but I don't know anything else at the moment.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •