Results 1 to 10 of 10

Thread: XEN Breaks Networking - Will Give My Left Testicle For an Answer

  1. #1

    Default XEN Breaks Networking - Will Give My Left Testicle For an Answer

    Hi All,

    I've been trying to troubleshoot this problem for some weeks now.

    I am running OpenSuse 11.4 X86_64 patched to the current day (although this problem was occurring on 11.2 as well). When I install Xen and the associated dependencies my Samba instance crashes when transferring any files over about 100MB. I cannot see anything written to the samba or Linux logs that indicates a problem, even running tcpdump doesn’t show anything unusual, just the usual SYN and ACK packets until it suddenly stops. I have just installed Xen without setting up the bridge and even tried booting the previous kernel but the issues still occurs once these packages have been installed which leads me to believe the issue is related to a decency package that gets loaded regardless of the kernel. Does anyone have any suggestions as to how I can troubleshoot this issue?

    Note the server works flawlessly until I install Xen, I have tested it for over a week to make sure everything works. I would be most grateful for any help, I really need my server back for my uni study.

    Things I have tried:
    Transferring files via FTP or SCP seems to be fine although obviously much slower than Samba
    Add a second NIC of a different brand doesn’t change the result
    Dedicating a NIC to Samba doesn’t change the result
    Configuring Samba to only listen a dedicated NIC doesnt change the result

    Thanks,

    Adam

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: XEN Breaks Networking - Will Give My Left Testicle For an Answer

    Consider yourself lucky, because I don't know the answer, so you get to keep it. Sweaty ball sack included

    But that word: Xen = trouble IMO
    I can't think of anything that would make me install it. Hang on...... No, I'm right, I can't think of anything.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: XEN Breaks Networking - Will Give My Left Testicle For an Answer

    Forget about Xen and use kvm. But, please, do not take this suggestion as an answer to your question!

  4. #4

    Default Re: XEN Breaks Networking - Will Give My Left Testicle For an Answer

    I'll do some reading how but does LVM allow USB pass through. I would really like one of my VM's to have direct access to a USB wifi adapter.

  5. #5

    Default Re: XEN Breaks Networking - Will Give My Left Testicle For an Answer

    I was a little concerned if I did have to hand over my left testicle.... I should have mentioned pick up only

  6. #6

    Default Re: XEN Breaks Networking - Will Give My Left Testicle For an Answer

    Same issue with KVM

    Testicle is back on the platter...

  7. #7

    Default Re: XEN Breaks Networking - Will Give My Left Testicle For an Answer

    Quote Originally Posted by OrigenAG View Post
    I'll do some reading how but does LVM allow USB pass through. I would really like one of my VM's to have direct access to a USB wifi adapter.

  8. #8

    Default Re: XEN Breaks Networking - Will Give My Left Testicle For an Answer

    Very cool - thank you. I just need to resolve this **** networking issue

  9. #9

    Default Re: XEN Breaks Networking - Will Give My Left Testicle For an Answer

    I have a script which can help to create virtual machines in several directions: locally, remotely, by installing from DVD, from network. It probably needs to be reviewed, although I've been using it on 11.4 already. I haven't created a vm for a while and I update libvirt regularly. So I'm not 100% sure that it will still work but I'll find out sooner or later (probably later). When you understand the many options, it can be quite useful (the reason I worte it it that I needed it). You might want to give it a try. You'll find the explanation in post #2, the latest version in post #14 and the config file (which might need some changes) in post #15 of this thread: vm-create : create kvm virtual machines.

    You can create a vm either using NAT or bridge (that you can specify in the script options). If you use bridge and there is no bridge on the host, connecting to the hypervisor will fail. Therefore I wrote another script to convert virtual machines from nat to bridge and vice versa and create or destroy bridges on the host on the fly: vm-bridge : convert virtual machines from NAT to bridge or bridge to NAT. I mostly use it without argument to initiate a bridge before connecting to the hypervisor. Notice that you can create a bridge on any network interface - meaning in the worst case, add a nic, create a bridge on that one, add proper routes and keep your testicle (well, that would be in the best case then). But if you intend to use a wifi nic on the guest, you don't even need that. Maybe you could just remove the virtual network interface (whether NAT or bridge) using virsh command line or in virt-manager.

    virt-manager can manage local or remote hypervisor, as well as kvm or Xen. Actually I wrote the script to work with both kvm an Xen, but it has never been tested with Xen AFAIK, so I would assume that it probably won't work. IMO, Xen was yesterday.

  10. #10
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: XEN Breaks Networking - Will Give My Left Testicle For an Answer

    Try installing it using a different repo. I have in the past had bizarre
    issues where changing the repo solved it. No suggestions on which to try.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •