Results 1 to 8 of 8

Thread: Konqueror, nspluginviewer and flash 11 beta 1 for 64 bits

  1. #1

    Default Konqueror, nspluginviewer and flash 11 beta 1 for 64 bits

    I installed the adobe flash player 11 beta 1 64 bits from here
    Download Adobe Flash Player 11 Beta for Desktops - Adobe Labs
    It seems to work well with firefox 5, but under konqueror (4.6.5 / openSUSE 11.4) I have many random nspluginviewer crashes with a

    Application: nspluginviewer (nspluginviewer), signal: Segmentation fault

    message when a page contains a flash object. This did not happen with previous versions of the plugin so I'm wondering if anyone else see this. Reloading the page with F5 is usually enough and everything seems to work without problems... until I load another page and then have another crash. In fact, the crash mostly happens when loading the page, not when the flash object is already loaded.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Konqueror, nspluginviewer and flash 11 beta 1 for 64 bits

    So Konqueror has flash it just crashes?
    I don't have nspluginwrapper installed
    Konqueror works here just fine with flash _64
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Konqueror, nspluginviewer and flash 11 beta 1 for 64 bits

    The crash is not for nspluginswapper, but for nspluginviewer: because the plugin is 64 bits native, nspluginwapper is not even used. AFAIK, nspluginsviewer is provided by kdebase4-nsplugin package, not by nspluginwrapper, and it's needed for konqueror to use flash and other plugins.
    Notice that the problem is with 64 bits flashplayer 11 beta 1: the old 64 bits flashplayer square did not give this problem (it gave others, though ).

  4. #4

    Default Re: Konqueror, nspluginviewer and flash 11 beta 1 for 64 bits

    I'm seeing the same crash, but reloading the page does not fix anything for me; nspluginviewer just crashes again. The browser as a whole doesn't crash, though, and closing the crash dialog allows the rest of the page to display without the Flash objects. The new Flash works fine with Firefox, Opera, and even Rekonq.

    It is possible to keep the old version of Flash for Konqueror while using the new one for other browsers. Just put the old libflashplayer.so in a separate directory somewhere (I created one in my home directory), add it to the list of plugin directories in Konqueror, and have Konqueror scan for plugins.

  5. #5
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,093

    Default Re: Konqueror, nspluginviewer and flash 11 beta 1 for 64 bits

    Same experiences here. I usually use konqueror (with firefox as a back-up) and have suffered the same occasional crashing with the 64bit flash beta version. A quick re-fresh usually sorts out the problem.

    I was thinking of going back to the 64bit flashplayer square as I never had any problems but will see how things work out.

  6. #6

    Default Re: Konqueror, nspluginviewer and flash 11 beta 1 for 64 bits

    Newer versions of Firefox work fine with the beta 64 bit Flash 11, but there are lots of flash freezing problems with the Firefox 3.6 line. So I'm thinking that perhaps switching Konqueror from KHTML to webkit, which uses newer technology than KHTML, might help get Flash working. I'd check into that.
    Epox EP-8KRAIPRO AthlonXP3200+ GeForce 6600GT 2GB PC3200 DDR-SDRAM Audigy 2 ZS

  7. #7

    Default Re: Konqueror, nspluginviewer and flash 11 beta 1 for 64 bits

    Quote Originally Posted by dahveed3 View Post
    So I'm thinking that perhaps switching Konqueror from KHTML to webkit, which uses newer technology than KHTML, might help get Flash working. I'd check into that.
    I don't really use Konqueror for web browsing much, so I didn't even know you could do that until I saw your post. I just tried it, and yes, it does fix the problem for me.

  8. #8
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,093

    Default Re: Konqueror, nspluginviewer and flash 11 beta 1 for 64 bits

    Thanks for the tip. I changed the konqueror engine to webkit and the 64 bit flash beta version works much better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •