Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: I cant install rpm files

  1. #1

    Default I cant install rpm files

    Every time I download a rpm file from the web and I try to install it despite it says the installation was succesfull I can't find the program also it's not on yast i tried this command: rpm -qa --last | head but it doesnt show me the program someting is wrong can anyone help me?

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: I cant install rpm files

    One *usually* does not download packages from god knows where to install them, but rather use the package manager and trusted repositories for that - the chance of grabbing an incompatible .rpm is huge.

    Anyway, which .rpm do you try to install? Where did you get it? How did you try to install it?

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,721

    Default Re: I cant install rpm files

    LIke @gropiuskalle, I think also you must definitely provide more factual information. It sounds as if you are downloading and installing RPMs a lot, which is (like gropiuskalle explains) mostly not needed as most software is available on repos.

    And when you post factual information (read: computer text) do so please between CODE tags: Posting in Code Tags - A Guide
    Henk van Velden

  4. #4
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: I cant install rpm files

    To install some "stray" RPM packages put them into a dedicated directory and then enable this directory as an RPM-only repository in yast. I do this sometimes for stuff I packaged myself locally. For everything downloaded from the web the warning from post #2 applies.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  5. #5

    Default Re: I cant install rpm files

    I try to install a game named Toribash.... I also tried it with wine via the opensuse web page and I always get the same result. I double click on the rpm file insert my password and after some seconds it says the installation was successful but then I can't find it....

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,721

    Default Re: I cant install rpm files

    I would try to use the rpm query function to ask what files the RPM should install. But I can't give you the exact command (may be others know a good combination of options by hart) and I do not have an RPM here to test. In any case
    Code:
    man rpm
    contains the needed information (but it may not be easy to understand, thus experiment a bit).
    Henk van Velden

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,721

    Default Re: I cant install rpm files

    Got it. Use
    Code:
    rpm --query --package --filesbypkg <file>.rpm
    where <file>.rpm is of course to be replaced with your file name. It gives al the files that will be (or are allready) installed by the package. Thus you can at least check if they are there. (And when they are there, you have found them )
    Henk van Velden

  8. #8

    Default Re: I cant install rpm files

    Gnome or KDE? If KDE, are you using KPackageKit or Zypper? If KPacakge, then try Zypper. KPackageKit seems to have a lot of problems, not least installing programs but not ACTUALLY installing them. God knows what it thinks it's doing when it says installation complete...
    On a side note, I really don't think avoiding web based .rpm's is particularly useful. I've found repos to be frequently out of date and had to go find the latest .rpm myself to get rid of bugs (I'm referring specifically to the NVidia drivers hosted on opensuse repos).

  9. #9
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: I cant install rpm files

    Toribash will not create any menu entry. You can start it via a terminal

    Code:
    toribash
    ...or create you own menu entry (in KDE → rightclick the K-Menu-button and choose to edit the applications).

  10. #10

    Default Re: I cant install rpm files

    i am sitting here looking at the tar file .It is from 2008
    it's is a bit OLD
    -- on suse 11.3 ---
    first run - errors
    Code:
    ~/Download/toribash-3.50-amd64> ./toribash
    ./toribash: error while loading shared libraries: liblua5.1.so.0: cannot open shared object file: No such file or directory
    newer lua is installed - let's see the normal; easy fix might do it
    Code:
    su -
    ln -s /usr/lib64/liblua.so.5.1 /usr/lib64/liblua5.1.so.0
    let's see
    runs but errors
    Code:
    ~/Download/toribash-3.50-amd64> ./toribash
    failed to load texture data/textures//award_igf
    failed to load texture data/textures//award_pcformat
    failed to load texture data/textures//award_pcgamer
    failed to load texture data/textures//award_sga
    failed to load texture data/textures//award_slamdance
    Unable to retrieve login information
    ok the folder is not in $PATH but the data folder in that file should be seen ?
    no they ARE MISSING and not data/textures folder
    but it runs .



Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •