Results 1 to 8 of 8

Thread: Package conflicts updating KDE SC 4.6.5

  1. #1

    Default Package conflicts updating KDE SC 4.6.5

    openSUSE 11.4, 64 bits, with
    Index of /repositories/KDE:/Release:/46/openSUSE_11.4
    and
    Index of /repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4
    repositories enabled. Since some days, if I go to YaST2 → Package → "Update packages if a new version is available" (I'm translating from Spanish) I get a warning that plasma-addons-4.6.5-9.3.x86_64 needs akonadi-runtime < 1.5.40, but that that requirement cannot be match because there are eliminated providers: akonadi-runtime-1.5.3-91.1.x86_64
    and non instalable providers: akonadi-runtime-1.5.0-3.3.1.x86_64[openSUSE-11.4-11.4-0]
    As "solution" it offers me to not install akonadi-runtime-1.6.0.93.1.x86_64 and libakonadiprotocolinternals1-1.6.0.93.1.x86_64 (which I selected) or to uninstall plasma-addons and kadressbook, which I do not think it is a good idea...
    Someone else have this problem?
    Cheers

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Package conflicts updating KDE SC 4.6.5

    On 07/16/2011 03:06 PM, RGBsuse wrote:
    >
    > Someone else have this problem?


    i'm running KDE 4.6.0 without problems so for now i'm not looking to
    upgrade into problems like you are having...so, i can't answer..

    BUT, i have a question: in your subject i see "KDE SC 4.6.5" and wonder
    what the 'SC' means...can you EIP?

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the BMW® of operating systems!


  3. #3

    Default Re: Package conflicts updating KDE SC 4.6.5

    Quote Originally Posted by DenverD View Post
    BUT, i have a question: in your subject i see "KDE SC 4.6.5" and wonder
    what the 'SC' means...can you EIP?
    SC means "Software Compilation" and was introduced on 4.4
    Repositioning the KDE Brand

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Package conflicts updating KDE SC 4.6.5

    Quote Originally Posted by RGBsuse View Post
    openSUSE 11.4, 64 bits, with
    Index of /repositories/KDE:/Release:/46/openSUSE_11.4
    and
    Index of /repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4
    repositories enabled. Since some days, if I go to YaST2 → Package → "Update packages if a new version is available" (I'm translating from Spanish) I get a warning that plasma-addons-4.6.5-9.3.x86_64 needs akonadi-runtime < 1.5.40, but that that requirement cannot be match because there are eliminated providers: akonadi-runtime-1.5.3-91.1.x86_64
    and non instalable providers: akonadi-runtime-1.5.0-3.3.1.x86_64[openSUSE-11.4-11.4-0]
    As "solution" it offers me to not install akonadi-runtime-1.6.0.93.1.x86_64 and libakonadiprotocolinternals1-1.6.0.93.1.x86_64 (which I selected) or to uninstall plasma-addons and kadressbook, which I do not think it is a good idea...
    Someone else have this problem?
    Cheers
    Let me show you what I had to do:

    Code:
    2011-07-15 17:54:41|install|libakonadiprotocolinternals1|1.5.0-3.3.1|x86_64|root@114-kde.site|repo-oss|b43e32d7ebed1794405e4688eafa23971e9860d4
    2011-07-15 17:54:42|install|kdebase4-workspace-liboxygenstyle|4.6.5-10.2|x86_64||r46|8ab7611c475a34a5ea59dc7a39967c2cd628c1f4b731bbe49dcf11b61d3488c7
    2011-07-15 17:54:43|install|kdebase4-workspace-ksysguardd|4.6.5-10.2|x86_64||r46|36d3cdbe4921629e84f4b07311dc8bf7648256c460e0b4618cbc3b8a0d527bd1
    2011-07-15 17:54:43|install|kde4-kgreeter-plugins|4.6.5-10.2|x86_64||r46|b842f7683804a4c7629631e9ca536680342bfc2a62764f15cb70631a88dec007
    2011-07-15 17:54:44|install|akonadi-runtime|1.5.0-3.3.1|x86_64|root@114-kde.site|repo-oss|409487b90ddef1c5cddada2952af42c1dd354929
    2011-07-15 17:54:45|install|libakonadi4|4.6.5-8.3|x86_64||r46|f90cae914ecb3ba8c126ff43832b294418c90ebf5687fb296e0337d7218a2592
    2011-07-15 17:54:46|install|libkdepimlibs4|4.6.5-8.3|x86_64||r46|5624272659e519bd9bd449618e586ae1e5974506da46ef6d3fa5e2b8c217193f
    2011-07-15 17:54:46|install|libkdepim4|4.4.11.1-3.10|x86_64||r46|8c1febe094a6f7d76e08b1b1756027efba14424675b11595f203bd429059fd5f
    2011-07-15 17:54:49|install|kdepimlibs4|4.6.5-8.3|x86_64||r46|b66f993516986437f9752e3bd9b1470ebe84d7364322773568a93881cdbaa5a2
    2011-07-15 17:54:51|install|kdepim4-runtime|4.4.11.1-3.11|x86_64||r46|5b4a2834f0b6a55f93693cb672cc5d378aca2481e65ae647931b9ca59f0cb7b3
    2011-07-15 17:54:55|install|kdebase4-workspace|4.6.5-10.2|x86_64||r46|6479b0b373e9de0fb429424a145fe29b107e628b67c946220f035b39698bf0bb
    2011-07-15 17:54:58|install|plasma-addons|4.6.0-4.7.1|x86_64|root@114-kde.site|repo-oss|0a7cd58774a5c154158bc57a0b234da6a5556d53
    2011-07-15 17:54:59|install|kwin|4.6.5-10.2|x86_64||r46|5ff3a84adaf4214df287f95dbf3373f1a45fdf39fc11ba7a73ea06f73dcf5b46
    2011-07-15 17:55:00|install|korganizer|4.4.11.1-3.10|x86_64||r46|ca7234cfb7221969f077735552d85411a7f5aea65fd7c456d0a75a9f08413558
    2011-07-15 17:55:01|install|kontact|4.4.11.1-3.10|x86_64||r46|8967e8fca8c50b88d0302cd29644ec38e315f6477f17bc21a6e371708021fe8c
    2011-07-15 17:55:02|install|knotes|4.4.11.1-3.10|x86_64||r46|47aa1187ca7b823136c75662719c5d9439730d5f159c0a79a4b508aa18ae29d3
    # 2011-07-15 17:55:02 kdm-4.6.5-10.2.x86_64.rpm installed ok
    # Additional rpm output:
    # Warning: Do not know how to create missing GreeterUID user kdm
    # Information: reading pre-existing kdmrc /usr/share/kde4/config/kdm/kdmrc (config version 2.4)
    # 
    2011-07-15 17:55:02|install|kdm|4.6.5-10.2|x86_64||r46|0b708acb19fb3fc5124849b99577da7949b84431de8e1ecc5fcc67d15991cae7
    2011-07-15 17:55:04|install|kdepim4|4.4.11.1-3.10|x86_64||r46|88ea872fb9a6672aaf6d54dabf4c356098d3bfb7de1f9aeb17e2a9c26e2f07ea
    2011-07-15 17:55:05|install|akregator|4.4.11.1-3.10|x86_64||r46|6da706a753e7717bec508e3f2a96cec50a14bd5e0db49c4d47750e5ba4ef6678
    2011-07-15 17:55:06|install|kmail|4.4.11.1-3.10|x86_64||r46|21fcf5a634cbdebe355c2b3e1aa3cbd2ff13f12edbd0c695e03a5f66ce200eb8
    2011-07-15 17:55:06|install|kdepim4-wizards|4.4.11.1-3.10|x86_64||r46|c067805e5472bf4c4715e07dd99ed8f83dab1e8c022cf43ecebfcce992059cd2
    2011-07-15 17:55:07|install|kaddressbook|4.4.11.1-3.10|x86_64|root@114-kde.site|r46|e190d2706198079142b08b57e623e835e1f7aa2a0cc06287a664faa1b26b2418
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Package conflicts updating KDE SC 4.6.5

    @caf4926, if I understand your answer right, you have akonadi related packages (including kdepim) from OSS repository (i.e., from KDE SC 4.6.0) while the rest of your KDE packages are from /KDE:/Release:/46/ repo. While this mix of repos could avoid the warning, it do not solve the issue that /KDE:/Release:/46/ repo offers akonadi 1.6 while some packages on the same repo depends upon akonadi 1.5.3.
    Is this a known issue or needs to be reported?

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Package conflicts updating KDE SC 4.6.5

    On 07/16/2011 04:36 PM, RGBsuse wrote:
    >
    > SC means "Software Compilation" and was introduced . . .


    oh IC! do u also use KDE A, KDE c, KDE P, KDE p, KDE PD, KDE PN, aoc KDE W?

    IJWWYUINIKT!

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the BMW® of operating systems!

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Package conflicts updating KDE SC 4.6.5

    Quote Originally Posted by RGBsuse View Post
    @caf4926, if I understand your answer right, you have akonadi related packages (including kdepim) from OSS repository (i.e., from KDE SC 4.6.0) while the rest of your KDE packages are from /KDE:/Release:/46/ repo. While this mix of repos could avoid the warning, it do not solve the issue that /KDE:/Release:/46/ repo offers akonadi 1.6 while some packages on the same repo depends upon akonadi 1.5.3.
    Is this a known issue or needs to be reported?
    Yes
    There is a PIM repo, which enables a switch up from OSS, but korganizer is broken.
    So for now, I have to keep the PIM stuff from OSS
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Package conflicts updating KDE SC 4.6.5


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •