Results 1 to 5 of 5

Thread: Gnome-tweak-tool Trouble

  1. #1
    Join Date
    Mar 2010
    Location
    Muncie, IN
    Posts
    24

    Default Gnome-tweak-tool Trouble

    Hey guys,
    I installed the gnome-tweak-tool to easily switch themes, then installed gnome-shell-extensions to presumably allow theme switching. Still getting the "User theme extension not enabled" thing and don't know how to fix it. Tried 1-click install first, then re-installed both the tweak tool and the extensions through the package manager, still a no-go. Any advice? Thanks!

    3.0.4-1.2 (noarch) gnome-tweak-tool
    3.1.3-13.1 (noarch) gnome-shell-extensions
    openSUSE 11.4

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,677
    Blog Entries
    15

    Default Re: Gnome-tweak-tool Trouble

    Hi
    Are you running factory? The extensions should match the gnome-shell version.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Mar 2010
    Location
    Muncie, IN
    Posts
    24

    Default Re: Gnome-tweak-tool Trouble

    Lol, malcom you're killing it troubleshooting today. Yeah, I think I may have accidentally installed factory.
    Open your source, Open your mind

  4. #4
    Join Date
    Mar 2010
    Location
    Muncie, IN
    Posts
    24

    Default Re: Gnome-tweak-tool Trouble

    Wow, one thing led to another and I just realized I'm running an outdated version of shell (3.0.2-1.1). There's a dependency issue though, apparently the upgrade is being blocked because the package manager can't find libxml2.so.2(LIBXML2_2.4.30)(64bit). Here's what my repos look like:

    # | Alias | Name | Enabled | Refresh
    ---+-------------------------+----------------------------+---------+--------
    1 | GNOME:Backports:Factory | GNOME:Backports:Factory | Yes | Yes
    2 | GNOME:Factory | GNOME:Factory | Yes | Yes
    3 | GNOME:STABLE:3.0 | GNOME:STABLE:3.0 | Yes | Yes
    4 | google-chrome | google-chrome | Yes | Yes
    5 | nVidia Graphics Drivers | nVidia Graphics Drivers | Yes | Yes
    6 | packman | packman | Yes | Yes
    7 | repo-debug | openSUSE-11.4-Debug | No | Yes
    8 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Yes
    9 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes
    10 | repo-oss | openSUSE-11.4-Oss | Yes | Yes
    11 | repo-source | openSUSE-11.4-Source | No | Yes
    12 | repo-update | openSUSE-11.4-Update | Yes | Yes

    Should I disable Factory? It's been a long time since I used SUSE, I can only guess that's a testing repo. Thanks!
    Open your source, Open your mind

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,677
    Blog Entries
    15

    Default Re: Gnome-tweak-tool Trouble

    Hi
    For sure;
    Code:
    zypper rr 1
    zypper rr 2
    Set the priority for 3 (GNOME STABLE 3.0) to 98, then either run screen or logout and drop to run level 3 (ctrl+alt+F1)
    Code:
    zypper dup
    That should set things right...

    More info here openSUSE:GNOME 3.0 - openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •