Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: How to type in Korean

  1. #1

    Question How to type in Korean

    How can i type in Hangul (Korean) in Suse 11.4 ?
    When I select Korean, I can olnly write English

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,430

    Default Re: How to type in Korean

    If you are using KDE, go to System settings>Input devices>Keyboard>Layouts>Add layout and then scroll down the list past Vietnam where you will find Korea. Once the layout is installed a flag will appear in the System tray. Clicking this will cycle through the installed layouts.

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: How to type in Korean

    The easiest way would be to install ibus, ibus-hangul and some Korean fonts.
    Once installed configure ibus to use ibus-hangul and set up some shortcuts to turn it on and off and you should be away.

    If you use the traditional method of installing a second language (yast - languages) you will end up with scim/skim instead of ibus and you will have a world of headaches trying to get scim to work properly.
    ibus is much newer and much easier to work with than scim/skim

  4. #4

    Default Re: How to type in Korean

    I have both scim and ibus , and I see the KOREAN in the panel of GnomeSUSE , but when I typing , It is written English instead of Korean
    For example, I posted this post by Korean layout ! But it is Englsh as you see

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: How to type in Korean

    Quote Originally Posted by fbhello View Post
    I have both scim and ibus , and I see the KOREAN in the panel of GnomeSUSE , but when I typing , It is written English instead of Korean
    For example, I posted this post by Korean layout ! But it is Englsh as you see
    When you say that you see Korean in the panel of Gnome what do you mean. Do you see Korean in Scim or Ibus?

    Sorry - I am not familiar with Gnome so don't really know what you are talking about here - but to type in Korean Ibus or Scim will need to be running as it is these applications that let you select Korean input.

    It is probably not a good idea to have both scim and ibus. I'd remove scim from your system.

    Just installing ibus is not enough - once installed you need to set it up to use an input method (in my case I use Anthy for Japanese input).

    If you have also installed ibus-hangul and libhangul (which you will need to also install if you want to type in Korean) then right click on ibus in your system tray and select preferences.
    Click on the input method tab. There should be a dropdown box to select an input method - (in your case for Korean lib-hangul.) Select and click add.
    As mentionedin my previous post - you then need to select a shortcut to turn ibus hangul off and on to select between English input and Korean input.
    If you do not want to enter a shortcut then when you want to type in Korean simply open up the application that you want to write in and then right click ibus and select hangul input.

  6. #6

    Default Re: How to type in Korean

    I'm really sorry , I'm confused
    pls See this picture which I uploaded .
    in the above has been written Korean but the keyboard is English !
    See here

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: How to type in Korean

    all you have done is specify the layout of the keys on your keyboard - it does not allow you to type in Korean.
    To type in a language other than English on Linux, Mac & Windows an IME (input method editor) is required. In Linux you have the choice of two - the older scim/skim or the newer ibus. You should have one of these installed but not both.
    Once you have installed you need to configure as I have mentioned previously and this will allow you to type in the language of your choice.
    Here are some screenshots of my system


    You can see ibus present in the system tray.


    Here I select that I would like to type in Japanese


    Typing away in Japanese

    If you follow the instructions in my previous post you should be able to do exactly as I do but with Korean/Hangul.

  8. #8
    Join Date
    Jan 2009
    Location
    Seoul South Korea
    Posts
    26

    Default Re: How to type in Korean

    Will you please provide instructions for configuring ibus for korean and setting up the short cut key for openSUSE 11.4. I am currently doing the same things. The SCIM configuration with KDE4 does not work. Are there plans to change openSUSE from SCIM/SKIM to ibus and fix this issue so this can be configured through YaST and KDE4 with ibus? It seems strange to keep old software when there is a newer version that functions properly.

  9. #9

    Default Re: How to type in Korean

    Thanks farcusnz. That was useful to me. Anyone trying to use Scim in openSUSE 11.4, kill it and go with Ibus

  10. #10

    Default Re: How to type in Korean

    Hi, I'm also having trouble getting Korean input to work on my openSUSE 11.4 (64-bit) Gnome desktop.

    From a clean install from the LiveCD I first set Korean as a secondary language in Yast, then removed scim and installed ibus and ibus-hangul. I also tried skipping the Yast method and directly installing ibus and ibus-hangul, but no luck. I can choose Korean as my input in ibus-setup, but I can't switch to it using any of the mapped keys (ctrl-space, hangul key, hanja key, etc.) These are all the ibus packages installed: ibus, ibus-gtk, ibus-hangul, ibus-m17n, ibus-qt, libibus2. These are the hangul packages installed: ibus-hangul, imhangul, imhangul-32bit, libhangul, libhangul-32bit.


    Strangely, I never had this problem with any Fedora version and it worked in openSUSE 11.3. Would some happen to know what's going on and how to get this working again?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •