Results 1 to 3 of 3

Thread: Libre Office problem - Java runtime environment

  1. #1
    Join Date
    Jan 2009
    Location
    Belgium
    Posts
    245

    Default Libre Office problem - Java runtime environment

    Hello,

    This afternoon, I desactivated the IcedTea thing and installed the Java programs + plugin (having had trouble with my banking software - which eventually got resolved thanks to Java).

    I now want to do some spreadsheet work, I want to open Libre Office Calc, but I get this error :

    Code:
    LibreOffice requires a Java runtime environment (JRE) to perform this task.The selected JRE is defected. Please select another version or install a new JRE and select it under Tools-Options-LibreOffice-Java.
    When I verify this I see in the Options box :

    Code:
    Sun Microsystems Inc. version 1.6.0_26
    installed in directory :

    Code:
    /usr/lib64/+jvm/java-1.6.0-sun-1.6.0/jre
    What can I do ?

    W

  2. #2
    PeeGee NNTP User

    Default Re: Libre Office problem - Java runtime environment

    On 10/07/11 14:36, wba wrote:
    >
    > Hello,
    >
    > This afternoon, I desactivated the IcedTea thing and installed the Java
    > programs + plugin (having had trouble with my banking software - which
    > eventually got resolved thanks to Java).
    >
    > I now want to do some spreadsheet work, I want to open Libre Office
    > Calc, but I get this error :
    >
    >
    > Code:
    > --------------------
    > LibreOffice requires a Java runtime environment (JRE) to perform this task.The selected JRE is defected. Please select another version or install a new JRE and select it under Tools-Options-LibreOffice-Java.
    > --------------------
    >
    >
    > When I verify this I see in the Options box :
    >
    >
    > Code:
    > --------------------
    > Sun Microsystems Inc. version 1.6.0_26
    > --------------------
    >
    >
    > installed in directory :
    >
    >
    > Code:
    > --------------------
    > /usr/lib64/+jvm/java-1.6.0-sun-1.6.0/jre
    > --------------------
    >
    >
    > What can I do ?
    >
    > W


    You have selected the Sun JAVA in the options (ie there is a dot in the
    circle to the left of the entry)? When that is done and if you have
    macros, you can de-select "use JAVA runtime" and Calc will load without
    the few seconds "lock-up" (?while JAVA initialises?), but you need to
    answer "No" at every start-up.

    --
    PeeGee

    MSI m/b 870-C45, AMD Athlon II X3 445, 4GB, openSUSE 11.3/11.2 x86_64
    dual boot + XP Home in VBox
    Asus m/b M2NPV-VM, AMD 64X2 3800+, 2GB, openSUSE 11.3 x86_64/XP Home
    dual boot
    Acer Aspire 1350, AMD (M)XP2400+, 768MB, openSUSE 11.4/XP Home dual boot
    Asus eeePC 4G (701), Celeron M353, 2GB, openSUSE 11.3 on SSD

  3. #3
    Join Date
    Jan 2009
    Location
    Belgium
    Posts
    245

    Thumbs up Re: Libre Office problem - Java runtime environment

    Quote Originally Posted by PeeGee View Post
    On 10/07/11 14:36, wba wrote:[color=blue]
    >
    > Hello,
    >[... snip]

    You have selected the Sun JAVA in the options (ie there is a dot in the
    circle to the left of the entry)? When that is done and if you have
    macros, you can de-select "use JAVA runtime" and Calc will load without
    the few seconds "lock-up" (?while JAVA initialises?), but you need to
    answer "No" at every start-up.

    --
    PeeGee

    MSI m/b 870-C45, AMD Athlon II X3 445, 4GB, openSUSE 11.3/11.2 x86_64
    dual boot + XP Home in VBox
    Asus m/b M2NPV-VM, AMD 64X2 3800+, 2GB, openSUSE 11.3 x86_64/XP Home
    dual boot
    Acer Aspire 1350, AMD (M)XP2400+, 768MB, openSUSE 11.4/XP Home dual boot
    Asus eeePC 4G (701), Celeron M353, 2GB, openSUSE 11.3 on SSD
    Thanks for your quick reply.

    You're absolutely right. By putting a dot in the small circle, everything seems to be working by now. How stupid can one be ?
    Thank you very much !

    W

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •