Results 1 to 5 of 5

Thread: can't install window manager?

Hybrid View

  1. #1
    Join Date
    Apr 2010
    Location
    i am location
    Posts
    1,421

    Default can't install window manager?

    I try to install two window manager under openSUSE 11.4 x64.
    AmiWb and WindowLab. I compiled them and there were no errors, but they don't show up in the login menu.
    If i start them by switching ALT-F2 i can't connect to the xserver.
    As far as i can see, it is not in USR/X11 either. Have to check where it ended up in. But in my previous experience in installing a WM i did not have any problems. Very strange. Maybe i did a mistake?
    +++ ATH0

    . . . . . . . .
    LOGOFF COMPLETE

  2. #2

    Default Re: can't install window manager?

    I'd never heard of either of these managers so I hst had to check them out, couldn't even find amiwb with some searches but I did find and download windowlab, haven't tried installing it as I'm booted into windows with some steam downloads goping that I don't wanna interrupt but I did find two things that may be of use to you with a quick look at the files

    From the readme:

    To make WindowLab your default window manager, edit ~/.xinitrc (if you start X from the console by typing "startx") or ~/.xsession (if you start with a graphical login manager) and change the last line to "exec windowlab"

    That one might help you at least get into windowlab

    You said you couldn't find it in usr/x11 and had to check where it ended up, I had a look at the makefile and these are the default directories for where it puts it's files:

    PREFIX = /usr/local
    CONFPREFIX = $(PREFIX)
    CONFDIR = /etc/X11/windowlab
    SYSCONFDIR = $(CONFPREFIX)$(CONFDIR)
    BINDIR = $(DESTDIR)$(PREFIX)/bin
    MANDIR = $(DESTDIR)$(PREFIX)$(MANBASE)/man1
    CFGDIR = $(DESTDIR)$(SYSCONFDIR)

    DESTDIR isn't set anywhere but with PREFIX being /usr/local I can't see what else it could be but /

    So it looks like the file you need to start windowlab is probably in /usr/local/bin


    Hope that helps and here's the full code from the makefile in case it helps you or someone else more knowledgeable make more sense of it than I can


    Code:
    # Makefile for WindowLab
    
    # Comment out to remove shape support (for X11R5 or just a tiny bin)
    DEFINES += -DSHAPE
    EXTRA_LIBS += -lXext
    
    # Set this to the hardcoded location of all files if it's not /
    PREFIX = /usr/local
    
    # Set this to the directory, below PREFIX, where man pages 
    # are expected. Below this directory, the target "install"
    # will put "windowlab.1x" in section "man1".
    MANBASE = /man
    
    # Set this to the location of the X installation you want to compile against
    XROOT = /usr/X11R6
    
    # Some flexibility for configuration location
    CONFPREFIX = $(PREFIX)
    CONFDIR = /etc/X11/windowlab
    
    # Set this to the location of the global configuration files
    SYSCONFDIR = $(CONFPREFIX)$(CONFDIR)
    
    # Information about the location of the menurc file
    ifndef MENURC
    MENURC = $(SYSCONFDIR)/windowlab.menurc
    endif
    
    DEFINES += -DDEF_MENURC="\"$(MENURC)\""
    
    # Uncomment to add MWM hints support
    #DEFINES += -DMWM_HINTS
    
    # Uncomment to add freetype support (requires XFree86 4.0.2 or later)
    # This needs -lXext above, even if you have disabled shape support
    #DEFINES += -DXFT
    #EXTRA_INC += `pkg-config --cflags xft`
    #EXTRA_LIBS += `pkg-config --libs xft`
    
    # Uncomment for debugging info (abandon all hope, ye who enter here)
    #DEFINES += -DDEBUG
    
    # --------------------------------------------------------------------
    
    CC = gcc
    ifndef CFLAGS
    CFLAGS = -g -O2 -Wall -W
    endif
    
    BINDIR = $(DESTDIR)$(PREFIX)/bin
    MANDIR = $(DESTDIR)$(PREFIX)$(MANBASE)/man1
    CFGDIR = $(DESTDIR)$(SYSCONFDIR)
    INCLUDES = -I$(XROOT)/include $(EXTRA_INC)
    LDPATH = -L$(XROOT)/lib
    LIBS = -lX11 $(EXTRA_LIBS)
    
    PROG = windowlab
    MANPAGE = windowlab.1x
    OBJS = main.o events.o client.o new.o manage.o misc.o taskbar.o menufile.o
    HEADERS = windowlab.h
    
    all: $(PROG)
    
    $(PROG): $(OBJS)
    	$(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
    
    $(OBJS): %.o: %.c $(HEADERS)
    	$(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
    
    install: all
    	mkdir -p $(BINDIR) && install -m 755 -s $(PROG) $(BINDIR)
    	mkdir -p $(MANDIR) && install -m 644 $(MANPAGE) $(MANDIR) && gzip -9vfn $(MANDIR)/$(MANPAGE)
    	mkdir -p $(CFGDIR) && cp -i windowlab.menurc $(CFGDIR)/windowlab.menurc && chmod 644 $(CFGDIR)/windowlab.menurc
    
    clean:
    	rm -f $(PROG) $(OBJS)
    
    .PHONY: all install clean

  3. #3
    Join Date
    Apr 2010
    Location
    i am location
    Posts
    1,421

    Default Re: can't install window manager?

    Quote Originally Posted by Ecky View Post
    I'd never heard of either of these managers so I hst had to check them out, couldn't even find amiwb with some searches but I did find and download windowlab, haven't tried installing it as I'm booted into windows with some steam downloads goping that I don't wanna interrupt but I did find two things that may be of use to you with a quick look at the files

    From the readme:

    To make WindowLab your default window manager, edit ~/.xinitrc (if you start X from the console by typing "startx") or ~/.xsession (if you start with a graphical login manager) and change the last line to "exec windowlab"

    That one might help you at least get into windowlab

    You said you couldn't find it in usr/x11 and had to check where it ended up, I had a look at the makefile and these are the default directories for where it puts it's files:

    PREFIX = /usr/local
    CONFPREFIX = $(PREFIX)
    CONFDIR = /etc/X11/windowlab
    SYSCONFDIR = $(CONFPREFIX)$(CONFDIR)
    BINDIR = $(DESTDIR)$(PREFIX)/bin
    MANDIR = $(DESTDIR)$(PREFIX)$(MANBASE)/man1
    CFGDIR = $(DESTDIR)$(SYSCONFDIR)

    DESTDIR isn't set anywhere but with PREFIX being /usr/local I can't see what else it could be but /

    So it looks like the file you need to start windowlab is probably in /usr/local/bin


    Hope that helps and here's the full code from the makefile in case it helps you or someone else more knowledgeable make more sense of it than I can


    Code:
    # Makefile for WindowLab
    
    # Comment out to remove shape support (for X11R5 or just a tiny bin)
    DEFINES += -DSHAPE
    EXTRA_LIBS += -lXext
    
    # Set this to the hardcoded location of all files if it's not /
    PREFIX = /usr/local
    
    # Set this to the directory, below PREFIX, where man pages 
    # are expected. Below this directory, the target "install"
    # will put "windowlab.1x" in section "man1".
    MANBASE = /man
    
    # Set this to the location of the X installation you want to compile against
    XROOT = /usr/X11R6
    
    # Some flexibility for configuration location
    CONFPREFIX = $(PREFIX)
    CONFDIR = /etc/X11/windowlab
    
    # Set this to the location of the global configuration files
    SYSCONFDIR = $(CONFPREFIX)$(CONFDIR)
    
    # Information about the location of the menurc file
    ifndef MENURC
    MENURC = $(SYSCONFDIR)/windowlab.menurc
    endif
    
    DEFINES += -DDEF_MENURC="\"$(MENURC)\""
    
    # Uncomment to add MWM hints support
    #DEFINES += -DMWM_HINTS
    
    # Uncomment to add freetype support (requires XFree86 4.0.2 or later)
    # This needs -lXext above, even if you have disabled shape support
    #DEFINES += -DXFT
    #EXTRA_INC += `pkg-config --cflags xft`
    #EXTRA_LIBS += `pkg-config --libs xft`
    
    # Uncomment for debugging info (abandon all hope, ye who enter here)
    #DEFINES += -DDEBUG
    
    # --------------------------------------------------------------------
    
    CC = gcc
    ifndef CFLAGS
    CFLAGS = -g -O2 -Wall -W
    endif
    
    BINDIR = $(DESTDIR)$(PREFIX)/bin
    MANDIR = $(DESTDIR)$(PREFIX)$(MANBASE)/man1
    CFGDIR = $(DESTDIR)$(SYSCONFDIR)
    INCLUDES = -I$(XROOT)/include $(EXTRA_INC)
    LDPATH = -L$(XROOT)/lib
    LIBS = -lX11 $(EXTRA_LIBS)
    
    PROG = windowlab
    MANPAGE = windowlab.1x
    OBJS = main.o events.o client.o new.o manage.o misc.o taskbar.o menufile.o
    HEADERS = windowlab.h
    
    all: $(PROG)
    
    $(PROG): $(OBJS)
        $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
    
    $(OBJS): %.o: %.c $(HEADERS)
        $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
    
    install: all
        mkdir -p $(BINDIR) && install -m 755 -s $(PROG) $(BINDIR)
        mkdir -p $(MANDIR) && install -m 644 $(MANPAGE) $(MANDIR) && gzip -9vfn $(MANDIR)/$(MANPAGE)
        mkdir -p $(CFGDIR) && cp -i windowlab.menurc $(CFGDIR)/windowlab.menurc && chmod 644 $(CFGDIR)/windowlab.menurc
    
    clean:
        rm -f $(PROG) $(OBJS)
    
    .PHONY: all install clean
    Actually, that was the problem. First the .xinitrc file wasn't there and then it was. Strange. But the problem with this is, you always have that windowmanager. No matter what you select at login.
    But it did eventually work. So it was not a problem because of the compiling. That is what i feared.
    Thanks.
    +++ ATH0

    . . . . . . . .
    LOGOFF COMPLETE

  4. #4
    Taki NNTP User

    Default Re: can't install window manager?

    On 07/08/2011 05:06 PM, JoergJaeger wrote:
    >
    > I try to install two window manager under openSUSE 11.4 x64.
    > AmiWb and WindowLab. I compiled them and there were no errors, but they
    > don't show up in the login menu.

    [...]

    Some window managers 'register' themselves with the login/display
    manager like KDM. Some don't, even if they compile properly.

    Become 'root':
    $ su
    [give 'root' password]
    Then:
    # cd /usr/share/xsessions

    You should see a few entries like 'twm.dekstop', 'kde-plasma.desktop',
    'icewm.desktop'. The simplest way to create' an entry for a window
    manager, I find, is to copy an already-existing entry and edit the copy
    for the new window manager.

    # cp twm.desktop windowlab.desktop
    ['twm' is always installed]

    # vim [or gedit/kate/xemacs] windowlab.desktop.

    The file 'windowlab.desktop' should look like this:

    [Desktop Entry]
    Encoding=UTF-8
    Type=XSession
    Exec=windowlab
    TryExec=windowlab
    Name=WindowLab
    Comment=a small and simple window manager of novel design

    "X-SuSE-translate=true" is in the 'twm.desktop'. I don't know what that
    means; perhaps, it is about packaging for openSUSE.

    "Exec" and "TryExec" point to the executable, in this case,
    '/usr/local/bin/windowlab'. Since '/usr/local/bin' is in the PATH set by
    openSUSE, 'windowlab' is enough'. I'm guessing that 'TryExec' is for a
    possible alternate location for the executable.

    "Name" can be anything. This is what appears on the KDM screen. So long
    as you know which window manager it refers to, it can be 'windowlab',
    'WindowLab', 'winlab', 'my_installed_wm'.

    "Comment" seems optional.

    The next time you log out, a new entry should be visible among the
    choices for KDM.

  5. #5
    Join Date
    Apr 2010
    Location
    i am location
    Posts
    1,421

    Default Re: can't install window manager?

    Quote Originally Posted by Taki View Post
    On 07/08/2011 05:06 PM, JoergJaeger wrote:
    >
    > I try to install two window manager under openSUSE 11.4 x64.
    > AmiWb and WindowLab. I compiled them and there were no errors, but they
    > don't show up in the login menu.

    [...]

    Some window managers 'register' themselves with the login/display
    manager like KDM. Some don't, even if they compile properly.

    Become 'root':
    $ su
    [give 'root' password]
    Then:
    # cd /usr/share/xsessions

    You should see a few entries like 'twm.dekstop', 'kde-plasma.desktop',
    'icewm.desktop'. The simplest way to create' an entry for a window
    manager, I find, is to copy an already-existing entry and edit the copy
    for the new window manager.

    # cp twm.desktop windowlab.desktop
    ['twm' is always installed]

    # vim [or gedit/kate/xemacs] windowlab.desktop.

    The file 'windowlab.desktop' should look like this:

    [Desktop Entry]
    Encoding=UTF-8
    Type=XSession
    Exec=windowlab
    TryExec=windowlab
    Name=WindowLab
    Comment=a small and simple window manager of novel design

    "X-SuSE-translate=true" is in the 'twm.desktop'. I don't know what that
    means; perhaps, it is about packaging for openSUSE.

    "Exec" and "TryExec" point to the executable, in this case,
    '/usr/local/bin/windowlab'. Since '/usr/local/bin' is in the PATH set by
    openSUSE, 'windowlab' is enough'. I'm guessing that 'TryExec' is for a
    possible alternate location for the executable.

    "Name" can be anything. This is what appears on the KDM screen. So long
    as you know which window manager it refers to, it can be 'windowlab',
    'WindowLab', 'winlab', 'my_installed_wm'.

    "Comment" seems optional.

    The next time you log out, a new entry should be visible among the
    choices for KDM.
    This is good plan. Because i noticed that it did not write in to the menu. I think this is a better approach than with the .xinitrc file. I have to write that down (scrible).
    Still have one windowmanager to test > Amiwm.
    I think i learned again something valuebale. Thanks guys.
    +++ ATH0

    . . . . . . . .
    LOGOFF COMPLETE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •