Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Booting skipped runlevel 5 on KDE

  1. #1

    Default Booting skipped runlevel 5 on KDE

    After successful upgrading from 11.3 to 11.4 I had to install ATI driver from here Index of /mirror/ati/openSUSE_11.4 and delete the old ones.
    After rebooting the system entered in runlevel 5 where I received kwin error which I couldn't back-trace with the tools, but it was working. When I have made an on-line update and rebooted again it went to runlevel 3 without showing any error.
    When I type startx it shows error, but when I enter as root KDE starts normally and it's functional.
    Can somebody advise me how to get to the KDE with my account, but not as a root user ?

  2. #2

    Default Re: Booting skipped runlevel 5 on KDE

    Quote Originally Posted by terziyski View Post
    When I type startx it shows error, but when I enter as root KDE starts normally and it's functional.
    It would make it easier for people to help if you posted what the error actually says rather than just saying it shows error with no info about what that error is, generally speaking mate it's always good to give as much info as you can when asking for help.

    Do you know whether the kernel and/or the ati driver got updated when you ran online update?

    Something that may help is when you're in runlevel 3 try running this command as root: aticonfig --initial, after running it reboot your machine by (still as root) typing: reboot (you could log out as root, log back in as another user and then startx, but probably quicker and easier to just reboot)

    Oh btw, a lot of people would say it's a bad idea to log into kde (or any other desktop environment) as root, it's possible to break your system by doing that so to be on the safe side it's best to avoid doing it

  3. #3

    Default Re: Booting skipped runlevel 5 on KDE

    Thanks for the answer,
    Yes I had kernel upgraded when the problem showed up. The error message was something like : Can't move the file /var/log/Xorg.0.log to /var/log/Xorg.0.log.old and asked me to look at the /etc/permissions.local to solve this. Maybe if you tell me which log files you are interested in I can send their content.

  4. #4

    Default Re: Booting skipped runlevel 5 on KDE

    If you installed the ati driver through yast and still have the repository enabled it usually works ok after a kernel upgrade, maybe you don't have the linux kernel-source package installed, check for that and I would also check for gcc & gcc-c++

    You might have to reinstall the ati driver after installing the above packages if you didn't already have them

    You also haven't mentioned whether you tried running aticonfig --initial

  5. #5

    Default Re: Booting skipped runlevel 5 on KDE

    Hi,

    I have installed the driver through yast and repository is enabled, I haven't started 'aticonfig --initial' (used these instructions - openSUSE Lizards - Next ati recommend to use ati –initial-config but that break the auto-detect stack of xorg. So I recommend changing one line in file /etc/X11/xorg.conf.d/50-device.conf
    just change driver line to driver “fglrx”
    All the rest of the setup (double screen etc) will be made lately with the ati catalyst control center (command is amdcccle).)

    I haven't had only gcc-c++ installed.

  6. #6

    Default Re: Booting skipped runlevel 5 on KDE

    As you seem to have the driver installed you probably have the dependencies too

    But all you've told us there is what it says on the opensuse lizards page, not what you've actually done

    Have you for example changed the driver in 50-device.conf to fglrx, have you blacklisted the driver "radeon" (I've never had to blacklist the radeon driver btw)

    As for the command: ati –initial-config

    I've never heard of it, I suspect the author meant aticonfig --initial (I could of course be wrong but I think if there was an ati –initial-config way to do it I would have come across it before now)


    There are two ways to configure xorg - the 'old way' using /etc/X11/xorg.conf and the 'new way' using conf files found under /etc/X11/xorg.conf.d/ such as 50-device.conf, if you are sure you are using the fglrx driver then the 'auto-detect stack of xorg' isn't working for you, it's meant to auto-detect the best resolution for your graphics card/monitor combination ... but you can't even start X so there's obviously something wrong

    The curious thing though is that on opensuse lizards it's telling you not to use xorg.conf, then it tells you to use ati catalyst control center, guess what ati control center does? It creates an xorg.conf file and if an xorg.conf file exists the system will use it

    There's something else that comes with the ati driver which makes an xorg.conf for you, that something is ... aticonfig --initial


    For some people just installing the driver and letting things auto-detect just works which is great, but when it doesn't and you can't start kde then the recommended thing to do (and not only ati themselves recommend this), is run aticonfig --initial

    We have two machines here with ati cards, one a hd5770 the other a hd6870, both work fine and were configured by installing the driver and then running aticonfig --initial, and further tweaks such as dual monitors by either editing xorg.conf directly or using the catalyst control centre

  7. #7

    Default Re: Booting skipped runlevel 5 on KDE

    Hi Ecky,

    I want to thank you for your comprehensive answer at first.

    This file is as it was:
    cat /etc/modprobe.d/50-fglrx.conf
    blacklist radeon

    I have change the following :
    cat /etc/X11/xorg.conf.d/50-device.conf
    Section "Device"
    Identifier "Default Device"

    Driver "fglrx"

    ## Required magic for radeon/radeonhd drivers; output name
    ## (here: "DVI-0") can be figured out via 'xrandr -q'
    #Option "monitor-DVI-0" "Default Monitor"

    My card is Radeon HD 2600Pro AGP.
    This manual was the first I saw when searched for installing new ATI driver for upgraded version of OpenSuSE and that's why I followed it.
    Obviously I have to execute 'aticonfig --initial' command.
    The thing is that I have distant access to this machine via SSH till Wednesday. Can I execute the command via SSH and check the 'startx' result when I am on site ?

  8. #8

    Default Re: Booting skipped runlevel 5 on KDE

    Yeah that should be ok mate

    But if you're not gonna startx until you're physically at the machine might as well do it then

  9. #9

    Default Re: Booting skipped runlevel 5 on KDE

    Thanks Ecky, I'll keep you posted about the issue.

  10. #10

    Default Re: Booting skipped runlevel 5 on KDE

    Hi Ecky, after executing 'aticonfig --initial' (Said it was going to use Xorg.0.conf and backed it up) and the result is the same - stopping at runlevel 3 with the same error:
    cat .xsession-errors
    xauth: file /home/ivo/.serverauth.5653 does not exist
    xauth: (stdin):2: unknown command "af3d1d80002a41c04ed97ed8a8ec51ad"

    Again I am able to start KDE using my root account.
    Any other suggestions ?
    Fatal server error:
    Cannot move old log file "/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old"


    Please consult the The X.Org Foundation support
    at X.Org Wiki - Home
    for help.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •