Results 1 to 9 of 9

Thread: Gnome 3 Cursor Theme

  1. #1

    Angry Gnome 3 Cursor Theme

    I installed Gnome 3 on my openSUSE 11.4 install. The cursor goes from white to black like it did in Gnome 2 before I edited etc/sysconfig in Yast. Well I have gotten gnome-tweak-tool and edited sysconfig to use Adwaita and the cursor is still black on firefox white in other areas.

  2. #2
    Join Date
    May 2011
    Derbyshire, United Kingdom

    Default Re: Gnome 3 Cursor Theme

    I had the exact same problem, however I found that it went away once i changed the cursor theme to DMZ in Gnome Tweak Tool

    Hope this helps.


    Desktop: OpenSUSE 11.4 | Dell Optiplex GX620 | 3GB RAM | Pentium D 820 2.8 Ghz | 40GB Internal, 250GB External | nVidia GeForce G210

    Netbook: OpenSUSE 11.4 | HP Mini 5101 1366x768 model | Intel Atom N280 | 2GB RAM | 250GB Internal | Intel GMA950

  3. #3

    Default Re: Gnome 3 Cursor Theme

    This seems to work for the session but as soon as I reboot it goes back to white and black.

  4. #4

    Default Re: Gnome 3 Cursor Theme

    does anyone know any other openSuse specific settings files I can check to hard code it?

  5. #5

    Default Re: Gnome 3 Cursor Theme

    Hi Guys,

    I fixed this issue on the hardest way.

    I figured out that Gnome 3 uses black cursor theme by default. So, I reinstalled openSUSE and set black mouse pointer in Gnome 2.x. After that, I installed Gnome 3 and now my cursor is permanently black.


  6. #6

    Default Re: Gnome 3 Cursor Theme

    I have narrowed this down to a user setting, if I log in as root (!) the cursor themes are fine, I just now need to know what file in my home directory sets the cursor.

  7. #7

    Default Re: Gnome 3 Cursor Theme

    Hi all, i don't have a good english, but i try to explain the solution to this problem.

    I have the same problem, when i install a cursor theme it's only appear when i'm on Firefox. I solved it on my ArchLinux creating the folder .icons on my home, extracting the .tar.gz theme on it, and changing the name to "default" for example: The theme "Ecliz-Arch" changes its name into "default" and puts here: /home/user/.icons/default

    Now i'm going to try the same to the root user in /root/.icons/default but i'm not sure about this. I just see this issue on internet and i want to help everyone.

  8. #8

    Default Re: Gnome 3 Cursor Theme

    I tried that still a no go.

  9. #9
    Join Date
    Nov 2011
    Sofia, Bulgaria

    Default Re: Gnome 3 Cursor Theme

    Have similar problem and find a solution from some guy's blog - i try it and it's work like a charm!

    make a directory named "default" in /usr/share/icons
    # mkdir /usr/share/icons/default
    make new file named "index.theme"
    # nano -w index.theme :
    put inside new created file index.theme the next 2 rows:

    [Icon Theme]

    that's it - hope will work for you or people with similar problems :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts