Results 1 to 5 of 5

Thread: PackageKit patch question

  1. #1

    Default PackageKit patch question

    I'm running SuSE 11.4. The latest updates involve a conflict with PackageKit-gstreamer. This is the warning that I can't decide how to resolve:

    PackageKit-gstreamer-plugin-0.6.14-0.2.1.x86_64 obsoletes opensuse-codecs-installer.

    Then I'm presented with these:

    ° Deinstallation of PackageKit-gstreamer-plugin-0.6.14-0.2.1.x86_64
    ° Downgrade opensuse-codecs-installer-10.3.1-148.1.noarch to PackageKit-gstreamer-plugin-0.6.14
    ° Do not install patch softwaremgmt-201105-4608.noarch


    I don't know what to do. I'm sure I need the latest gstreamer package so that I can play my DVD's and music. If I downgrade it, then I might have problems later with K3B and my other media software, right?
    Why are such conflicting patches offered? Aren't patches important?

    I also have a screenshot if you need to see it.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,872
    Blog Entries
    3

    Default Re: PackageKit patch question

    In my experience with this sort of situation, you are better off going to Yast online update. That presents the options more clearly, and should make it easier to decide.

    I have not run into the particular problem that you are reporting.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: PackageKit patch question

    YaST Online Update is where this came from.

    Do you have both opensuse-codecs-installer and PackageKit-gstreamer-plugin? Are they from the same repo or different ones?

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,872
    Blog Entries
    3

    Default Re: PackageKit patch question

    I have "PackageKit-gstreamer-plugin", which comes from "Updates-for-openSUSE-11.4-11.4-0".

    It seems that I don't have "opensuse-codecs-installer" installed.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: PackageKit patch question

    It seems that I don't have "opensuse-codecs-installer" installed.
    Neither do I
    Because it was removed by some earlier updates
    Try removing it Bobbie and see if that solves the issue
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •