Results 1 to 8 of 8

Thread: System policies prevent you from getting the brightness level (KDE)

  1. #1

    Default System policies prevent you from getting the brightness level (KDE)

    Does anyone know how to (permanently) get rid of this?


    As you might have guessed, typing the root password and pressing OK has no effect.
    This is NOT a laptop!

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: System policies prevent you from getting the brightness level(KDE)

    On 06/25/2011 06:06 PM, please try again wrote:
    >
    > Does anyone know how to (permanently) get rid of this?
    > [image:
    > http://img715.imageshack.us/img715/5...cykit1kde.png]
    >
    >
    > As you might have guessed, typing the root password and pressing OK has
    > no effect.
    > This is NOT a laptop!


    i see in Personal Settings - Configure Desktop > System Administration >
    Actions Policy > org.kde > powerdevil > KDE > Get Brightness (and also
    Set Brightness)

    if i click on "Get Brightness" it asks for a root password and then show
    me my settings:

    Any - No
    Inactive console - No
    Active console - Yes

    and in the "Local authorizations" i see
    "org.kde.powerdevil.backlighthelper.brightness *group has the following
    policy: 'yes' on inactive console, 'yes' on any console,"

    now, i have NO idea what you should do, but i know with my brightness
    settings (which i've not messed with that i know of) i have never seen
    your error..

    if you wanna change to no, no, yes its ok by me, but i'd suggest you
    click on the "Help" button in the lower left corner, AND read my caveat
    first!

    btw, mine is a netbook if that means anything..

    btw2, maybe your monitor has a sensor to determine and auto-adjust your
    backlighting according to room illumination..

    --
    DD
    -Caveat-Hardware-Software-

    25 June: Sunrise 4:38 AM, Sunset 10:12 PM

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: System policies prevent you from getting the brightness level (KDE)

    There is an upstream bug report for this, you may want to comment on it
    https://bugs.kde.org/show_bug.cgi?id=269310
    I do not know a solution or a workaround so far.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.4 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.4 | nVidia
    ION | 3GB Ram

  4. #4

    Default Re: System policies prevent you from getting the brightness level(KDE)

    Quote Originally Posted by DenverD View Post

    i see in Personal Settings - Configure Desktop > System Administration >
    Actions Policy > org.kde > powerdevil > KDE > Get Brightness (and also
    Set Brightness)

    if i click on "Get Brightness" it asks for a root password and then show
    me my settings:

    Any - No
    Inactive console - No
    Active console - Yes
    Same thing here (even if I press Cancel at this warning)

    I might have tried to disable powerdevil (or even succeeded) but I cannot remember where.

    Quote Originally Posted by DenverD View Post
    and in the "Local authorizations" i see
    "org.kde.powerdevil.backlighthelper.brightness *group has the following
    policy: 'yes' on inactive console, 'yes' on any console,"
    I can not find "Local authorizations". (?)


    Quote Originally Posted by DenverD View Post
    now, i have NO idea what you should do, but i know with my brightness
    settings (which i've not messed with that i know of) i have never seen
    your error..
    Yes ... I see errors that only few people get to see ... I must be one out of 6 (as my wife always says). But I have this error on any machine on which I installed 11.4 - just saw it on another monitor around here.

    Quote Originally Posted by DenverD View Post
    if you wanna change to no, no, yes its ok by me, but i'd suggest you
    click on the "Help" button in the lower left corner, AND read my caveat
    first!
    I read your caveat already out of curiosity, as did probably everyone here at least once.

  5. #5

    Default Re: System policies prevent you from getting the brightness level (KDE)

    Quote Originally Posted by martin_helm View Post
    There is an upstream bug report for this, you may want to comment on it
    https://bugs.kde.org/show_bug.cgi?id=269310
    I do not know a solution or a workaround so far.
    Yes, I found that while looking for an answer. I have to do some more testing. Maybe it is related to the way I usually start kde and X in general (from startx). I have to wait and see if it also happens when the session is started from kdm or gdm. I believe I'm missing something.

  6. #6

    Default Re: System policies prevent you from getting the brightness level (KDE)

    I have the same problem with my OpenSUSE 11.4 using KDE 4.6 on a laptop with an nVidia GPU. It turns out this is a wider known bug, with a known solution: "https://bugzilla.novell.com/show_bug.cgi?id=688267"

  7. #7
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    408

    Default Re: System policies prevent you from getting the brightness level (KDE)

    I have this window each time i switch from a graphic user session to another (ctl+alt+f7 <-> ctl+alt+f8) .

  8. #8

    Default Re: System policies prevent you from getting the brightness level (KDE)

    Actually I don't have laptops and I'm quite sure - after using KDE for a while on several computers - that it happens only (for me) when I start KDE directly from console (startx) without a session manager (xdm,gdm,kdm) and even, I guess, whenever I start KDE from console without having started it before from a session manager. In any case, it is definitely a polkit issue. I'll try this hack asap.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •