Results 1 to 7 of 7

Thread: Mozilla Seamonkey 2.1 update

  1. #1
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    145

    Default Mozilla Seamonkey 2.1 update

    Today I did the Seamonkey 2.1 update. I found out that some of the add-ons or extensions did not work. They were disabled, due to incompatible versions. I found out a simple solution. I hope this helps some.
    This helped me with the Webdeveloper, fxif and Novell Moonlight extensions.

    In the file install.rdf is an element called MaxVersion. Change this to 2.1.* and the extensions work again.

    The file install.rdf is to be found in ~/.mozilla/seamonkey/user-thingies.default/extensions/{extensioncode}
    The changed code for Moonlight looks like this:
    Code:
          <Description>
            <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
            <em:minVersion>2.0b1</em:minVersion>
            <em:maxVersion>2.1.*</em:maxVersion>
          </Description>
    Good luck if you are a Seamonkey user.

  2. #2
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Mozilla Seamonkey 2.1 update

    Although I've seen that fix in the MozillaZine forum, I have never used it.

    I just may try it out. I do miss the Webdeveloper extension.

    Thanks!
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    145

    Default Re: Mozilla Seamonkey 2.1 update

    I missed Webdeveloper also. I may have read the solution within the Mozilla reported bugs. But that doesn't matter for the solution. Just to help you any further. Some (also webdeveloper) have these codes between accolades. Mine is {c45c406e-ab73-11d8-be73-000a95be3b12}. I don't know if the number is standard. But I found the appropriate extensions by clicking the 'chrome' directory. There I found a webdeveloper.jar file, so I knew I was at the right location.
    The part with the Seamonkey version in the install.rdf file is where MaxVersion has something with 2.1.b1 of 2.0.*
    My new code is:
    Code:
        <em:targetApplication>
          <Description>
            <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
            <em:maxVersion>2.1.*</em:maxVersion>
            <em:minVersion>1.0</em:minVersion>
          </Description>
        </em:targetApplication>
    I hope this helps you.

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Mozilla Seamonkey 2.1 update

    This approach would mean that i will have to tweak all the addons which are not compatible

    I use "scripty add on" by using add-on-compatibility-reporter to disable all add on version checks

    https://addons.mozilla.org/en-US/sea...lity-reporter/
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Mozilla Seamonkey 2.1 update

    I also found that instead of using moonlight as a browser add on(will load huge amount of moonlight code and make browser sluggish),i will turn it into a plug by installing it from the repo
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    145

    Default Re: Mozilla Seamonkey 2.1 update

    I added the Add-on Compatibility Reporter, thanks for the advise.

  7. #7
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Mozilla Seamonkey 2.1 update

    Quote Originally Posted by Max_23 View Post
    I added the Add-on Compatibility Reporter, thanks for the advise.
    I also find that you can use scriptish(with assistance of Add-on Compatibility Reporte) instead of greasemonkey as greasemonkey doesn't seem to work in seamonkey 2.1
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •