Results 1 to 7 of 7

Thread: Removed gnome-games-* 4 times AND Updater wants to update locked packages

  1. #1
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Thumbs down Removed gnome-games-* 4 times AND Updater wants to update locked packages

    I have uninstalled the gnome-games-recommended FOUR times and yet it keeps re-installing that package.
    I have removed the package 4 times and each time I verify the lock, it is locked.

    Firefox and Thunderbird are LOCKED also and I still get prompted to "update" via Software Update applet.
    I added gnome-games-recommended manually today via "sudo zypper al gnome-games-recommended"

    sudo zypper ll
    Code:
    # | Name                    | Type    | Repository
    --+-------------------------+---------+-----------
    1 | MozillaThunderbird      | package | (any)     
    2 | MozillaFirefox          | package | (any)     
    3 | gnome-games-recommended | package | (any)
    If I go into Software Manager and find these packages and right click the only option I have is Unlock | Select All | Show Column

    It's getting very old.

    Any advice/suggestions?
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  2. #2
    josephkk NNTP User

    Default Re: Removed gnome-games-* 4 times AND Updater wants to update locked packages

    On Mon, 04 Jul 2011 14:06:03 GMT, Habitual
    <Habitual@no-mx.forums.opensuse.org> wrote:

    >
    >I have uninstalled the gnome-games-recommended FOUR times and yet it
    >keeps re-installing that package.
    >I have removed the package 4 times and each time I verify the lock, it
    >is locked.
    >
    >Firefox and Thunderbird are LOCKED also and I still get prompted to
    >"update" via Software Update applet.
    >I added gnome-games-recommended manually today via "sudo zypper al
    >gnome-games-recommended"
    >
    >sudo zypper ll
    >
    >Code:
    >--------------------
    >
    > # | Name | Type | Repository
    > --+-------------------------+---------+-----------
    > 1 | MozillaThunderbird | package | (any)
    > 2 | MozillaFirefox | package | (any)
    > 3 | gnome-games-recommended | package | (any)
    >
    >--------------------
    >
    >
    >If I go into Software Manager and find these packages and right click
    >the only option I have is Unlock | Select All | Show Column
    >
    >It's getting very old.
    >
    >Any advice/suggestions?


    Sounds like time for a bug report to me.

  3. #3
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Removed gnome-games-* 4 times AND Updater wants to update locked packages

    I am still not sure that it is a bug. I have narrowed it down to the installation of one of my favorite non-OpenSUSE application, TaskCoach.

    I downloaded the Fedora package from Task Coach previously and installed it.
    I de-installed it and installed the OpenSUSE version and the games are installed. Arg!

    I have fired off an email to the taskcoach-subscribe@yahoogroups.com user mailing list about it.
    and why the install removed the lock on gnome-games-support

    To be continued...
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,079

    Default Re: Removed gnome-games-* 4 times AND Updater wants to updatelocked packages

    On Wed, 13 Jul 2011 02:36:03 +0000, Habitual wrote:

    > I am still not sure that it is a bug. I have narrowed it down to the
    > installation of one of my favorite non-OpenSUSE application, TaskCoach.


    Packagekit (which is what the updater users) apparently has a known issue
    with this - it apparently doesn't know that a package that's been
    uninstalled should not be reinstalled, even if it's locked out.

    I remember reading something to this effect in other posts here - you
    might search on packagekit to see what turns up.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Removed gnome-games-* 4 times AND Updater wants to updatelocked packages

    Thanks Jim:

    Well this is getting curious'er and curious'er

    The author says "Task Coach only depends on Python and python-wxGTK. Could the culprit be wxGTK" but (after several installs)
    Code:
    --+------------------------+----------------------------------------------+--------
    i | python-wxWidgets       | Python Bindings for wxWidgets                | package
      | python-wxWidgets-devel | Everything needed for development with wxGTK | package
    i | python-wxWidgets-lang  | Languages for package python-wxWidgets       | package
    and manually installing the rpm:
    Code:
    rpm -ivh /home/jj/Downloads/taskcoach-1.2.23-1.opensuse.i386.rpm
    Preparing...                ########################################### [100%]
       1:taskcoach              ########################################### [100%]
    no games.

    I deleted taskcoach via yast and installed as I have in the past, using right mouse click > "Open with Install/Remove Software" and we have the games back.

    Certainly seems like PackageKit is the culprit?

    Work Around: Leave the silly games installed, or install via c-li

    I do love OpenSUSE but this is more of an annoyance more than anything else and your previous post suggests that it is a known issue.
    So I guess I will live with it.

    Another annoyance:
    zypper ll
    Code:
    # | Name                    | Type    | Repository
    --+-------------------------+---------+-----------
    1 | MozillaThunderbird      | package | (any)     
    2 | MozillaFirefox          | package | (any)     
    3 | gnome-games-recommended | package | (any)     
    4 | gnome-games-support     | package | (any)
    but # zypper in gnome-games-support allows me to install?


    Thanks for your time.
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,079

    Default Re: Removed gnome-games-* 4 times AND Updater wants to updatelocked packages

    On Wed, 13 Jul 2011 15:36:03 +0000, Habitual wrote:

    > Certainly -seems like PackageKit is the culprit-?


    Fits the pattern from the other posts reporting the issue.

    > Work Around: Leave the silly games installed, or install via c-li


    Or use YaST - I don't believe that uses PackageKit.

    > Another annoyance:
    > zypper ll
    >
    > Code:
    > --------------------
    > # | Name | Type | Repository
    > --+-------------------------+---------+----------- 1 |
    > MozillaThunderbird | package | (any) 2 | MozillaFirefox
    > | package | (any) 3 | gnome-games-recommended | package | (any) 4 |
    > gnome-games-support | package | (any)
    > --------------------
    >
    >
    > but # zypper in gnome-games-support allows me to install?


    Yes, zypper won't install it unless you ask it to (directly or by
    installing something that requires it), but it won't automatically
    install it unless you ask it to.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Removed gnome-games-* 4 times AND Updater wants to updatelocked packages

    Quote Originally Posted by hendersj View Post
    ...Yes, zypper won't install it unless you ask it to (directly or by
    installing something that requires it), but it won't automatically
    install it unless you ask it to.
    Roger that Jim. Thanks!
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •