Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: X Error: GLXBad

  1. #1
    Join Date
    Feb 2010
    Location
    Vancouver, Canada
    Posts
    23

    Default X Error: GLXBad

    Hello all,
    Any one has experienced the message attached below when running a software? Any hint in how to resolve this issue?
    Thanks in advance



    X Error: GLXBadContextTag 173
    Extension: 154 (Uknown extension)
    Minor opcode: 5 (Unknown request)
    Resource id: 0x460026e
    X Error: GLXBadContextTag 173
    Extension: 154 (Uknown extension)
    Minor opcode: 1 (Unknown request)
    Resource id: 0x9a0005
    X Error: GLXBadContextTag 173
    Extension: 154 (Uknown extension)
    Minor opcode: 117 (Unknown request)
    Resource id: 0x9a0005

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: X Error: GLXBad

    Try again telling us what you are doing when this happens....

    Because your first comment: when running a software

    Doesn't make much sense
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Feb 2010
    Location
    Vancouver, Canada
    Posts
    23

    Default Re: X Error: GLXBad

    Thanks for responding. It happens when I run OpenFoam, a fluid flow software. A graphic interface is loaded and when I try to display some variables on a graphic, theses messages pop up and the graphic interface freezes. I have to Ctrl C to get out of the interface and the software. I have a laptop Thinkpad Duo T9600 with VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650. I am running OpenSuse 11.4_x64. Let me know if you need something else ...thanks a lot

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: X Error: GLXBad

    OK
    So did you follow any advice here
    SuSE-RPM Pack Installation

    Did you install via the science repo?

    I can't say I really understand the problem, I'm just thinking of possibilities.

    Disable desktop effects is always a good place to start too
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: X Error: GLXBad

    Since you get an OpenGL error, can you tell us which graphics driver you
    use? The output of
    Code:
    glxinfo | grep OpenGL
    can help to identify the opengl version in use. Please post the complete
    output in code tags.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.4 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.4 | nVidia
    ION | 3GB Ram

  6. #6
    Join Date
    Feb 2010
    Location
    Vancouver, Canada
    Posts
    23

    Default Re: X Error: GLXBad

    @caf4926: Yes, I followed that link. The installation went fine.
    @Martin: here is the output:

    OpenGL vendor string: Mesa Project
    OpenGL renderer string: Software Rasterizer
    OpenGL version string: 1.4 (2.1 Mesa 7.10)
    OpenGL extensions:

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: X Error: GLXBad

    Fennec wrote:

    >
    > @caf4926: Yes, I followed that link. The installation went fine.
    > @Martin: here is the output:
    >
    > OpenGL vendor string: Mesa Project
    > OpenGL renderer string: Software Rasterizer
    > OpenGL version string: 1.4 (2.1 Mesa 7.10)
    > OpenGL extensions:
    >

    This is of course only a guess, but it seems your OpenGL version is simply
    insufficient for what the software wants to do. Is it an option for you to
    to install the proprietary ATI driver to get full 3D support for your
    hardware?
    The error (Uknown extension) indicates that the software needs opengl
    context with more features than your default driver (radeon I guess)
    provides.


    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.4 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.4 | nVidia
    ION | 3GB Ram

  8. #8
    Join Date
    Feb 2010
    Location
    Vancouver, Canada
    Posts
    23

    Default Re: X Error: GLXBad

    Thanks Martin. Actually, I tried to install the FGLRX driver and went through all sort of problems with my X unable to start, as described in SDB:ATI troubleshooting - openSUSE ... (you can read my threads in boot/installation). Is there another efficient compatible driver out there ?

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: X Error: GLXBad

    Fennec wrote:
    > Is there another efficient compatible
    > driver out there ?
    >

    I do not know, since I did not use ATI with linux for about 6 years now. Can
    you check which driver you use now (vesa, radeon, radeonhd)? If radeonhd is
    in use now radeon may be better for your card or exactly the other way
    around, I am afraid you can only find out by try and error.
    Just as a side note, I use several scientific applications myself and use
    VTK myself (I mention it because it seems to be used by openfoam) for
    visualisations and also do 3D programming with plain OpenGL and gave up on
    ATI in 2005 because of all the trouble I had as a user and a programmer with
    drivers working some time and sometimes not.

    I see you have several threads about updating openSUSE and the one about
    fglrx. To be honest I think your best option is to backup everything and do
    a clean install with 11.4 and try the catalyst 11.6 driver. Sorry for not
    having a better idea.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.4 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.4 | nVidia
    ION | 3GB Ram

  10. #10
    Join Date
    Feb 2010
    Location
    Vancouver, Canada
    Posts
    23

    Default Re: X Error: GLXBad

    Thanks Martin for your advice, I am using Radeon. Actually, I don't know if a fresh install would resolve the issue. I remember installing opensuse 11.3 and I had exactly the same error message with this software. I ll do some tests and keep you posted.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •