Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Can't install LXDE/YaST2 isn't responding.

  1. #1

    Default Can't install LXDE/YaST2 isn't responding.

    Hi, it's me again, from the thread where I asked how to improve my computer's speed.

    But I have a problem. Whenever I tried to install LXDE using the 1-click install, YaST2 just freezes and doesn't respond and doesn't install anything. In fact, YaST2 always freezes whenever trying to install a program with the 1-click install.

    So my question is, How do you abort YaST2 from installing because obviously the Abort button doesn't even work!
    And lastly, how can I install LXDE through the terminal as I always never have a problem installing something through the terminal.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,549
    Blog Entries
    37

    Default Re: Can't install LXDE/YaST2 isn't responding.

    Quote Originally Posted by Krankles View Post
    And lastly, how can I install LXDE through the terminal as I always never have a problem installing something through the terminal.
    If you are installing LXDE from the LXDE liveCD from a text mode, then you can follow the guidance here: Text mode install from liveCD

    The LXDE liveCD is here: Index of /repositories/X11:/lxde/images/iso

  3. #3

    Default Re: Can't install LXDE/YaST2 isn't responding.

    No, I'm not installing LXDE from a liveCD, I just went to openSUSE and searched for LXDE software.opensuse.org: Search Results and then I clicked 1-click install.

    This pops up YaST2 and it gets frozen at the part where it says "Please wait while this software is being installed."

    And I have no way of aborting this because the abort button doesn't work. So first, before I install LXDE, how can I stop and abort YaST2 from to install without damaging anything. Do I pop up terminal and type in a command to get rid of it? Please specify the command as I am quite new to linux.

  4. #4

    Default Re: Can't install LXDE/YaST2 isn't responding.

    Please help, I'm new to openSUSE.
    I read around online that you can "kill" the process using the terminal and typing "kill PID" PID as in the number of the process. Is this the safe and correct way to abort YaST2 without anything getting damaged?

    I need a confirmation. And after all of that is solved, is there a way to just open up terminal and type in something like "zypper install LXDE"?

    Please, first help me with the first problem where I don't know how to abort YaST2.

  5. #5

    Default Re: Can't install LXDE/YaST2 isn't responding.

    Sorry for a triple post but I just killed all of YaST processes. I rebooted and I am stuck at the part where it says:

    Loading required kernel modules
    Activating swap-devices in /etc/fstab/...
    Loading console font lat9w-16.psfu -m trivial G0:loadable
    Loading keymap i386/qwerty/us.map.gz
    touch: cannot touch '/var/run/numlock-on': Read-only file system
    Start Unicode mode

    fsck failed. Please repair manually and reboot. The root
    file system is currently mounted read-only. To remount it read-write do:

    bash# mount -n -o remount,rw /

    Attention: Only CONTROL-D will reboot the system in this
    maintenance mode. shutdown or reboot will not work.
    So, I typed in
    mount -n -o remount,rw /
    and it does nothing. Please help

    In fact, I'd rather just get this fixed and get YaST fixed if it's broken because I killed it and not even install LXDE.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Can't install LXDE/YaST2 isn't responding.

    Code:
    su -
    zypper in patterns-openSUSE-lxde
    But you need to resolve your boot problem first.
    Use something like parted magic to run a check on your partitions, it might be easier for you.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Can't install LXDE/YaST2 isn't responding.

    Sorry for all of those posts

    I've managed to fix the boot problem myself! What I did was type in "mount -n -o remount,rw / " then rebooted. Then it said something about it again but it was different. However, I typed in "fsck" and then I typed in "N" because it said if I continued, it will severly damage my computer. Then, another prompt popped up after that and then I pressed "Y" to fix up my computer.

    So, now thats fixed, do I just type in

    su -
    zypper in patterns-openSUSE-lxde
    and that will install lxde for me? (Like I just type it in, and once it's finished, I just reboot and I can use LXDE through Session Type?) Or do I have to do something also to get it up and running?

    Again, sorry for being a newb. If you can, can you also help me learn openSUSE/Linux? Just direct me to a link to learn the basics/advanced stuff because I want to know how things work and so I can troubleshoot things myself.

  8. #8

    Default Re: Can't install LXDE/YaST2 isn't responding.

    Okay I installed LXDE. Thanks for your help guys! My computer is definitely much faster.

    Again, thanks. But if you guys can show me where I can learn the basics/advanced stuff about opensuse/linux, it'll help me a lot.

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Can't install LXDE/YaST2 isn't responding.

    On 07/04/2011 08:36 PM, Krankles wrote:
    >
    > Again, thanks. But if you guys can show me where I can learn the
    > basics/advanced stuff about opensuse/linux, it'll help me a lot


    to start on openSUSE:
    http://en.opensuse.org/Portal:Support
    http://en.opensuse.org/Portal:Support_database
    http://docs.opensuse.org

    generic linux: covered pretty well in one of my old posts:
    http://tinyurl.com/3a5rong

    --
    DD
    -Caveat-Hardware-Software-

  10. #10
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Can't install LXDE/YaST2 isn't responding.

    It's not possible to abort the process once Yast has started to install software. Doing so can cause serious damage to your system, as you found out. Why they even display the disabled button I don't know.

    You might find this article on the wiki helpful:

    Concepts - openSUSE

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •