Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

  1. #1

    Default 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    On My OpenSuse 11.3 box, all my 64-bit apps correctly select Western font for menu items, file selection etc.. But my 32-bit apps like Adobe reader and 32-bit version of Firefox display unreadable text for mouse right click, file save and select etc, as if they are trying to use an invalid font or character encoding.
    Can somebody please tell me how I configure 32-bit apps to use Western character set, and to find what it is actually looking for ?
    thanks
    Rod

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,585

    Default Re: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    KDE? Gnome? Something else?

  3. #3

    Default Re: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    The problem occurs with all my 32-bit apps e.g. Adobe Reader, Firefox. If I use 64-bit Evince (Gnome PDF reader) or Okular (KDE PDF reader) they work OK. 64-bit Firefox also works OK. So no 32-bit apps at all can correctly display text for menus, right-click mouse etc. Which Is why I think my 32-bit environment is broken, the problem does not appear related to Gnome or KDE specifically. But how to fix ?

  4. #4

    Default Re: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    is the text corrupted, not showing at all, only showing little squares?
    can you upload a picture of the problem? just display the menu where the error ocurrs and hit F12 to save a screenshot.

    I dont know if its the same thing, but i had problems with suse showing strange/corrupted fonts in some apps, and the way i fixed it was to disable compiz.
    give it a shot, disable desktop effects and reboot, if problem persists, you can allways re-enable the effects.

  5. #5

    Default Re: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    Quote Originally Posted by ErnestoRD View Post
    is the text corrupted, not showing at all, only showing little squares?
    can you upload a picture of the problem? just display the menu where the error ocurrs and hit F12 to save a screenshot.

    I dont know if its the same thing, but i had problems with suse showing strange/corrupted fonts in some apps, and the way i fixed it was to disable compiz.
    give it a shot, disable desktop effects and reboot, if problem persists, you can allways re-enable the effects.
    oops! im mistaking suse with left 4 dead 2
    the key to take screenshots in suse is actually "PrintScreen"

  6. #6

    Default Re: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    Quote Originally Posted by ErnestoRD View Post
    is the text corrupted, not showing at all, only showing little squares?
    can you upload a picture of the problem? just display the menu where the error ocurrs and hit F12 to save a screenshot.

    I dont know if its the same thing, but i had problems with suse showing strange/corrupted fonts in some apps, and the way i fixed it was to disable compiz.
    give it a shot, disable desktop effects and reboot, if problem persists, you can allways re-enable the effects.
    Screenshot showing what I see when I click the Print icon : this is typical of all my 32-bit apps :

  7. #7

    Default Re: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    your right, it seems suse is trying to render the characters in some character set that it doesnt have or something.
    Maybe go to yast->Languages-Details and double check that your language and locale are correct?
    Not just the language, but also the locale, for example not just US, but US_GB (if in england) or US_US (if in usa) etc.

    I use Spanish localization, and when i fist installed suse, i had the problem of some text showing in english, i went there and changed it from ES to ES_MX and suse automatically downloaded the aditional translations, and problem was solved.

    I dont know if this will fix your problem, but it cant hurt to try it.

    hope this helps

  8. #8

    Default Re: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    Yast shows it's configured for en-GB which is correct. But the point I'm trying to make is that this is a 64-bit system, and fonts and language work correctly for all 64-bit apps.
    The problem only occurs with 32-bit apps, which I presume rely on the existence and correct configuration of 32-bit compatibility libraries. I don't know how/where these are configured, or whether Yast just configures the 64-bit environment of 32-bit as well.

  9. #9

    Default Re: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    ernestoRD, mine only displays squares. This is an 11.3 32bit system that was installed without X. I installed X by: zypper install -t pattern gnome_basis

    Any ideas?

  10. #10

    Default Re: 32-bit apps on OpenSuse 11.3 don't display readable text for menu items

    Quote Originally Posted by chr00t3d View Post
    ernestoRD, mine only displays squares. This is an 11.3 32bit system that was installed without X. I installed X by: zypper install -t pattern gnome_basis

    Any ideas?
    I fixed that by uninstalling & reinstalling all gnome packages. I'm still having the block text for firefox though...I uninstalled & reinstalled firefox with no luck

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •