Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: openSUSE 11.4 - LibreOffice causes very severe system lockup

  1. #1

    Default openSUSE 11.4 - LibreOffice causes very severe system lockup

    Hi everyone,

    I am new here, but I've tried my best to post this in the correct area. I am not sure of which LibreOffice version I am using because I can't open the ********** program.

    So here's what's happening: I start LibreOffice, my screen looks unusual (it tiles a section of the screen that is the same size as the LibreOffice window (I think) across both of my monitors) and my system locks up. I am unable to use Ctrl+Alt+Backspace, Ctrl+Alt+Delete, Ctrl+Alt+F1-F8, or any other keyboard combination. No mouse click registers and the cursor acts as if the mouse is in one location (if the system locked up with my cursor over a link, the cursor stays like that) BUT the mouse still moves. Also, if I am playing music when it locks up, I can continue to hear the music and the music continues to shuffle through my playlist. I am able to access my machine normally through ssh and the only way I've been able to fix this is to hold down the power button or pull the power.

    I have not identified what action causes the system to lock up, the only thing I've noticed is that LibreOffice is open every time this happens (It's happened no matter if Writer or Calc is open). The system almost always locks up upon startup of LibreOffice if the recovery window pops up, otherwise it locks up at some point during my LibreOffice session no matter what.

    I have not touched LibreOffice on my other machine's openSUSE installation, so I don't know how reproducible the problem is.

    Let me know if you need any extra information or if there are any diagnostic commands I could run.

    Thanks,
    Vi3

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: openSUSE 11.4 - LibreOffice causes very severe system lockup

    Post the result of the following:

    Code:
    zypper lr -d
    If you open a terminal and try starting it with:
    Code:
    lowriter
    Do you notice any errors in the terminal?

    Does it make any difference if desktop effects are OFF?

    What desktop: KDE or Gnome?
    What version of SUSE?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: openSUSE 11.4 - LibreOffice causes very severe system lockup

    > zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+----------------------------------+----------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------+--------
    1 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_11.4/ |
    2 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    3 | VLC | VLC | Yes | Yes | 99 | rpm-md | Index of /pub/vlc/SuSE/11.4/ |
    4 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
    5 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/11.4/ |
    6 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVD-RAM_GH40L_922CD020830,/dev/sr0 |
    7 | openSUSE_11.4_Contrib | openSUSE:11.4:Contrib (standard) | Yes | No | 99 | rpm-md | Index of /repositories/openSUSE:/11.4:/Contrib/standard |
    8 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /mirrors/packman/suse/11.4 |
    9 | repo-debug | openSUSE-11.4-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.4/repo/oss |
    10 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/11.4 |
    11 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
    12 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
    13 | repo-source | openSUSE-11.4-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.4/repo/oss |
    Desktop Effects are off. I'm using openSUSE 11.4 with GNOME. Let me try opening from command line (I'm posting this first in case it crashes again)

    EDIT: Three crashes and hard reboots later, I have not been able to get any output from the lowriter command in terminal (and because it kept crashing, I used "lowriter > lowriter.out" to see if I could catch the errors in the output file)

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: openSUSE 11.4 - LibreOffice causes very severe system lockup

    I can't really see anything there that makes me think it would cause problems with loffice
    But there are some things that need putting right.
    Here is what to do...open a terminal and use your mouse to paste this in:

    Code:
    su -
    zypper rr 8
    Code:
    zypper rr 3
    Now close the terminal and open Yast > Software > Software Management
    Look carefully at and follow this:
    http://www.su2root.ukfsn.org/files/Switcher Pics/packman in gnome.png
    All hell might break loose because of your having had VLC repo, but lets see. You can use the expert button in any error box to save the error to file and then post it here for us to see
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,935

    Default Re: openSUSE 11.4 - LibreOffice causes very severe system lockup

    You could try unchecking hardware accel and softening in LO Tools>Options>Display.

    Since you can't run LO long enough to do that, try changing the config file directly. In my system I think it is
    ~/username/.libreoffice/3-suse/user/registrymodifications.xcu
    .

    The first lines are the ones changed when I change the options above. With them unckecked, I get in this file:

    <?xml version="1.0" encoding="UTF-8"?>
    <oor: items xmlns: oor="http://openoffice.org/2001/registry" xmlns: xs="http://www.w3.org/2001/XMLSchema" xmlns: xsi="http://www.w3.org/2001/XMLSchema-instance">
    <item oor: path="/org.openoffice.Office.Canvas"><prop oor: name="ForceSafeServiceImpl" oor: op="fuse"><value>true</value></prop></item>
    <item oor: path="/org.openoffice.Office.Common/Drawinglayer"><prop oor: name="AntiAliasing" oor: op="fuse"><value>false</value></prop></item>
    With acceleration and softening checked on, the values in bold are inverted.

    Good luck.

    PS: I had to insert spaces after ":" to avoid them being rendered as smiles.
    Last edited by brunomcl; 04-Jul-2011 at 20:32. Reason: remove smiles

  6. #6

    Default Re: openSUSE 11.4 - LibreOffice causes very severe system lockup

    As a side note it might be important to mention that I am using the 64-bit version, I wasn't aware to any difficulties using the 64-bit version as opposed to the 32-bit version but I had to go through three windows of "you need to manually select what to do for these" and lists of 20 or so packages that had incompatibilities. This happened when I switched packages to the packman repo versions.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: openSUSE 11.4 - LibreOffice causes very severe system lockup

    Quote Originally Posted by Vi3GameHkr View Post
    As a side note it might be important to mention that I am using the 64-bit version, I wasn't aware to any difficulties using the 64-bit version as opposed to the 32-bit version but I had to go through three windows of "you need to manually select what to do for these" and lists of 20 or so packages that had incompatibilities. This happened when I switched packages to the packman repo versions.
    Which is why I suggested you post the info
    Lets hope you got it right
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: openSUSE 11.4 - LibreOffice causes very severe system lockup

    I guess I didn't interpret those as error messages but rather yes/no dialog boxes! Well I'm not sure which part of everything I did fixed this but...
    * Disabled anti-aliasing (then the LibreOffice-opening crash would log me out and change the screen resolution... I assume X crashed and rebooted itself)
    * I installed nvidia drivers (running a 9800 GT, configuration took forever but I found it easiest to copy xorg.conf from my Ubuntu installation)
    * Followed caf4926's instructions, removed redundant packman repository and an old VLC repo that I used before I knew of packman, then I switched several packages to the packman repo version
    * I also tinkered around with some screensaver settings because I found out my screensaver also crashes X for some reason.. Basically, when I resume session after the screensaver was activated, I find myself at a low-res login screen and upon login, nothing is open.

    Well so far I've been able to edit a really important paper that was due 2 minutes ago, which is a good thing... Unfortunately I didn't realize it was already 12AM or I would have turned that paper in before I made this post.

    Thanks,
    I'll let you know if anything else happens.
    - Vi3

  9. #9
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,926

    Default Re: openSUSE 11.4 - LibreOffice causes very severe system lockup

    Quote Originally Posted by brunomcl View Post
    PS: I had to insert spaces after ":" to avoid them being rendered as smiles.
    There is an option in advanced post editing to work around this :
    SUSE Paste

    Best regards,
    Greg
    Best regards,
    Greg

  10. #10

    Default Re: openSUSE 11.4 - LibreOffice causes very severe system lockup

    Quote Originally Posted by caf4926 View Post
    Now close the terminal and open Yast > Software > Software Management
    Look carefully at and follow this:
    http://www.su2root.ukfsn.org/files/Switcher Pics/packman in gnome.png
    All hell might break loose because of your having had VLC repo, but lets see. You can use the expert button in any error box to save the error to file and then post it here for us to see
    How do I undo that?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •