Results 1 to 7 of 7

Thread: 11.4: knotify4 seems too hungry for RAM and CPU

  1. #1
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default 11.4: knotify4 seems too hungry for RAM and CPU

    openSUSE 11.4 (32bit) on Acer Aspire One with 1GB RAM (fresh install, with KDE):

    Observing the output of 'top' I note that knotify4 is consuming 2.3% of the total memory (RES=22m) and 2% of the CPU. This is more memory than a running mysqld needs.

    Can knotify4 be shut down or is there some configuration option to make it behave a bit better?
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,503
    Blog Entries
    3

    Default Re: 11.4: knotify4 seems too hungry for RAM and CPU

    "Personal Settings" --> "Application and System Notifications" --> "Manage Notification" --> "Player Settings"

    I checked the "No audio output" box, and knotify no longer shows up near the top of the "top" listing.

    I made that change more than a month ago. I haven't found any undesirable effects. There is no longer any sound when KDE starts up or ends, which is fine by me. I still get beeps from browser notices.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: 11.4: knotify4 seems too hungry for RAM and CPU

    Thank you nrickert.

    That did the trick. I had to reboot to make the new settings take effect.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 11.4: knotify4 seems too hungry for RAM and CPU

    On 07/02/2011 07:06 PM, nrickert wrote:
    >
    > I made that change more than a month ago.


    cool hack!!

    --
    DD
    -Caveat-Hardware-Software-

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,503
    Blog Entries
    3

    Default Re: 11.4: knotify4 seems too hungry for RAM and CPU

    Quote Originally Posted by vodoo View Post
    I had to reboot to make the new settings take effect.
    I'm pretty sure that I only had to logout (from KDE), then login again.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: 11.4: knotify4 seems too hungry for RAM and CPU

    I'm pretty sure that I only had to logout (from KDE), then login again.
    Yep. That's the "soft" (and actually preferred) way of doing it.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  7. #7
    Join Date
    Sep 2011
    Location
    Luna de Sus, Romania
    Posts
    1

    Default Re: 11.4: knotify4 seems too hungry for RAM and CPU

    I found on Archlinux wiki, you may install mplayer, vlc or any other sound player and System Settings > Application and System Notifications > Manage Notifications > Player Settings and change to Use an external player. After a logout it works for me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •