Results 1 to 4 of 4

Thread: skype: error while loading shared libraries

  1. #1

    Default skype: error while loading shared libraries

    Hi,

    I'm running openSUSE 11.0 (X86-64) and just installed skype 2.1.0.47. When starting it, I get
    skype: error while loading shared libraries: libQtDBus.so.4: wrong ELF class: ELFCLASS64
    Where do I get the correct library from? Or which one should I point it to?

    Thanks

  2. #2
    cavacoparis NNTP User

    Default Re: skype: error while loading shared libraries

    Hi,
    I had the same problem, but it works now. My machine is x86_64. The installation of the openSuse skype package worked without problem.

    To check which libraries are missing:
    ldd /usr/bin/skype | grep not

    In my case, I needed these two:
    libQtDBus.so.4
    libQtGui.so.4

    In Yast2, I searched qt4 and installed the related packages (32 bits). Install all the missing packages and then it should work.

    Best.

  3. #3
    Join Date
    Dec 2009
    Location
    Thailand
    Posts
    60

    Default Re: skype: error while loading shared libraries

    Solved:

    Code:
    zypper in libasound2-32bit xorg-x11-libXv-32bit xorg-x11-libs-32bit libqt4-32bit libqt4-x11-32bit libpng12-0-32bit libsigc++2-32bit
    Regards,
    SuSEThailand.com is a SUSE Linux user and community found in Thailand.

  4. #4

    Default Re: skype: error while loading shared libraries

    This is well documented on the wiki: SDB:Skype - openSUSE

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •