Results 1 to 5 of 5

Thread: to firefox 5 upgrading problem

  1. #1
    Join Date
    Apr 2011
    Location
    Yazd (Iran)
    Posts
    253

    Question to firefox 5 upgrading problem

    today opensuse 11.4 introduce Firefox 5 update to me (my current version is ff4) but when i click on "apply" to install it, the following error report appeared:
    a package dependency could not be found,
    Details:
    patch:firefox50-upgrade-4806.noarch conflicts with MozillaFirefox-branding-openSUSE.i586 < 5.0-2.3.1 provided by MozillaFirefox-branding-openSUSE-5.0-2.1.i586

    how can i solve this problem?

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: to firefox 5 upgrading problem

    On 07/02/2011 09:06 AM, ilAli wrote:
    >
    > today opensuse 11.4 introduce Firefox 5 update to me (my current version
    > is ff4) but when i click on "apply" to install it, the following error
    > report appeared:
    > a package dependency could not be found,
    > Details:
    > patch:firefox50-upgrade-4806.noarch conflicts with
    > MozillaFirefox-branding-openSUSE.i586< 5.0-2.3.1 provided by
    > MozillaFirefox-branding-openSUSE-5.0-2.1.i586
    >
    > how can i solve this problem?


    try not using package kit...close it, and launch YaST > Online Update..

    does it work better?
    because the current package kit is broken, i recommend you (and all) tp
    set package kit to *never* install anything..

    well, i did not have the problem you report and i have no kpackagekit
    installed...and no packagekit running..

    --
    DD
    -Caveat-Hardware-Software-

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,875
    Blog Entries
    3

    Default Re: to firefox 5 upgrading problem

    Quote Originally Posted by ilAli View Post
    Details:
    patch:firefox50-upgrade-4806.noarch conflicts with MozillaFirefox-branding-openSUSE.i586 < 5.0-2.3.1 provided by MozillaFirefox-branding-openSUSE-5.0-2.1.i586
    Yes, I ran into that, on my test gnome 3 install.

    I skipped the update. Then I went to Yast online update, and did it from there.

    Online update offered me several alternatives. One option was to remove the firefox 4 branding. I did that, and every thing proceeded just fine.

    I'm not sure, but I think this happens because the firefox 5 branding comes from a different repo than the firefox 4 branding, due to the way the gnome 3 demo was originally organized.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Apr 2011
    Location
    Yazd (Iran)
    Posts
    253

    Default Re: to firefox 5 upgrading problem

    Quote Originally Posted by DenverD View Post
    On 07/02/2011 09:06 AM, ilAli wrote:
    >
    > today opensuse 11.4 introduce Firefox 5 update to me (my current version
    > is ff4) but when i click on "apply" to install it, the following error
    > report appeared:
    > a package dependency could not be found,
    > Details:
    > patch:firefox50-upgrade-4806.noarch conflicts with
    > MozillaFirefox-branding-openSUSE.i586< 5.0-2.3.1 provided by
    > MozillaFirefox-branding-openSUSE-5.0-2.1.i586
    >
    > how can i solve this problem?


    try not using package kit...close it, and launch YaST > Online Update..

    does it work better?
    because the current package kit is broken, i recommend you (and all) tp
    set package kit to *never* install anything..

    well, i did not have the problem you report and i have no kpackagekit
    installed...and no packagekit running..

    --
    DD
    -Caveat-Hardware-Software-
    OK, i do this and has no problem. Thanks

  5. #5
    Join Date
    Nov 2010
    Location
    Kazakhstan
    Posts
    3

    Default Re: to firefox 5 upgrading problem

    Quote Originally Posted by DenverD View Post
    On 07/02/2011 09:06 AM, ilAli wrote:
    >
    > today opensuse 11.4 introduce Firefox 5 update to me (my current version
    > is ff4) but when i click on "apply" to install it, the following error
    > report appeared:
    > a package dependency could not be found,
    > Details:
    > patch:firefox50-upgrade-4806.noarch conflicts with
    > MozillaFirefox-branding-openSUSE.i586< 5.0-2.3.1 provided by
    > MozillaFirefox-branding-openSUSE-5.0-2.1.i586
    >
    > how can i solve this problem?


    try not using package kit...close it, and launch YaST > Online Update..

    does it work better?
    because the current package kit is broken, i recommend you (and all) tp
    set package kit to *never* install anything..

    well, i did not have the problem you report and i have no kpackagekit
    installed...and no packagekit running..

    --
    DD
    -Caveat-Hardware-Software-
    Thank you very much! It really helps me

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •