Results 1 to 7 of 7

Thread: kpackage kit bug

  1. #1

    Default kpackage kit bug

    Suse 11.4 64bit

    I get this on kpackage kit update. Also, it asks for admin password twice. How can I fix this?

    Code:
    This update will add new features and expand functionality.
    openSUSE is a distribution by the openSUSE.org project.
    Obsoletes:
    • openSUSE-release - 11.4-1.9
    /• openSUSE-release - 11.4-1.8
    /• openSUSE-release - 11.4-1.8
    /• openSUSE-release - 11.4-1.9
    Repository: repo-oss
    Normally, I just use kpackage kit to notify me of updates.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,497
    Blog Entries
    3

    Default Re: kpackage kit bug

    Quote Originally Posted by lord_valarian View Post
    Also, it asks for admin password twice. How can I fix this?
    I put it down to packagekit weirdness.

    Sometimes, but not always, it asks for password twice.

    On one of my systems, the window asking for the admin password manages to open underneath other windows, where it is not visible.

    On another system, after entering the admin password, that window just stays there with the password entry slot grayed out. I have to manually close that window before kpackagekit proceeds.

    On my gnome 3 test system, the gnome package kit sometimes kills the gnome shell, though packagekit continues doing its thing until done. When that happens, after I log back in, I run "top" so that I can see when it has finished.

    I am putting it all down to packagekit wierdness.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: kpackage kit bug

    On 06/23/2011 10:36 PM, nrickert wrote:
    >
    > I am putting it all down to packagekit wierdness.


    packagekit is _not_ reliable and should not be used until it is fixed..

    use YaST or zypper instead, please!

    --
    DD
    Caveat
    Hardware
    [url=http://tinyurl.com/DD-Software]Software[/ul]
    23 June: Sunrise 4:36 AM, Sunset 10:03 PM

  4. #4

    Default Re: kpackage kit bug

    >packagekit is _not_ reliable and should not be used until it is fixed. Use YaST or zypper instead, please!

    It's now giving the above and a few other regular updates. The regular updates doesn't appear in yast online update. Do I have updates or not?

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: kpackage kit bug

    On 06/24/2011 07:36 AM, lord valarian wrote:
    >
    > It's now giving the above and a few other regular updates. The regular
    > updates doesn't appear in yast online update. Do I have updates or not?


    HELLO! follow the updates available in YaST Online Updates, *only*.

    right click on kpackagejunk and set it to *never* update....it is made
    by the KDE folks and is NOT fully integrated with YaST, yet...for now it
    is broken!

    i used YaST to delete kpgackagekit, so it takes neither resources or a
    spot on my panel!!

    only thing is you then need to run YaST Online Update every once in a
    while....seems most updates come out near the weekend...so, check every
    saturday, at least..

    --
    DD
    Caveat
    Hardware
    Software


  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,497
    Blog Entries
    3

    Default Re: kpackage kit bug

    Quote Originally Posted by lord_valarian View Post
    It's now giving the above and a few other regular updates. The regular updates doesn't appear in yast online update. Do I have updates or not?
    Package-kit seems to offer two kinds of things:

    Updates, as needed, for software already installed;
    New packages that are suggested as possibly useful to you, based on what you already have installed.

    Unfortunately, it doesn't distinguish very clearly between the two.

    Yast online update offers only the updates, and not the new packages. It will offer a new package only if that is due to a dependency being created by an update.

    If you use only Yast online-update, you will get all of the updates, but you won't get those suggested new packages.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,918

    Default Re: kpackage kit bug

    Quote Originally Posted by lord_valarian View Post
    Suse 11.4 64bit

    I get this on kpackage kit update. Also, it asks for admin password twice. How can I fix this?

    Code:
    This update will add new features and expand functionality.
    openSUSE is a distribution by the openSUSE.org project.
    Obsoletes:
    • openSUSE-release - 11.4-1.9
    /• openSUSE-release - 11.4-1.8
    /• openSUSE-release - 11.4-1.8
    /• openSUSE-release - 11.4-1.9
    Repository: repo-oss
    Normally, I just use kpackage kit to notify me of updates.
    I didn't have the problem of having to enter the admin password twice since upgrading to KDE 4.6.3 from the sable repo but I don't know if that's a feasible solution for You. I'm also not sure if this is the real solution Maybe I'm just lucky.

    Best regards,
    Greg
    Best regards,
    Greg

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •