Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: WebKit - How?

  1. #1
    Join Date
    Jun 2011
    Location
    divinopolis, br
    Posts
    7

    Default WebKit - How?

    The programs Gwibber and Gramps uses Webkit, but they can't find it. I've installed everything possible about webkit, but nothing changes. In Gwibber I can't add accounts with Oauth and in Gramps I can't click/use Web Painel.
    Gwibber I trying to use because of facebook and Gramps... just curiosity. Can anyone help me, please?
    I'm using Opensuse 11.4 x64.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,433

    Default Re: WebKit - How?

    Open Konqueror and go to View>View mode. If you haven't got Konqueror installed, installing it will add WebKit.

  3. #3
    Join Date
    Jun 2011
    Location
    divinopolis, br
    Posts
    7

    Default Re: WebKit - How?

    Konqueror were already installed. I changed the engine to "Webkit", but nothing changes. Those programs I said runs under gnome. I tried something installing Epiphany, but it crash too (segmentation fault like others). I believe something is missing or need to be configured. But What?

    Any Way,

    Thanks a lot!

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,195
    Blog Entries
    3

    Default Re: WebKit - How?

    Both gwibber and gramps appear to be in the opensuse-11.4 repos. Did you install them from there?

    They seem to require "python-webkitgtk" which should be automatically brought in if you install via Yast software management.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,433

    Default Re: WebKit - How?

    I have GRAMPS installed and it runs perfectly; have you installed the most recent version from the openSUSE repos?

  6. #6
    Join Date
    Jun 2011
    Location
    divinopolis, br
    Posts
    7

    Default Re: WebKit - How?

    nrickert,

    I installed them from opensuse 11.4 repos, but, all of them from: gnome 3 repository

    zypper info python-webkitgtk
    Loading repository data...
    Reading installed packages...


    Information for package python-webkitgtk:

    Repository: @System
    Name: python-webkitgtk
    Version: 1.1.8-1.1
    Arch: x86_64
    Vendor: obs://build.opensuse.org/GNOME
    Installed: Yes
    Status: up-to-date
    Installed Size: 132.0 KiB
    Summary: Python bindings for WebKit/Gtk
    Description:
    PyWebKitGtk provides an API for developers to program WebKit/Gtk using
    Python.

    The project share the same goals with WebKit. The purpose of this
    binding is to bring an alternative web engine to Python/GTK+
    application developers who might need a web browser engine for their
    next application or developers wishing to have a better browser engine
    that they can access to using the Python programming language.

    zypper info gramps
    Loading repository data...
    Reading installed packages...


    Information for package gramps:

    Repository: @System
    Name: gramps
    Version: 3.3.0-11.1
    Arch: noarch
    Vendor: obs://build.opensuse.org/GNOME
    Installed: Yes
    Status: up-to-date
    Installed Size: 21.2 MiB
    Summary: Genealogical Research Software
    Description:
    Gramps gives you the ability to record the many details of an
    individual's life as well as the complex relationships between
    various people, places and events. All of your research is kept
    organized, searchable and as precise as you need it to be.



    zypper info gwibber
    Loading repository data...
    Reading installed packages...


    Information for package gwibber:

    Repository: @System
    Name: gwibber
    Version: 3.0.0.1-53.2
    Arch: x86_64
    Vendor: obs://build.opensuse.org/GNOME
    Installed: Yes
    Status: up-to-date
    Installed Size: 1.7 MiB
    Summary: Microblogging Client
    Description:
    Gwibber is an open source microblogging client for GNOME developed with
    Python, GTK and WebKit. It supports Twitter, identi.ca, Jaiku, Facebook,
    Pownce, Flickr and Digg.

  7. #7
    Join Date
    Jun 2011
    Location
    divinopolis, br
    Posts
    7

    Default Re: WebKit - How?

    Quote Originally Posted by john_hudson View Post
    I have GRAMPS installed and it runs perfectly; have you installed the most recent version from the openSUSE repos?
    zypper info gramps
    Loading repository data...
    Reading installed packages...


    Information for package gramps:

    Repository: @System
    Name: gramps
    Version: 3.3.0-11.1
    Arch: noarch
    Vendor: obs://build.opensuse.org/GNOME
    Installed: Yes
    Status: up-to-date
    Installed Size: 21.2 MiB
    Summary: Genealogical Research Software
    Description:
    Gramps gives you the ability to record the many details of an
    individual's life as well as the complex relationships between
    various people, places and events. All of your research is kept
    organized, searchable and as precise as you need it to be.

  8. #8
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,433

    Default Re: WebKit - How?

    Just to go back to the original question, I don't have a Web Panel option but I have a Web Pages option which works fine. What exactly is it that you cannot do?

  9. #9
    Join Date
    Jun 2011
    Location
    divinopolis, br
    Posts
    7

    Red face Re: WebKit - How?

    Quote Originally Posted by john_hudson View Post
    Just to go back to the original question, I don't have a Web Panel option but I have a Web Pages option which works fine. What exactly is it that you cannot do?
    About Gramps,

    When I click in "Web" Navigation bar, the program crashes. (See image on: Screenshot - 06282011 - 09:56:06 PM | Flickr - Photo Sharing! )

    But now, later a bunch of "trying" it appears only a error:

    Traceback (most recent call last):
    File "/usr/share/gramps/gui/viewmanager.py", line 1171, in __create_page
    page_display = page.get_display()
    File "/usr/share/gramps/gui/views/pageview.py", line 394, in get_display
    self.top = self.build_interface()
    File "/usr/share/gramps/gui/views/pageview.py", line 167, in build_interface
    widget = self.build_widget()
    File "/usr/share/gramps/plugins/view/htmlrenderer.py", line 513, in build_widget
    self.renderer = RendererWebkit()
    File "/usr/share/gramps/plugins/view/htmlrenderer.py", line 252, in __init__
    self.window = webkit.WebView()
    AttributeError: 'module' object has no attribute 'WebView'



    BUT, Gramps it's "Ok". I can use the program whitout using this "Web Navigator", it's only something more. I mentioned because of the error, related with webkit.

    My main goal is making GWIBBER works. I can't add any account that uses Oauth. Exemple: When I try to include a facebook account, clicking on "authorize", the window closes.

    Maybe I could have messed up my files, "playing with repos" installing a new version of opensuse over the old (Upgrade), and not sufficient, include now new repositories of Gnome 3.

    Maybe in the next version of opensue I do a clear installation.

    Any way,

    Thanks a lot, anda help if possible.

  10. #10
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,433

    Default Re: WebKit - How?

    It looks as if you have an experimental version installed; I have 3.3.0 which, according to the website, is the latest release but I don't have a Web option. Which repo did you get it from? Mine is from the OBS GNOME repo.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •