Results 1 to 6 of 6

Thread: unable to mount NTFS partitons

  1. #1
    Join Date
    Feb 2010
    Location
    Florida,USA
    Posts
    80

    Default unable to mount NTFS partitons

    I first noted a few weeks ago I couldn't mount my NTFS partitions using dolphin. At the time I was having problems with windows, so I thought - naturally, they are marked as dirty, no biggie-

    However, I still can't mount them and I know they are clean. I get the error: "filesystem is neither well know nor in /proc/filesystem nor in /etc/filesystems" which is strange since I can mount just fine in the console using mount -t ntfs-3g.


    What gives?

  2. #2

    Default Re: unable to mount NTFS partitons

    hi, try installing ntfs-config.
    I had a problem where suse wouldnt mount an extended NTFS partition, and with ntfs-config i was able to do it in about 1 minute, and from a nice GUI.

  3. #3

    Default Re: unable to mount NTFS partitons

    You can also add ntfs to the file /etc/filesystems, here's what my /etc/filesystems looks like:


    Code:
    ntfs
    vfat
    hfs
    minix
    reiserfs
    *
    For allowing users write access there's another little trick that's done in /etc/fstab, the default mount options for ntfs partitions mounted using yast look something like this:

    users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0

    If you find you're asked for the root password to access your ntfs partitions and want to change this so you are allowed access without the root password when logged in as a normal user, try changing your mount options in fstab for ntfs partitions so that they look like this:

    user,users,gid=users,fmask=113,dmask=002,locale=en_GB.UTF-8 0 0

    The differences are: adding user, in front of users, changing fmask =133 to 113 and dmask =022 to 002

    You have to be root to edit /etc/filesystems and /etc/fstab, I always add these edits and never have to install ntfs-config

  4. #4
    Join Date
    Feb 2010
    Location
    Florida,USA
    Posts
    80

    Default Re: unable to mount NTFS partitons

    Quote Originally Posted by Ecky View Post
    You can also add ntfs to the file /etc/filesystems, here's what my /etc/filesystems looks like:


    Code:
    ntfs
    vfat
    hfs
    minix
    reiserfs
    Lol, that did the trick alright

    Thanks

  5. #5

    Default Re: unable to mount NTFS partitons

    Anytime, glad I could help

  6. #6

    Default Re: unable to mount NTFS partitons

    thanks ecky, i was also facing the same problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •