Results 1 to 10 of 10

Thread: PiTiVi won't start - terminal shows error

  1. #1

    Question PiTiVi won't start - terminal shows error

    Hi everyone,

    I'm running 11.4 with Gnome 3. I've installed the PiTiVi video editor from Software Manager, but when I tried to run the program, it wouldn't start. Trying to run from the terminal returned this error: "Gst-Python couldn't be found!" I tried looking for the dependency, but couldn't find it in Software Manager.

    Any help would be greatly appreciated. Thanks!

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: PiTiVi won't start - terminal shows error

    Try expanding your search options by clicking the "rpm provides" check box in Yast Software Manager.

    There's a hit for gst-python in package "python-gstreamer=0_10-devel" (python bindings for gstreamer).

    I hope that's what you need.

  3. #3

    Default Re: PiTiVi won't start - terminal shows error

    Thanks for your reply. I wasn't able to locate the "rpm provides" check box in the Yast Software Manager, but I did locate and install the "python-gstreamer=0_10-devel" package. Unfortunately, it didn't resolve the issue. It may bear mentioning that I'm running 64-bit openSUSE.

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: PiTiVi won't start - terminal shows error

    From this search I see that there are two sources at least, standard and gnome 3.0 apps. Perhaps the one you didn't install will solve the dependencies correctly. I'd give it a try.

  5. #5

    Default Re: PiTiVi won't start - terminal shows error

    Thanks. I tried all pitivi results from the link you provided, but none of them successfully resolved the dependencies; same error. Maybe my first question should be: has anyone gotten this to successfully work on openSUSE via Software Manager?

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: PiTiVi won't start - terminal shows error

    Hmm... Did you add the corresponding repo or just installed from the RPM? Did you use yast SM (as you did initially)? If so, no dependency error messages?
    No go? Try searching in google like this:
    sitepensuse.org pitivi

  7. #7
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: PiTiVi won't start - terminal shows error

    That smiling face is a ":" and a "o". No idea how to diable this...

  8. #8

    Default Re: PiTiVi won't start - terminal shows error

    Both when installing from 11.4 repositories (v 0.13) and from source (v0.14), PiTiVi won't run because of gst-python. When importing gst in a python shell (import gst) this message is raised.
    ** Message: pygobject_register_sinkfunc is deprecated (GstObject)
    Even after erasing the import error checks from the PiTiVi source it won't work. I don't get any configure or make errors.

  9. #9

    Default Re: PiTiVi won't start - terminal shows error

    Quote Originally Posted by brunomcl View Post
    Hmm... Did you add the corresponding repo or just installed from the RPM? Did you use yast SM (as you did initially)? If so, no dependency error messages?
    No go? Try searching in google like this:
    At first I just tried installing the RPM from openSUSE's website, but after reading your recommendation I tried adding all corresponding repo's. The package version was still the same and it installed without any dependency errors, but when I tried to run it via Gnome terminal, I received the same error: "Gst-Python couldn't be found!" I'll probably just submit an official bug report to openSUSE dev's and see if they can't come up with a quick solution that I'm not seeing.

  10. #10
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: PiTiVi won't start - terminal shows error

    Yes, it seems to be a packaging problem, possibly gst-python is not installed where pitivi expects it, sometimes just simlinking the libraries work. The hard part is finding out what libs, and to what directory.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •