Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

  1. #1

    Default Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    Running:

    Suse11.4 (Celadon)
    Kernel Linux 2.6.37.6-0.5-desktop
    Gnome 2.32.1


    I've just followed the instructions at SDB:Skype - openSUSE again, as before. The install didn't start automatically when the download finished so I used package installer. Skype appears to start normally, before promptly closing itself after about 3-5 seconds. When running it from terminal, I get the message:

    Inconsistency detected by ld.so: dl-open.c: 582: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!

    Code: rpm -q libasound2-32bit xorg-x11-libXv-32bit xorg-x11-libs-32bit libqt4-x11-32bit libpng12-0-32bit skype

    Returns: libasound2-32bit-1.0.24.1-4.7.1.x86_64
    xorg-x11-libXv-32bit-7.6-6.1.x86_64
    xorg-x11-libs-32bit-7.6-16.1.x86_64
    libqt4-x11-32bit-4.7.1-7.1.x86_64
    libpng12-0-32bit-1.2.44-7.1.x86_64
    skype-2.2.0.35-suse111.i586

    Code: zypper lr -d

    Returns: # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+---------+---------+---------+---------+----------+--------+--------------------------------------------------------------+--------
    1 | Non-OSS | Non-OSS | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
    2 | OSS | OSS | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
    3 | Update | Update | Yes | Yes | 99 | rpm-md | Index of /update/11.4

    Anyone have ideas?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,520
    Blog Entries
    37

    Default Re: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    try these commands with root permissions and your pc connected to the internet:
    Code:
    rpm -e skype
    zypper ar http://download.opensuse.org/repositories/home:/Lord_LT/openSUSE_11.4/ skype1
    # note there is a space between /openSUSE_11.4/ and skype1 in previous line
    zypper in skype
    zypper rr skype1
    and see if that works any better.

    That last command is very important.

    Also, if you are going to start a new thread on a problem in an old thread, please advise those who are participating in the old thread. Its not consider proper forum etiquette to have more than one thread going on for a problem.

  3. #3
    Join Date
    Oct 2010
    Location
    China
    Posts
    14

    Default 回复: Re: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    try this:
    vi /usr/share/applications/skype.desktop
    add that:
    Exec=LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,520
    Blog Entries
    37

    Default Re: 回复: Re: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    An explanation of alpha080's post ... that is intended for users who typically have a gspca compatible webcam. Its likely NOT for users with a uvc compatible webcam.

    Quote Originally Posted by alpha080 View Post
    try this:
    vi /usr/share/applications/skype.desktop
    add that:
    Code:
    Exec=LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype
    skins345669, what can you tell us about your webcam? With webcam connected, run this command and post here the output:
    Code:
    lsusb

  5. #5

    Default Re: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    lsusb returned: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 003: ID 0bda:8197 Realtek Semiconductor Corp. RTL8187B Wireless Adapter
    Bus 005 Device 002: ID 04f2:b070 Chicony Electronics Co., Ltd
    Bus 003 Device 002: ID 046d:c521 Logitech, Inc. Cordless Mouse Receiver

    Besides that, I followed the instructions given and am still having the same error message returned

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,520
    Blog Entries
    37

    Default Re: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    Quote Originally Posted by skins345669 View Post

    lsusb returned:
    Code:
    Bus 005 Device 002: ID 04f2:b070 Chicony Electronics Co., Ltd
    ok, thats your webcam. What is important there is "04f2:b070".

    If one then goes to this wiki page: HCL:Web cameras - openSUSE you will note it recommends you check uvc driver wiki page to see if your webcam is supported by the 'uvc' webcam driver. (IMHO uvc compatible webcams are the easiest to use in GNU/Linux).

    And that page has this to say:
    Code:
    04f2:b070Toshiba Satellite L350D notebooksChicony Electronics
    indicating your webcam is a UVC compatible webcam.

    Hence the
    Code:
    Exec=LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skypeExec=LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype
    code is not appropriate as it is intended for a gspca compatible webcam which yours, being a 'uvc' is not a 'gspca'.

    Quote Originally Posted by skins345669 View Post
    Besides that, I followed the instructions given and am still having the same error message returned
    Did you try my recommendation (with root permissions) ?

    Code:
    rpm -e skype
    zypper ar http://download.opensuse.org/repositories/home:/Lord_LT/openSUSE_11.4/ skype1
    # note there is a space between /openSUSE_11.4/ and skype1 in previous line
    zypper in skype
    zypper rr skype1

  7. #7

    Default Re: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    Quote Originally Posted by oldcpu View Post
    Did you try my recommendation (with root permissions) ?

    Code:
    rpm -e skype
    zypper ar http://download.opensuse.org/repositories/home:/Lord_LT/openSUSE_11.4/ skype1
    # note there is a space between /openSUSE_11.4/ and skype1 in previous line
    zypper in skype
    zypper rr skype1
    Yes, followed those and got the same error message.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,520
    Blog Entries
    37

    Default Re: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    Quote Originally Posted by skins345669 View Post
    Yes, followed those and got the same error message.
    I'm still puzzled over why this message has appeared for you. Did you previous try using gtalk ? (ie the google video chat). I ask that because I have read of this problem originating because of an attempt with gtalk (and I don't know the solution there) but I have never read of it before originating from Skype.

  9. #9
    Join Date
    Jun 2008
    Location
    Wales, MA
    Posts
    486

    Default Re: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    I have had the same exact problem with skype 2.2 since it was released. Rather than battle with it, I just use the previous version.

  10. #10

    Default Re: Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit

    Quote Originally Posted by brucecadieux View Post
    I have had the same exact problem with skype 2.2 since it was released. Rather than battle with it, I just use the previous version.
    Very sensible. Can't find the RPM though, would you mind sharing a link?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •