Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 52

Thread: GNOME Shell Lost Desktop icons

  1. #11
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,486
    Blog Entries
    15

    Default Re: GNOME Shell Lost Desktop icons

    Quote Originally Posted by jimt123 View Post
    Hi,
    Yes ver 3.0.2, how do I force the install, I already re-built the hicolor icon-theme-cache.

    thanks
    Hi
    Just use;
    Code:
    zypper in -f  hicolor-icon-theme hicolor-icon-theme-branding-openSUSE
    There are some macros that the rpms run that hopefully clean it up...

    Else does it duplicate if you create a test user and login?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  2. #12
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default Re: GNOME Shell Lost Desktop icons

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Just use;
    Code:
    zypper in -f  hicolor-icon-theme hicolor-icon-theme-branding-openSUSE
    There are some macros that the rpms run that hopefully clean it up...

    Else does it duplicate if you create a test user and login?
    Hi

    Tried zypper and it reinstalled the directories, but still the same missing icons, not sure how to create a test user.

    Thanks

  3. #13
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,486
    Blog Entries
    15

    Default Re: GNOME Shell Lost Desktop icons

    Hi
    Use YaST -> Security and Users -> User and Group Management and hit the add button, then once finished, logout and login as that test user.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #14
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default Re: GNOME Shell Lost Desktop icons

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Use YaST -> Security and Users -> User and Group Management and hit the add button, then once finished, logout and login as that test user.
    Hi done that, but when i try to log in get this message:: could not update ICEauthority file /home/test/.ICEauthority

    i think i have to change ownership with chown but i can't find the file!

  5. #15
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,486
    Blog Entries
    15

    Default Re: GNOME Shell Lost Desktop icons

    Hi
    If it doesn't exist, login as your normal user and open a terminal;
    Code:
    su -
    touch /home/test/.ICEauthority
    chmod 600 /home/test/.ICEauthority
    chown test:users /home/test/.ICEauthority
    exit
    Then try logging in again as user test
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #16
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,486
    Blog Entries
    15

    Default Re: GNOME Shell Lost Desktop icons

    Hi
    You might also want to check other file permissions and ownership in the test and your user home directories...

    Maybe in you playing around it somehow changed the permissions of some files?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #17
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default Re: GNOME Shell Lost Desktop icons

    I did that, but i get when I try to create the file with touch, i get the error message 'no such file or directory', should I create a directory called 'test' first, then the file

    cheers

  8. #18
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,486
    Blog Entries
    15

    Default Re: GNOME Shell Lost Desktop icons

    Quote Originally Posted by jimt123 View Post
    I did that, but i get when I try to create the file with touch, i get the error message 'no such file or directory', should I create a directory called 'test' first, then the file

    cheers
    Hi
    Ahh, you didn't select to create the test users home directory in YaST, login back as your user and use YaST to delete the test user and then re-create, just check the box to create the users home directory...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #19
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default Re: GNOME Shell Lost Desktop icons

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Ahh, you didn't select to create the test users home directory in YaST, login back as your user and use YaST to delete the test user and then re-create, just check the box to create the users home directory...
    No, I created it in the terminal with usradd before I read your instruction, in future i will not jump ahead of things and wait for your advice!

    I will get back to you

    cheers

  10. #20
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,486
    Blog Entries
    15

    Default Re: GNOME Shell Lost Desktop icons

    Quote Originally Posted by jimt123 View Post
    No, I created it in the terminal with usradd before I read your instruction, in future i will not jump ahead of things and wait for your advice!

    I will get back to you

    cheers
    Hi
    Ahh, you need to add the -d option
    Code:
    useradd -d /home/test -G users -c "Test User" test
    passwd test
    You can check the other defaults with useradd --show-defaults

    Edit: -m creates the home dir as well..
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 2 of 6 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •