Following up on my suspicions, I have found a fix for my problem but do not fully understand it. Perhaps a file system guru will jump in and expand on what follows.

When I first set up my 11.4 system (new install of 11.4 for /, reuse /home), I entered the following line in fstab to mount my windows drive
Code:
/dev/disk/by-id/ata-FUJITSU_MHZ2320BH_G2_K618T882G161-part1        /windows/C      ntfs-3g user,uid=myusername,gid=users,fmask=113,dmask=000,locale=en_US.UTF-8 0 0
With this mount, /windows/C is owned by myusername, users dwrxwrxwrx .
I had full rwx access to the Windows partition as I wanted/needed and all seemed well.

However, experimenting, I determined that the lightning add-on would not properly install and run when the Thunderbird profile folder was located on this /windows/C partition, but would when I allowed a default Thunderbird profile to be set up in /home/username/.thunderbird.

I looked back at my 11.3 setup notes, and then changed /etc/fstab to
Code:
/dev/disk/by-id/ata-FUJITSU_MHZ2320BH_G2_K618T882G161-part1     /windows/C      ntfs-3g defaults 0 0
With this mount, /windows/C is owned by root,root dwrxwrxwrx .
With the /windows/C partition mounted this way, lightning and google calendar provider installed, configure and run OK.

Other Tbird add-ons (e.g. view:about) had loaded and installed OK with the first fstab, so I am unclear as to why lightning would not.
I did observe that with the first fstab setup, lightning would install but would not properly configure and would not uninstall. I found in a file in the Tbird profile folder named extensions.log a number of error messages.