Results 1 to 7 of 7

Thread: Plasma no longer registers mouse clicks after unlocking the cursor from DOSBox

  1. #1

    Default Plasma no longer registers mouse clicks after unlocking the cursor from DOSBox

    I'm currently running openSuSE 11.4 (kde v 4.6.4), and after unlocking the mouse cursor from the DOSBox (v 0.74) window, none of the Plasma Desktop Widgets or Components will register mouse clicks until I reboot.

    Is there something config-wise I might change to prevent this from happening, or is there an otherwise quick way to restart only plasma using the terminal? Yakuake still drops down, and works, fortunately, so doing this is not a problem.

    EDIT: Forgot to mention that all of said applications were installed from openSuSE repos using YaST2.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Plasma no longer registers mouse clicks after unlocking the cursor from DOSBox

    I'm currently running openSuSE 11.4 (kde v 4.6.4), and after unlocking the mouse cursor from the DOSBox (v 0.74) window, none of the Plasma Desktop Widgets or Components will register mouse clicks until I reboot.

    Is there something config-wise I might change to prevent this from happening, or is there an otherwise quick way to restart only plasma using the terminal? Yakuake still drops down, and works, fortunately, so doing this is not a problem.

    EDIT: Forgot to mention that all of said applications were installed from openSuSE repos using YaST2.
    Have you tried the Ctrl-Alt-F1, which gives you a terminal session to log in to, but then, instead, enter Ctrl-Alt-F7 to restore the GUI session? It has allowed KDE to "find" a new monitor attached after startup, but not sure about mouse clicks. None the less, it might be worth a try when this occurs.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Plasma no longer registers mouse clicks after unlocking the cursor from DOSBox

    Quote Originally Posted by jdmcdaniel3 View Post
    Have you tried the Ctrl-Alt-F1, which gives you a terminal session to log in to, but then, instead, enter Ctrl-Alt-F7 to restore the GUI session? It has allowed KDE to "find" a new monitor attached after startup, but not sure about mouse clicks. None the less, it might be worth a try when this occurs.

    Thank You,
    Just tried that, no effect.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Plasma no longer registers mouse clicks after unlocking the cursor from DOSBox

    So it is my thoughts this is a bug of some sort with kde v 4.6.4 as I don't see it in kde 4.6. I just saw were kde 4.7 was going to hit Factory and so perhaps you will want to upgrade to the newer version and see just what it might do for this problem. I must say that when I used to chase the KDE version up the ladder, I had nothing but odd issues all of the time and finally decided I would just stick with what works, though I do understand other issues with kde 4.6 might still exist.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Plasma no longer registers mouse clicks after unlocking the cursorfrom DOSBox

    On 06/19/2011 12:06 AM, jwesleycooper wrote:
    >
    > I'm currently running openSuSE 11.4 (kde v 4.6.4), and after unlocking
    > the mouse cursor from the DOSBox (v 0.74) window, none of the Plasma
    > Desktop Widgets or Components will register mouse clicks until I reboot.
    >
    > Is there something config-wise I might change to prevent this from
    > happening, or is there an otherwise quick way to restart only plasma
    > using the terminal? Yakuake still drops down, and works, fortunately,
    > so doing this is not a problem.
    >
    > EDIT: Forgot to mention that all of said applications were installed
    > from openSuSE repos using YaST2.
    >
    >


    occasionally my desktop (11.4 32 /w KDE4.6.0) will not respond to left
    mouse clicks, while i can continue to control the cursor and right mouse
    clicks or scroll wheel clicks (double click) sometimes are 'seen' and
    sometimes not..

    however, i have (so far) been unable to determine when these situations
    occur and when not......EXCEPT, another (somewhere her) noticed that
    maybe it happens with Flash running in FF..

    and, i must say that every time it has happened to me lately i have
    flash running, or was running..

    once, while the mouse was 'broken' i ran "zypper ps" and saw that TWO
    "plugin-containe" (which i associate with Flash in FF) were still
    running with its 'file' (video, i guess) already deleted..

    --
    dd
    http://is.gd/bpoMD

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Plasma no longer registers mouse clicks after unlocking the cursorfrom DOSBox

    occasionally my desktop (11.4 32 /w KDE4.6.0) will not respond to left
    mouse clicks, while i can continue to control the cursor and right mouse
    clicks or scroll wheel clicks (double click) sometimes are 'seen' and
    sometimes not..

    however, i have (so far) been unable to determine when these situations
    occur and when not......EXCEPT, another (somewhere her) noticed that
    maybe it happens with Flash running in FF..

    and, i must say that every time it has happened to me lately i have
    flash running, or was running..

    once, while the mouse was 'broken' i ran "zypper ps" and saw that TWO
    "plugin-containe" (which i associate with Flash in FF) were still
    running with its 'file' (video, i guess) already deleted..
    That is very interesting that you could associate a mouse issue with Flash operation in Firefox. Is this the 64 bit beta version you can install or the current 32 bit version?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Plasma no longer registers mouse clicks after unlocking the cursorfrom DOSBox

    On 06/19/2011 04:36 PM, jdmcdaniel3 wrote:
    > That is very interesting that you could associate a mouse issue with
    > Flash operation in Firefox.


    i am not (yet) certain, but i'm beginning to believe that somehow Flash
    is either keeping FF or Plasma or the CPU or something _so_ busy that
    the mouse clicks are being 'overlooked' or just lost....for a while...it
    seems if you wait LONG enough eventually you get the mouse clicks back....

    and, i think the waiting period is shorter after you shut down FF..


    > Is this the 64 bit beta version you can
    > install or the current 32 bit version?


    i'm running 32

    --
    dd
    http://is.gd/bpoMD

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •