Results 1 to 8 of 8

Thread: 11.3+nvidia: Monitor wird nicht korrekt erkannt, zu geringe Auflösung

  1. #1
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    130

    Default 11.3+nvidia: Monitor wird nicht korrekt erkannt, zu geringe Auflösung

    Hallo beisammen,

    ich habe nach einer Neuinstallation von 11.3 folgendes Problem:
    Ich kann in den nvidia-Settings, bzw. auch in der KDE-Systemeinstellung nur noch max. 1024x768 bei 60Hz einstellen. Mein Monitor ist aber ein Iiyama HM903DT (19" Röhre), der kann aber bis 1920x1440. 1280x... hätte ich schon gerne, und vor allem eine höhere Bildwiederholrate. Das hat bei allen Distris, die ich bisher hatte (10.0, 10.3, 11.2 Boxversionen) geklappt.
    Jetzt nur noch das:
    Code:
    mars:/usr/share/man # hwinfo --monitor
    35: None 00.0: 10000 Monitor                                    
      [Created at fb.71]
      Unique ID: rdCR.EY_qmtb9YY0
      Hardware Class: monitor
      Model: "Generic Monitor"
      Vendor: "Generic"
      Device: "Monitor"
      Resolution: 1024x768@76Hz
      Driver Info #0:
        Max. Resolution: 1024x768
        Vert. Sync Range: 50-90 Hz
        Hor. Sync Range: 31-61 kHz
      Config Status: cfg=new, avail=yes, need=no, active=unknown
    Die o.a. Auflösung lässt sich zwar nach einem Boot mit Grub VGA=0x31b auf 1280x1024 erhöhen, X lässt aber trotzdem nur 1024x768 zu.

    OpenSuse 11.3, 64 bit, Downloadversion, Desktop-Kernel
    Graka: Geforce 6600GT, Treiber nvidia 270.xxx (Auch mit dem Neuinstallieren und Nouveau-Treiber nicht besser.)
    KDE 4.4.4
    AMD Phenom II X4 955

    Wird das evtl. beim Treiber 275 besser?

    Ich habe schon viel gelesen, dass es keine xorg.conf mehr gibt, die Einstellung per KMS erfolgt, etc. Da scheinen sich selbst einige Entwickler nicht einig zu sein, wie der X-Server die Konfiguration vornehmen sollte. Ich finde aber keine Abhilfe.1
    Wie kann ich meinem System beibringen, was mein Monitor kann?

    Vielen Dank im voraus.

    Gruß

    kasi

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: 11.3+nvidia: Monitor wird nicht korrekt erkannt, zu geringe Auflösung

    Ist jetzt nur ein Schuss ins Blaue, aber deaktiviere KMS doch mal.

  3. #3
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    130

    Default AW: Re: 11.3+nvidia: Monitor wird nicht korrekt erkannt, zu geringe Auflösung

    Hallo gropiuskalle,

    vielen Dank für die schnelle Antwort. Hättest Du auch noch einen kleinen Tipp, wie?
    Ich würde jetzt in der /etc/modprobe.d rumsuchen...

    LG

    kasi

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: AW: Re: 11.3+nvidia: Monitor wird nicht korrekt erkannt, zu geringe Auflösung

    Nicht ganz, dieser Parameter wird in der /boot/grub/menu.lst festgelegt, z.B. so:

    Code:
    ###Don't change this comment - YaST2 identifier: Original name: linux###                                                                                                              
    title Desktop -- openSUSE 11.4 - 2.6.37.6-0.5                                                                                                                                         
        root (hd0,0)                                                                                                                                                                      
        kernel /boot/vmlinuz-2.6.37.6-0.5-desktop root=/dev/disk/by-id/ata-WDC_WD3200JD-00KLB0_WD-WCAMR1269224-part1 resume=/dev/disk/by-id/ata-WDC_WD3200JD-00KLB0_WD-WCAMR1269224-part3 splash=verbose quiet showopts nomodeset ipv6.disable=1 vga=0x31a                                                                                                                      
        initrd /boot/initrd-2.6.37.6-0.5-desktop
    Die Option heißt "nomodeset". Die Option "ipv6.disable=1" kannst Du bei der Gelegenheit auch gleich hinzufügen (auch wenn das nix mit Deinem Problem zu tun hat), siehe →hier.

    Edit: Doppelposts sind eigentlich nicht so gern gesehen... →http://www.linux-club.de/viewtopic.php?f=48&t=113727

    → Bitte mal lesen

    Wie im anderen thread schon erwähnt, hatte ich diesen Monitor selber mal. Die Angabe der Bildwiederholrate war bei mir grundsätzlich falsch, da würde ich mir keinen Kopf machen - es sei denn, Du bekommst Kopfschmerzen. Sowohl der Monitor als auch die NVidia-Settings dürften Dir die Hz-Frequenzen korrekt anzeigen.

  5. #5
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    130

    Default AW: Re: AW: Re: 11.3+nvidia: Monitor wird nicht korrekt erkannt, zu geringe Auflösung

    Hallo nochmal,

    also, erstmal weiterhin danke für Deine Geduld.
    Grub mit "nomodeset" hat leider nichts gebracht, nur dass er schneller bootet. Meine System-Partitionen liegen auf eine SSD. Der bootet eigtl. in wenigen Sekunden, legt aber ohne "nomodeset" vor Erscheinen des KDM-Login-Screens etliches Sekunden Warteschleife ein. Das gab es früher nicht.

    Die Sache mit dem "Doppelpost" tut mir leid. Ich hatte so eine Antwort auch schon befürchtet, kann mir aber leider trotzdem nicht helfen:

    Ich bin seit etlichen Jahren Suse/Linux-User, und das ist mein erster Post/Hilferuf hier im Forum. Ich habe sehr lange überlegt, ob ich wirklich posten soll.
    Abgesehen davon, dass linux-club.de ein ganz anderes Forum ist, habe ich mir tagelang einen Wolf gesucht, dort wie hier. Bei der Masse an Threads muss ich schon auswählen, und die Überschrift "schlechte Schrift mit Suse 11.4" passt iwie nicht zu meinem Problem. Vor allem finde ich leider auch dort keine Lösung:
    Mein Bildschirm ist ein Vision Master Pro 454 (HM903DT), der schafft 102 Hz bei 1600x1200, empfohlene Auflösung: 12080x1024 bei 85Hz. Damit war ich immer zufrieden. Sowohl der Bildschirm als auch nvidia-settings zeigen mir aber nur 60 Hz an. Selbst nach arg durchzechten Nächten bekommen ich kaum mal Kopfschmerzen, aber das Flimmern nervt - auch wenn es kaum wahrnehmbar ist. Der Bildschirm ist ansonsten saugeil, den würde ich freiwillig nicht gegen einen LCD tauschen. Er wird aber leider nicht erkannt.
    Die nvidia-settings zeigt nur CRT-0(CRT-0 on GPU-0).
    Eine xorg.conf hatte ich bisher nicht. Hierzu habe ich etliche Diskussionen im Netz gefunden, wie diese hier:
    Re: Suse 11.3, kms, Grafik, Aufl
    Daher habe ich die Vermutung, dass mir eine xorg.conf auch nicht weiterhilft. Steht auch in Deinem Thread:
    Die Änderung der xorg.conf wird nicht berücksichtigt.
    Ich habe jetzt mit nvidia-settings eine erstellt, das steht darin:
    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 270.41.06  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Mon Apr 18 15:14:00 PDT 2011
    (...)
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Ich kenne mich zwar ganz gut mit Linux aus, bin leider kein Entwickler. Was ich da so in den letzten Wochen über die X-Server-Einrichtung gelesen habe, bin ich mir nicht sicher, ob ich den Tipps dort folgen sollte. Mein System ist endlich mal wieder schön stabil, da will ich nicht zu sehr an Kernel-Modulen etc. rumpfuschen, es sei denn, ich mache es richtig.

    Bin leider noch nicht schlauer....
    ????

    Viele Grüße

    kasi

  6. #6
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: AW: Re: AW: Re: 11.3+nvidia: Monitor wird nicht korrekt erkannt, zu geringe Auflösung

    Doch, eine xorg.conf wird durchaus berücksichtigt, sofern sie vorhanden ist, diese "überstimmen" zum derzeitigen Zeitpunkt auch die jeweiligen Einstellungen in der xorg.conf.d (wo steht das anders?). Ich würde es trotzdem darauf verzichten, denn sowohl Deine GFX-Karte als auch der Monitor sind Linux bekannt und können automatisch beim boot konfiguriert und angesteuert werden.

    Sorry, bin ansonsten etwas ratlos. Bei mir lief der Monitor mit einer NVidia 9500GT einwandfrei bei 1280x1024 @85Hz, dies aber noch auf einer openSUSE 11.2 (und ja, die Kiste ist wirklich toll, insbesondere für die gleiche Farbqualität muss man heute schon so einiges auf den Tisch blättern (der war ja damals auch alles andere als preisgünstig)).

    Noch mal ganz kurz zum Doppelpost: weshalb die nicht gern gesehen sind, hat mein Kollege framp im entsprechendem Artikel meiner Meinung nach ausreichend dargelegt. Kurz: es geht um Effizienz und den effektiven Einsatz der Ressourcen, über die unsere Community verfügt. Wenn Dir der Titel des ersten threads im LC nicht gefällt, so kannst Du ihn jederzeit ändern (einfach den ersten post editieren, da kannst Du auch den Titel umschreiben - wohlgemerkt: im LC, hier funktioniert das nicht).

  7. #7
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    130

    Default AW: 11.3+nvidia: Monitor wird nicht korrekt erkannt, zu geringe Auflösung

    Stimmt, die xorg.conf wird offensichtlich doch abgefragt. Wenn mit der o.a. Einstellung starte, kriege ich nur noch 640 x 480. Habe sie erstmal umbenannt, alles wieder beim alten.

    Wie auch immer, da es bei mir halt nicht richtig erkannt wird, werde ich demnächst mal etwas recherchieren, was ich in die xorg.conf eintragen kann, damit ich wieder mit 1280x1024 @85Hz arbeiten kann. Falls jemand einen Tipp hat, wäre ich natürlich dankbar. Wenn der 275er Treiber im Repository ist, werde ich den dann testen. Das wird aber 2 Wochen dauern, da ich erstmal auf Dienstreise muss, da habe ich nur nen Firmenlaptop.

    Zum (letzten mal) Doppelpost: Ich hatte nicht vor, einen aufzumachen, bin da ja absolut Eurer Meinung und habe deshalb auch so lange gesucht. Wegen der Überschrift hatte ich diesen ganzen Thread halt gar nicht erst gelesen.

  8. #8
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    130

    Default AW: 11.3+nvidia: Monitor wird nicht korrekt erkannt, zu geringe Auflösung

    So...
    Nach Wochen von Abwesenheit, anderen Prioritäten, Verdrängung etc. habe ich mich "meiner" Auflösung wieder gewidmet. Und: Es klappt.
    Nach ewigem Herumprobieren mit der xorg.conf - mit diversen Backups - bin ich auf den Fehler gestoßen - und das erst, nachdem ich es so versaut habe, dass der X-Server gar nicht mehr mit "startx" starten wollte.
    Die Fehlermeldung schlug mir vor, doch mal in die /var/log/Xorg.o.log zu schauen.
    Sehr hilfreich!
    Nachdem ich meine "alte" xorg.conf wierderhergestellt hatte, und wieder mein altes Problem angehen konnte, fand ich folgende Zeile:
    Code:
    [     7.975] (==) No monitor specified for screen "Screen0".
    Letztendlich habe ich festgestellt, dass nvidia-settings eine defekte xorg.conf erzeugt hatte.
    Die Section Screen war doppelt, außerdem waren die Identifier für den Monitor unterschiedlich, mal war er es Monitor0, mal Monitor[0]. Nachdem ich das korrigiert hatte gings - allerdings dann gleich mit 1600x1200.
    Dann habe ich die nvida-settings als root ausgeführt und konnte endlich 1280x1024 überhaupt wieder auswählen. Bei "save to x configuration file" die xorg.conf komplett neu geschrieben. Jetzt läuft sogar mit 118 Hz.
    Die Grub-Option nomodeset habe ich übrigens wieder herausgenommen. Der einzige Unterschied bei mir ist, dass mit der Option - also ohne KMS - viel mehr Zeit vergeht, bevor der X-Login-Screen kommt.
    Im Repository ist der 275er-Treiber übrigens immer noch nicht verfügbar.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •