Results 1 to 9 of 9

Thread: install wine in SLED 11

  1. #1

    Default install wine in SLED 11

    Hello,
    i tried to install wine in SLED11 but i got this error :

    configure: error: X development files not found. Wine will be built without X support, which probably isn't what you want. You will need to install development packages of Xlib/Xfree86 at the very least.
    Use the --without-x option if you really want this.

    i dont know what should i have to do......

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,775

    Default Re: install wine in SLED 11

    Welcome here on the openSUSE forums. I stress the fact that these are openSUSE forums.

    The place to ask on SLES/SLED is at SUSE PRODUCT DISCUSSION FORUMS

    This does however not mean that you can not ask questions here, but you must be aware of the fact that many people here will not see that you are not using openSUSE, it is even possible that they never heard of SLED.
    Thus their answers might be completely true for openSUSE, while in the same time having no value for you.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: install wine in SLED 11

    On 06/16/2011 04:06 PM, hesisaboury wrote:

    >
    > i tried to install wine in SLED11


    you are welcome to seek advice here, but BE ADVISED that these are the
    openSUSE forums and many of the answers might be from folks who have
    never run SLED (or maybe never even heard of it before) and you are
    likely much better off if you seek assistance from the Novell forums
    (where the SUSE Linux Enterprise gurus hang out), at:
    http://forums.novell.com/

    you are welcome to hang out here and see if anyone has the info you
    need, but you should for sure check in with the novell folks--your
    ID/Pass here works there also..

    i can't help with wine, at all.. (don't need or use it)

    --
    dd
    http://is.gd/bpoMD

  4. #4
    Join Date
    Aug 2010
    Location
    Aveiro, Portugal
    Posts
    313

    Default Re: install wine in SLED 11

    Hi,

    I'm not sure why you want to build from scratch wine... while you have pretty nice repositories with the latest version. Unless you want to custom it with additional patches that are not on the official release, I would recommend you to use the latest builds available from Emulators:Wine.

    Check out this repository: Index of /repositories/Emulators:/Wine/SLE-11

    1.3.21

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: install wine in SLED 11

    hesisaboury wrote:

    >
    > Hello,
    > i tried to install wine in SLED11 but i got this error :
    >
    > configure: error: X development files not found. Wine will be built
    > without X support, which probably isn't what you want. You will need to
    > install development packages of Xlib/Xfree86 at the very least.
    > Use the --without-x option if you really want this.
    >
    > i dont know what should i have to do......
    >

    Do you try to compile it yourself? Because otherwise I cannot understand the
    configure error.
    The easiest way is to install it from the repositories.
    http://download.opensuse.org/reposit...:/Wine/SLE-11/

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.3 | nVidia
    ION | 3GB Ram

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,331
    Blog Entries
    15

    Default Re: install wine in SLED 11

    Quote Originally Posted by martin_helm
    hesisaboury wrote:

    >
    > Hello,
    > i tried to install wine in SLED11 but i got this error :
    >
    > configure: error: X development files not found. Wine will be built
    > without X support, which probably isn't what you want. You will need
    > to install development packages of Xlib/Xfree86 at the very least.
    > Use the --without-x option if you really want this.
    >
    > i dont know what should i have to do......
    >

    Do you try to compile it yourself? Because otherwise I cannot
    understand the configure error.
    The easiest way is to install it from the repositories.
    http://download.opensuse.org/reposit...:/Wine/SLE-11/
    Hi
    The correct way FYI is to install the SLE 11 SDK iso image and then use
    YaST 'Add on Product' to add the iso image, this then enables the SLE
    online update repositories.

    This iso/repositories provides wine and the development tools/libraries
    and it's kept updated as part of your subscription.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.5-desktop
    up 0:42, 3 users, load average: 0.23, 0.10, 0.07
    GPU GeForce 8600 GTS Silent - Driver Version: 270.41.06


  7. #7

    Default Re: install wine in SLED 11

    Thank you For Response
    I Downloaded wine-1.3.21-1.1.src.rpm , But I can not Install With rpm -i command
    by the way how can i get SLE 11 SDK????

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: install wine in SLED 11

    On 06/16/2011 06:36 PM, hesisaboury wrote:
    >
    > Thank you For Response
    > I Downloaded wine-1.3.21-1.1.src.rpm , But I can not Install With rpm
    > -i command



    recognizing i've never seen a SLED run:

    it sounds like you are trying to install the old, last century, Windows
    way, don't do that..

    instead use YaST > Software Management....i think wine is there..

    if not, please ask in the forum where the SLED gurus hang out.

    > by the way how can i get SLE 11 SDK????


    ask at forums.novell.com

    --
    dd
    http://is.gd/bpoMD

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,331
    Blog Entries
    15

    Default Re: install wine in SLED 11

    Quote Originally Posted by hesisaboury
    by the way how can i get SLE 11 SDK????
    Hi
    http://www.novell.com/developer/sle_sdk.html

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.5-desktop
    up 1:43, 3 users, load average: 0.16, 0.13, 0.13
    GPU GeForce 8600 GTS Silent - Driver Version: 270.41.06


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •