Results 1 to 6 of 6

Thread: Paused - "/usr/lib/cups/backend/socket failed"

  1. #1
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default Paused - "/usr/lib/cups/backend/socket failed"

    My problem is fixed, but I have a general question regarding wireless printing with cups. When this error occurs:
    Paused - "/usr/lib/cups/backend/socket failed"
    This has to do with my printer (an HP 6940) changing the URL that is uses. What causes the URL to change in the printer?
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Paused - "/usr/lib/cups/backend/socket failed"

    This is a network-connected printer? I've seen a couple of useful discussions on this.

    1. This blog may (or may not) work fir you, but suggests examining /etc/cups/printers.conf for a couple of messages that need to removed/replaced.

    2. This OpenPrinting thread describes a similar problem to that you're experiencing. Anyway, it was recommended to run the 'hp-makeuri' command.

    just got this printer, too. I'm by no means an expert, but I got it working by using the command:
    hp-makeuri 192.168.2.20

    (obviously, use the ip address of your printer in place of 192.168.2.20)
    this returned two URI's, one for cups, and one for sane (for the scanner)
    I used the cups URI in the cups web-based setup to finally get the printer to work. The cups uri for my printer was:
    hp:/net/Photosmart_C5100_series?ip=192.168.2.20
    For example, if the printer IP address is 192.168.1.3, then run this as root

    Code:
    sudo hp-makeuri 192.168.1.3
    From that re-enter the URI, via the CUPS interface (use a browser):

    http://localhost:631/admin

    Reconfigure your printer, then try a test print.

    I hope this info helps.

  3. #3
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default Re: Paused - "/usr/lib/cups/backend/socket failed"

    Out of curiosity, by changing the uri as suggested
    Code:
    sudo hp-makeuri 192.168.1.3
    is that the same as changing the uri from applications/utilities/printing then clicking properties and changing the uri there?

    If that is the case, I see the suggested way is a faster, but I'm curious why my printer's uri is changing (I'm not having trouble changing the uri to be able to connect to the printer). The trouble I'm having is the printer seems to be changing uri. For example, yesterday, before I left, my uri was 192.168.2.104 and I was able to wirelessly print. Today, I printed my printers report page and seen the uri changed to 192.168.2.100 and changed the uri to the correct number. I'm not sure why the printer is changing. The only thing that occurs at night to the printer and router is they get turned off.
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Paused - "/usr/lib/cups/backend/socket failed"

    The trouble I'm having is the printer seems to be changing uri. For example, yesterday, before I left, my uri was 192.168.2.104 and I was able to wirelessly print. Today, I printed my printers report page and seen the uri changed to 192.168.2.100 and changed the uri to the correct number. I'm not sure why the printer is changing. The only thing that occurs at night to the printer and router is they get turned off.
    Now I understand what is happening. Normally, you assign a static IP to the printer, choosing an address just outside the router's dhcp range. (Some routers have a configuration option to reserve and pass the same IP address to a particular device like a printer as well).

  5. #5
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default Re: Paused - "/usr/lib/cups/backend/socket failed"

    Sorry, I had a brain freeze; I changed the information in the printer and set it to a manual ip address. Prior to this, the setting in the printer was set to automatic ip address. I'm assuming that is why, the printer would periodically change ip addresses.
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Paused - "/usr/lib/cups/backend/socket failed"

    Sorry, I had a brain freeze; I changed the information in the printer and set it to a manual ip address. Prior to this, the setting in the printer was set to automatic ip address. I'm assuming that is why, the printer would periodically change ip addresses.
    Yep. So we can consider this solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •