Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Is there a way to turn the terminal auto-detect off?

  1. #1

    Default Is there a way to turn the terminal auto-detect off?

    SuSE 11.4 is a wonderful release, but two chronic problems remain. The most serious is the inability to get Gnome to recognize an intel driver parameter specification in xorg.conf or 50-screen.conf with a predetermined, working screen specification. With the latest update that includes:
    http://download.opensuse.org/update/...8.1.noarch.rpm
    Gnome will boot up in a strange resolution with a display of a pink screen and fragments of icons split and duplicated over the display. Teasing open the terminal parameter screen, terminal parameters (resolution, horizontal rate) appear to be correct. The terminal type is 'undefined', whether the screen is operating correctly or not, and any attempt to set defaults are refused. Perhaps the intel driver has not been selected by the operating system. Is there a way to specify a default screen driver?
    This has been a chronic problem, now aggravated with the latest update to the point where the computer is now rendered inoperative.
    Ironically, the other problem, that of the difficulty in downloading certain update files also remains. Had an elaborate update workaround procedure not been followed, the system would still be usable.
    Any suggestions would be appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Is there a way to turn the terminal auto-detect off?


    in the future please use a different thread for different
    problems...giving each thread a descriptive subject..

    that said, this should get you far down the path of solving the video
    driver problem: http://tinyurl.com/37v9y7m

    and, that _might_ cure the terminal problem, maybe..

    --
    dd
    http://is.gd/bpoMD

  3. #3

    Default Re: Is there a way to turn the terminal auto-detect off?

    Thank you for the diagnostic information, should provide some hours of entertainment. I did compare xorg.0.log entries between two system IPL's, one that initializes usable and another that results in unusable screen resolution. The log entries were identical. (cat /var/log/Xorg.0.log | grep '('II') '' 'intel)

    With the latest updates, the system now drops into some sort of suspended mode, from which the only recovery is to force power off and reboot. The keyboard is non-responsive, and the screen reports no signal. It seems to be related to a period of system inactivity as if a power management utility had attempted to place the system in standby. The screen blanking is set for a maximum of 2 hours, and system hibernation and disk save have been set to 'never.' Previously, these settings prevented the screen from ever entering the 'screen saver' mode, however, after the latest updates, screen saver seems to be active in spite of any settings to inhibit the function. Power management has been disabled in the personal->startup options, perhaps this will provide a remedy.

  4. #4

    Default Re: Is there a way to turn the terminal auto-detect off?

    Unfortunately, even with the power management software disabled, the system still becomes inoperative, apparently after a period of inactivity.

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Is there a way to turn the terminal auto-detect off?

    On 06/16/2011 09:36 PM, hbco2 wrote:
    >
    > Unfortunately, even with the power management software disabled


    mine doesn't have a button marked "Disable", nor a checked box labeled
    "Enable" which i can uncheck--does yours?


    > the
    > system still becomes inoperative, apparently after a period of
    > inactivity.


    well, what you describe is _not_ normal, so you either have a system
    software problem, a setup problem or a hardware problem....where do you
    want to start? how about here:

    oh wait: i read again and see "after the latest updates, screen saver
    seems to be active in spite of any settings to inhibit the function."
    which is very odd and very bad!! two things:

    1. do not set the screen saver to Random...as it is my experience that
    if you do it will eventually find a saver that interacts with _your_
    hardware and software mix in a very bad way..

    2. use YaST to add a new test user, then log out and back in as that new
    user and see if the troubles end..

    --
    dd
    http://is.gd/bpoMD

  6. #6

    Default Re: Is there a way to turn the terminal auto-detect off?

    "mine doesn't have a button marked "Disable"..."

    It is likely not a global setting, but if I access Computer->Control Center->Startup Applications, "Power Manager" is among entries under the flag "Startup Programs." The respective box has been unchecked, and the Power Manager listing is grayed-out. (Gnome SuSE 11.4.)

    The loss of terminal and keyboard may be related to installing identical information in both /etc/Xinit/xorg.conf and /etc/Xinit/xorg.conf.d/50-screen.conf. Later, the 50-screen.conf file was reconfigured to the original installation default. The apparent result was an 'almost' consistent failure for the screen to initialize in proper resolution, which as mentioned has been the case since the last update. As a last hurrah, CTL-ALT-F1 was used to access a terminal, and the xorg.conf content was moved over to 50-screen.conf and xorg.conf content was removed. That effort may have improved operation, system lockout is gone, but believe there still remains a need to reboot several times in order to obtain correct screen resolution. Won't know until after a couple of tries.

    Screen saver has always been set to a blank screen and maximum delay with the intent that it never activates. When time permits, will try establishing a new user.

    Thanks for the suggestions.

  7. #7

    Default Re: Is there a way to turn the terminal auto-detect off?

    "well, what you describe is _not_ normal, so you either have a system
    software problem, a setup problem or a hardware problem

    2. use YaST to add a new test user, then log out and back in as that new
    user and see if the troubles end.."

    The system is configured to bypass the sign-in screen, and during IPL early screen background color signals the system is configured in the proper screen resolution. Sometimes, the correct color persists, and Gnome is able to generate a proper desktop. The system is then usable until it is shut off.

    Most of the time, the software layer that is installed after the first rotating wheel appears is able to successfully redefine screen resolution. The result is pink mush with little boxes. Switching to a new user is a good way to show how the system can be disrupted. Instead of pink mush, blue-green mush (likely a corrupted view of the SuSE splash screen) is displayed with little boxes.

    Pressing CTRL+ALT+F10 brings up a text screen filled with identical error statements that state in part "kernel [drm intel_prepare_page_flip] *ERROR* prepared flip multiple times."

    I don't know how the mush resolution is defined, as a working, elaborate screen definition (copied from a 11.1 system) has been installed in 50-screen.conf.

  8. #8

    Default Re: Is there a way to turn the terminal auto-detect off?

    System is still crashing. After a brief idle period, screen goes blank, keyboard is lost, only indication computer is operating is the power light on the cabinet. Only option is to force power off and reboot.
    Time to move on?

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Is there a way to turn the terminal auto-detect off?

    On 06/19/2011 03:06 AM, hbco2 wrote:
    >
    > Time to move on?


    or just do a format and reinstall...and, this time keep you hands off of
    it for a while....i mean, your first post indicates you had already
    installed an xorg.conf which has not been needed or used on openSUSE for
    a couple of version releases..

    so, i have NO idea what you did, but i also know that *lots* of other
    folks are not having the problems you are having, and i think i know why.

    ymmv

    --
    dd
    http://is.gd/bpoMD

  10. #10

    Default Re: Is there a way to turn the terminal auto-detect off?

    "or just do a format and reinstall...and, this time keep you hands off of
    it for a while....i mean, your first post indicates you had already
    installed an xorg.conf which has not been needed or used on openSUSE for
    a couple of version releases.."

    (1) The system was upgraded from 11.3 to 11.4.
    (2) A DVD was prepared, and the system was reinstalled from scratch from the DVD.
    (3) xorg.conf from an 11.1 system was emplaced in /etc/X11/ at the recommendation of an expert in this forum. The default 11.4 xorg.conf has been restored. Otherwise, there have been no other changes to the system. The display is now locked at 1024x768. The preferred resolution is 1280x1024. I hope the system will remain active, the intel swap *ERROR* messages have disappeared.

    "so, i have NO idea what you did, but i also know that *lots* of other
    folks are not having the problems you are having, and i think i know why"

    Would appreciate any additional specific suggestions.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •