Results 1 to 6 of 6

Thread: Got a pycurl error when startup miro on openSUSE 11.4

  1. #1
    Join Date
    Mar 2011
    Location
    Shenzhen China
    Posts
    114

    Question Got a pycurl error when startup miro on openSUSE 11.4

    Hi,

    I installed miro from PackMan :: Startseite repository with zypper.

    When I start up miro from terminal, I got below errors:
    $miro
    Fatal Python error: pycurl: libcurl link-time version is older than compile-time version
    ipv6 is sucking wind, so we're switching to ipv4./usr/bin/miro: line 27: 5859 Aborted miro.real "$@"
    I don't know what's this meaning. So, I hope I can get help here. Thanks!

    My system is openSUSE 11.4 x86_64 KDE 4.6.3 .

  2. #2
    Join Date
    Mar 2011
    Location
    Shenzhen China
    Posts
    114

    Default Re: Got a pycurl error when startup miro on openSUSE 11.4

    Solved, I downgraded the package python-curl , then it's ok!

  3. #3

    Default Re: Got a pycurl error when startup miro on openSUSE 11.4

    I'm having a similar problem. I have upgraded from 11.3 to 11.4 using zypper dup. Currently I have the following setup:

    Code:
    # uname -a
    Linux spatula 2.6.37.6-0.5-default #1 SMP 2011-04-25 21:48:33 +0200 x86_64 x86_64 x86_64 GNU/Linux
    
    # rpm -qa |grep python-curl
    python-curl-7.19.0-6.4.x86_64
    
    # rpm -qa |grep libcurl*
    libcurl4-7.21.2-9.1.x86_64
    libcurl4-32bit-7.21.2-9.1.x86_64
    libcurl-devel-7.21.2-9.1.x86_64
    But I get the following error:
    Code:
    # python
    Python 2.7 (r27:82500, Aug 07 2010, 16:54:59) [GCC] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import pycurl
    Fatal Python error: pycurl: libcurl link-time version is older than compile-time version
    Aborted
    I have done a fresh install of 11.4 on a different machine, and that is OK. I am thinking that something was left behind on the upgrade, but I can't see what, installing an older version of python-curl did not work, and a "zypper update" says there is nothing to do.

    Karl.

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Got a pycurl error when startup miro on openSUSE 11.4

    I cannot help you in a direct way since I do not use python-curl and my 11.4
    shows no error, but the following link can possibly help you to diagnose the problem by
    identifying the offending shared library
    http://blog.ksplice.com/2010/09/debu...world-example/
    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.4 | GeForce 9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.4 | nVidia ION | 3GB Ram

  5. #5

    Default Re: Got a pycurl error when startup miro on openSUSE 11.4

    Hello Martin,

    Thanks for that, it helped enormously, this file needed deleting: /usr/local/lib/libcurl.so.4

    Thanks again
    Karl.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Got a pycurl error when startup miro on openSUSE 11.4

    karl101 wrote:
    > Thanks for that, it helped enormously, this file needed deleting:
    > /usr/local/lib/libcurl.so.4

    Glad you found it.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.4 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.4 | nVidia
    ION | 3GB Ram

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •