Results 1 to 7 of 7

Thread: At&t internet causes some applications not to connect to the server

  1. #1
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default At&t internet causes some applications not to connect to the server

    I changed my Internet provider to At&t. I can not connect to the Internet with any Mozillia application and also, I am unable to do any onlne updates through Yast or zypper. I receive a system error when I try to do an online update. It doesn't matter if I connect directly to the modem with the ethernet cable, or use a wireless router.
    It is a Motorola modem.

    Somethings that are odd: (unfortunately I have to run windows a small percentage of the time); and any Internet searches I do with Firefox and Thunderbird work fine. When I go to my Opensuse 11.3 32 bit Gnome side, Thunderbird doesn't connect to the server, firefox mostly doesn't connect to the server (some bookmarks work), konquerer doesn't connect to the server at all; yet Opera, can do any kind of google search just as the windows side.

    I'm not sure where to begin to diagnose the problem, since in the Motorola modem, there is little to configure. I have a DSL and an Internet connection, I can ping anything in a terminal and I receive the packets. I can go down the road to a cafe, and I do not have any of these issues. Where is my configuration wrong?
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,680
    Blog Entries
    3

    Default Re: At&t internet causes some applications not to connect to the server

    My ISP is AT&T, and I am not having any of the problems you hint at.

    I would guess that you are having a DNS problem. Try coding the AT&T servers directly in "/etc/resolv.conf"

    Code:
    nameserver 68.94.156.1
    nameserver 68.94.157.1
    You might have to redo that after a reboot, though that can be fixed. At least test and see if that helps.

    Does your computer get a private IP address (perhaps 192.168.1.64) or a public IP address?
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: At&t internet causes some applications not to connect to theserver

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Two things:

    http://support.mozilla.com/en-US/kb/...programs%20can

    Go into Yast and disable IPv6, then reboot:

    sudo /sbin/yast lan

    Good luck.




    On 06/13/2011 09:06 PM, the Dude abides wrote:
    >
    > I changed my Internet provider to At&t. I can not connect to the
    > Internet with any Mozillia application and also, I am unable to do any
    > onlne updates through Yast or zypper. I receive a system error when I
    > try to do an online update. It doesn't matter if I connect directly to
    > the modem with the ethernet cable, or use a wireless router.
    > It is a Motorola modem.
    >
    > Somethings that are odd: (unfortunately I have to run windows a small
    > percentage of the time); and any Internet searches I do with Firefox and
    > Thunderbird work fine. When I go to my Opensuse 11.3 32 bit Gnome side,
    > Thunderbird doesn't connect to the server, firefox mostly doesn't
    > connect to the server (some bookmarks work), konquerer doesn't connect
    > to the server at all; yet Opera, can do any kind of google search just
    > as the windows side.
    >
    > I'm not sure where to begin to diagnose the problem, since in the
    > Motorola modem, there is little to configure. I have a DSL and an
    > Internet connection, I can ping anything in a terminal and I receive the
    > packets. I can go down the road to a cafe, and I do not have any of
    > these issues. Where is my configuration wrong?
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJN9tSjAAoJEF+XTK08PnB5KM4P/0BBokd8w0BYnBpkut8aohSc
    OWtv0Cy4F74M0l/ZTVb6DTB3b3HGjqU0K9yKUk8fI62kEQPi/FOmCcabKncS1iFn
    pJQrhr+zFoLjQQWLPhphTD/EAABsf31Zm1INiSR+p0Sqd1leJU5HdUjz71qCIb7N
    ekLd3dhl+cdZJlLsKLJu9d1qpPFL9wRlCom3ds2lCM98qkIDI7eCRi9Q7se54Yse
    7tu9OEfn65HywltwmUILz1XpADtR+b/7vFbpBLXYsEgmtYluNKkYtdvQZayMEV9s
    M8FDONCCv6PZiHjpi9rrIPY/oOT925b1GvSEK3faL3WNt5R6dkvJDnNYNZ3iurZN
    /VML0zNOhAn3bfmXc83lK5iFa74ZftYbWxi/Ei+dN2W7REhdYgZOquD2VXw4GM8l
    IYN6tJkZ92vZgv61/JDykSegUGainnBIc8FbL4GEG+4/879TYvjrdUED8VEP6qxi
    dwIfToayV6lOpGREzpAL7RnTaBt5XWfcufna8RNXP2c5DK9uwQyD4LAaCxenXh2y
    X3JvcEnsRx/SyGhJFzCmWzVGT4dxNyNR2cJgpq+KVSv9fCelsvuN8XyNKIzEjUio
    TkID/Mb6gYEjR3JFX0IkaT3ZYaQ4OYFEpLU7HgjwE4LFLKoLVsjwPi7Nu7BEUwUz
    +ofj+m4nVI7lIMcozcqb
    =EHUW
    -----END PGP SIGNATURE-----

  4. #4
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default Re: At&t internet causes some applications not to connect to the server

    Thank you for your responses:

    This worked from here Firefox cannot load websites but other programs can | Troubleshooting | Firefox Help

    I
    IPv6

    Firefox supports IPv6 by default, which may cause connection problems on certain systems. To disable IPv6 in Firefox:

    In the Location bar, type about:config and press Enter.
    The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page.
    In the Filter field, type network.dns.disableIPv6.
    In the list of preferences, double-click network.dns.disableIPv6 to set its value to true.
    I'm able to update OpenSuse, and Firefox works properly.

    Thunderbird still does not, it is having trouble connecting to the server. This is a great start though. Why would this setting have to be changed to begin with?
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

  5. #5

    Default Re: At&t internet causes some applications not to connect to theserver

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Thunderbird has a similar setting... Google found this:

    Edit: Preferences: Advanced: General: Config Editor

    network.dns.disableIPv6 (set to true).

    Why in the first place? Good question. A LAN trace will get you closer
    to the truth but to be honest I do not fully understand it yet. I
    believe, because Mozilla tries to write cross-platform software, that they
    have their own resolver in software and as a result sometimes Firefox and
    Thunderbird do things differently from other software on the machine (such
    as trying to resolve AAAA records for sites vs. just A records). That's
    annoying, but may serve their greater purpose. Why the responses they
    receive are not better handled... well, perhaps a bug. What is odd is
    that this is only a problem for my machine on very certain networks (only
    one found so far, and I hit a lot of networks all over) so I think it's a
    nasty combination of things. Anyway, "Just Do It" and once we're all IPv6
    enabled the problem will probably be gone. Otherwise, take a LAN trace
    and post back once you've figured it out.

    Good luck.





    On 06/13/2011 10:06 PM, the Dude abides wrote:
    >
    > Thank you for your responses:
    >
    > This worked from here 'Firefox cannot load websites but other programs
    > can | Troubleshooting | Firefox Help' (http://tinyurl.com/3dpfgsz)
    >
    > I> IPv6
    >>
    >> Firefox supports IPv6 by default, which may cause connection problems
    >> on certain systems. To disable IPv6 in Firefox:
    >>
    >> In the Location bar, type about:config and press Enter.
    >> The about:config "This might void your warranty!" warning page may
    >> appear. Click I'll be careful, I promise!, to continue to the
    >> about:config page.
    >> In the Filter field, type network.dns.disableIPv6.
    >> In the list of preferences, double-click network.dns.disableIPv6 to
    >> set its value to true.

    >
    > I'm able to update OpenSuse, and Firefox works properly.
    >
    > Thunderbird still does not, it is having trouble connecting to the
    > server. This is a great start though. Why would this setting have to be
    > changed to begin with?
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJN9uJxAAoJEF+XTK08PnB5AnYP/3/kDmSd92Y7j1mK18iZWz0u
    InofBjDXEFYSwMqX6XTQWUZqhyW0Wv4KtQmGsC9yBrwCEGGPRJsnHdB2EjJWRawa
    A4hfEbWpfEDC6TRqkbW9qjsQOR0B1828QjQl3r9/JgBydBrVTJykKNTrm2emEGhe
    Rj5T3oYblRNkvyMlLJmzx29vgk0VlY56/EPEPqiiqa8ERyFOghnQkbzIpvuCBZ5M
    MQdPCKaaABNGEKS05XpPmWctQqbnkGAgqZhGAvLueiLgiBgLQTwIy/fiMkf7w5vT
    B/F3VO+D2UBLju9wJhrRIk6dy+opHtQ6HG8ZmCe5u/MlIV0+ZcfWYj9G8aN1+wmw
    KZWbeW/u3dlEuwQlLDUVcne55dn8Tp/RpRurdGfKz5TofQIWO0TsRLZw+sNOMQO2
    ZQKk6bzT9BpaXDfrQeYrenKr5TM7XB6i0/uc5fenwiC230QmIy+rc77RZdv4fCkc
    IySencNikq1PiGck7zAfWqGRdH5o2k+ekFL7Io59hiCXZ6B21c9/IMhMkzNkokaw
    p6vCVoGBd6a8iEocESNP78c96ypgNyZUswSVtzKlmQbXRhT0lOPJfA1DdxEfbbPn
    CFsexQfaffXHgOl18Vw8A1+Ji3dpbogWO2YAnFZZjjAbz8BACQLnJ7bHRy509jI0
    gf7AQx1Q5a8/e0oXdecl
    =bi82
    -----END PGP SIGNATURE-----

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,680
    Blog Entries
    3

    Default Re: At&t internet causes some applications not to connect to the server

    Quote Originally Posted by the_Dude_abides View Post
    Why would this setting have to be changed to begin with?
    Many routers and dsl modems announce themselves as the DNS server, and provide a dns lookup forwarding service. Cheap routers and modems do that forwarding job very poorly, and they probably mangle IPv6 requests.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default Re: At&t internet causes some applications not to connect to the server

    Thank you, this fixed thunderbirds issue:

    Thunderbird has a similar setting... Google found this:

    Edit: Preferences: Advanced: General: Config Editor

    network.dns.disableIPv6 (set to true).
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •