Results 1 to 10 of 10

Thread: Login keyring

  1. #1
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Login keyring

    hi to all everytime when i login to openSUSE a window named login keyring appears and it asks me root password.it happens everytime when i login.how to fix this problem?


  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Login keyring

    Is that the gnome keyring?

    If it is, then it has its own password. Perhaps you happened to set that to be the same as the root password.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: Login keyring

    it asks both in gnome and kde on login.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Login keyring

    You have some program starting that requires root access.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Login keyring

    It probably needs access to your WiFi key in order to connect.

    If you are doing things in the standard way, then in KDE you should be prompted for the "kwallet" (or "kdewallet") password, while in gnome you should be prompted for the gnome keyring password. If you are doing things in a non-standard way, perhaps you are running the gnome NetworkManager applet while in KDE.

    The image in your first post for this thread is of the gnome keyring. It normally want's your login password there.

    Possible solutions:

    1: If you mainly connect to the same WiFi network, then edit the connection settings, and check the box near the bottom to make this available to all users of your computer. That will ask for the root password. But once that is setup, then you should connect to the WiFi each time before logging in, and you won't again be prompted for a password for that.

    2: If you change the DISPLAYMANAGER to "gdm" (in the "/etc/sysconfig" settings in Yast), then at least gnome should be able to unlock the keyboard on each login. Hmm, come to think of it, I had to fix something before that worked for me, probably because I installed from the KDE live CD.

    3: If you go back to using the plasmoid networkmanager client in KDE, then you can configure that to keep WiFi keys in ordinary files so that a kwallet password isn't needed for KDE logins.

    You need to indicate which of these choices you want to try. Then I'll see if I can provide more guidance if needed.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  6. #6
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: Login keyring

    how to make that applicationgetting permanent access?i mean without giving the password everytime.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Login keyring

    Which application? The gnome networkmanager applet and the KDE network manager client are two different applications, and they handle it differently.

    Let's do this one at a time. You decide where you want to start.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  8. #8
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: Login keyring

    Quote Originally Posted by nrickert View Post
    It probably needs access to your WiFi key in order to connect.

    If you are doing things in the standard way, then in KDE you should be prompted for the "kwallet" (or "kdewallet") password, while in gnome you should be prompted for the gnome keyring password. If you are doing things in a non-standard way, perhaps you are running the gnome NetworkManager applet while in KDE.

    The image in your first post for this thread is of the gnome keyring. It normally want's your login password there.

    Possible solutions:

    1: If you mainly connect to the same WiFi network, then edit the connection settings, and check the box near the bottom to make this available to all users of your computer. That will ask for the root password. But once that is setup, then you should connect to the WiFi each time before logging in, and you won't again be prompted for a password for that.

    2: If you change the DISPLAYMANAGER to "gdm" (in the "/etc/sysconfig" settings in Yast), then at least gnome should be able to unlock the keyboard on each login. Hmm, come to think of it, I had to fix something before that worked for me, probably because I installed from the KDE live CD.

    3: If you go back to using the plasmoid networkmanager client in KDE, then you can configure that to keep WiFi keys in ordinary files so that a kwallet password isn't needed for KDE logins.

    You need to indicate which of these choices you want to try. Then I'll see if I can provide more guidance if needed.
    Very sorry for taking long time to reply your post.First i disabled my kwallet and i am not using wifi now.and i use gnome network applet in gnome and plasmoid manager in kde.i have some doubt in your solutions.

    1.i am not using wifi now so pass it.

    2.i can't understand this.

    3.yes i am using plasmoid manager in kde and i am having one problem in plasmoid i am always using mobile broadband to connect net.see the following image.


    above is when i click on mobile broadband to get details about that connection it will give me a pop up for my password everytime.does it happen to you?how to get rid of this two problems?please help me.

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Login keyring

    Sorry. I have no experience with mobile broadband. I don't know whether that is fixable.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  10. #10
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: Login keyring

    Quote Originally Posted by nrickert View Post
    Sorry. I have no experience with mobile broadband. I don't know whether that is fixable.
    hmm it's okay.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •