Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Видео драйвер

  1. #1
    Join Date
    May 2011
    Location
    Russia, St. Petersburg
    Posts
    20

    Post Видео драйвер

    Добрый всем день.
    Хотел поставить драйвер для своей GeForce8400.. что-то намудрил видимо и теперь при загрузке системы полоска доходит до середины и монитор гаснет в черный экран(лампочка на панели сигнализирует что сигнал на монитор не поступает).
    Подскажите пожалуйста как в failsafe продиагностировать, что на данный момент с видео драйвером(какой стоит?, какой "работает"?, и почему не работает?). Чтобы хоть как-нибудь сдвинуться с мертвой точки.

  2. #2
    Join Date
    Aug 2010
    Location
    Russia
    Posts
    995

    Default Re: Видео драйвер

    1. Каким образом устанавливали драйвер?
    2. Где брали и какая версия?
    3. Есть ли конфиг иксов? (/etc/X11/xorg.conf)
    4. Какой модуль подгружается? nouveau или nvidia? (lsmod)

  3. #3
    Join Date
    May 2011
    Location
    Russia, St. Petersburg
    Posts
    20

    Arrow Re: Видео драйвер

    На 1 и 2 вопрос, четкого ответа нет) но точно могу сказать что драйвер либо с офф. сайта, либо с suse реп.. и он точно должен мне подходить потому что у него числовой индекс 02, ну ещё что-то там с nvidia..
    3. Нет, только файл http://dl.dropbox.com/u/1866846/xorg.conf.install Может пригодиться..
    4. nvidia подгружается: lsmod > lsmod.txt
    http://dl.dropbox.com/u/1866846/lsmod.txt

  4. #4
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: Видео драйвер

    к примеру так: Failsafe → startx → что-то там такое → telinit 3 и смотреть /var/log/Xorg.0.log

    если есть /etc/X11/xorg.conf - удалить (сделав резервную копию)

  5. #5
    Join Date
    May 2011
    Location
    Russia, St. Petersburg
    Posts
    20

    Default Re: Видео драйвер

    Ну он же сразу после startx вываливается в черный экран..
    вот мои логи: http://dl.dropbox.com/u/1866846/Xorg.0.log
    и старый http://dl.dropbox.com/u/1866846/Xorg.0.log.old

  6. #6
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: Видео драйвер

    явных ошибок не вижу.
    покажите rpm -qa | grep nvidia

  7. #7
    Join Date
    May 2011
    Location
    Russia, St. Petersburg
    Posts
    20

    Arrow Re: Видео драйвер

    Quote Originally Posted by joneone View Post
    явных ошибок не вижу.
    покажите rpm -qa | grep nvidia
    x11-video-nvidiaG02-260.19.44-24.1.i586
    nvidia-gfxG02-kmp-desktop-260.19.44_k2.6.37.1_1.2-23.1.i586

    у меня такое ощущение, что я что-то не довключал, какую-нить настройку..

  8. #8
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    2,995
    Blog Entries
    1

    Default Re: Видео драйвер

    Почитайте что пишет на десятой консоли.
    И приведите вывод lsmod.

    Лучше текст выкладывать на SUSE Paste

  9. #9
    Join Date
    May 2011
    Location
    Russia, St. Petersburg
    Posts
    20

    Default Re: Видео драйвер

    Quote Originally Posted by Lazy_Kent View Post
    Почитайте что пишет на десятой консоли.
    И приведите вывод lsmod.

    Лучше текст выкладывать на SUSE Paste
    На 10 консоли вообще ничего подозрительного Ten console
    lsmod я уже приводил выше lsmod

    В boot.msg у меня что-то подобное:
    <4>[ 17.552621] nvidia: module license 'NVIDIA' taints kernel.
    <4>[ 17.595944] Disabling lock debugging due to kernel taint
    <6>[ 17.932038] HDA Intel 0000:00:1b.0: PCI INT A -> Link[LNKD] -> GSI 5 (level, low) -> IRQ 5
    .............................................................................................................................................
    <7>[ 18.303372] ALSA patch_realtek.c:1665: realtek: Enable default setup for auto mode as fallback
    <6>[ 18.313172] input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
    <6>[ 18.735785] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input8
    <6>[ 19.325583] nvidia 0000:05:00.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
    <7>[ 19.368371] nvidia 0000:05:00.0: setting latency timer to 64
    <6>[ 19.368380] vgaarb: device changed decodes: PCI:0000:05:00.0,olddecodes=io+mem,decodes=nonewns=io+mem
    <4>[ 19.413139] NVRM: loading NVIDIA UNIX x86 Kernel Module 260.19.44 Sun Feb 27 21:30:31 PST 2011

    Еще есть zypper.history и zypper.log. Лучше там пользоваться поиском по nvidia ^^

  10. #10
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    2,995
    Blog Entries
    1

    Default Re: Видео драйвер

    loading NVIDIA UNIX x86 Kernel Module 260.19.44
    Вообще-то, пора обновиться. В репозитории 270.41.06 уже несколько месяцев.

    Загрузитесь в init3 и сделайте 'zypper up'.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •