Results 1 to 4 of 4

Thread: X randomly crashes

  1. #1

    Default X randomly crashes

    Hi,

    My X session is randomly crashing with the following backtrace:


    Backtrace:
    [ 36277.010] 0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x483068]
    [ 36277.010] 1: /usr/bin/Xorg (0x400000+0x5e6d9) [0x45e6d9]
    [ 36277.010] 2: /lib64/libc.so.6 (0x7fe7fcd4b000+0x32b30) [0x7fe7fcd7db30]
    [ 36277.010] 3: /usr/lib64/xorg/modules/extensions/libglx.so (0x7fe7fbbe2000+0x38928) [0x7fe7fbc1a928]
    [ 36277.010] 4: /usr/bin/Xorg (FreeResource+0x12e) [0x4278be]
    [ 36277.010] 5: /usr/bin/Xorg (0x400000+0x4ddf6) [0x44ddf6]
    [ 36277.010] 6: /usr/bin/Xorg (0x400000+0x52561) [0x452561]
    [ 36277.010] 7: /usr/bin/Xorg (0x400000+0x25ace) [0x425ace]
    [ 36277.011] 8: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7fe7fcd69bfd]
    [ 36277.011] 9: /usr/bin/Xorg (0x400000+0x25679) [0x425679]
    [ 36277.011] Segmentation fault at address 0x800000005
    [ 36277.011]
    Fatal server error:
    [ 36277.011] Caught signal 11 (Segmentation fault). Server aborting
    [ 36277.011]
    [ 36277.011]
    Please consult the The X.Org Foundation support
    at X.Org Wiki - Home

    it seems to happen most of the time when alt-tabbing to another window, very weird. I'm using OpenSuSE 11.4. This is my hardware:

    Dell Vostro 3550 with Intel i5 processor
    Hybrid Intel + ATI graphics:

    # lspci -v|grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    01:00.0 VGA compatible controller: ATI Technologies Inc NI Whistler [AMD Radeon HD 6600M Series] (prog-if 00 [VGA controller])

    I'm currently using the Intel card as I haven't found a way to switch to the ATI card using vga_switcheroo nor the fglrx driver.

    The system is up to date with updates. Is anyone having this issue?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: X randomly crashes

    The combination of Hybrid Intel + ATI graphics at the same time can be a problem. If you could disable the ATI graphics in your BIOS, you would be better off I would think. There is a kernel load command called nomodeset that you might also want to try. In the Grub OS selection menu, you have the option to enter (type in) a command like nomodeset, just before you press the enter key. I would give it a try and see what that does for you. I would visit your BIOS and see if you can disable the dual personality that your graphics have as well.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: X randomly crashes

    Hi,

    Thanks for the quick response. I have looked into the BIOS before to see if I can disable one of the cards but it isn't possible on this laptop. I'll give a try to the nomodeset boot param and see how it goes.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: X randomly crashes

    Hi,

    Thanks for the quick response. I have looked into the BIOS before to see if I can disable one of the cards but it isn't possible on this laptop. I'll give a try to the nomodeset boot param and see how it goes.
    I would search the internet using your laptop model and the word Linux and see if anyone else has a solution. If you find one with another distro, I would consider switching to it to see if it might work better. Please keep us informed of your progress if you can And, I wish good luck!

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •