Results 1 to 5 of 5

Thread: Switched from Gnome to KDE, and now my system font size (etc) all screwy!

  1. #1

    Default Switched from Gnome to KDE, and now my system font size (etc) all screwy!

    Hey, SUSErs.

    So, I'm trying to switch from gnome 3 to KDE4, due to some serious stability issues, and I'm having some trouble with the system appearance settings:



    What's the best way to get this stuff back to normal?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Switched from Gnome to KDE, and now my system font size (etc) all screwy!

    First make sure you are using the kde session and window managers
    http://dl.dropbox.com/u/10573557/Dis...nager-kde4.jpg
    http://dl.dropbox.com/u/10573557/Dis...nager-kde4.jpg
    A reboot is required

    Then in system settings, have a look at this thread
    Unusual big icons and windows
    it may help
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Switched from Gnome to KDE, and now my system font size (etc) all screwy!

    Quote Originally Posted by knidsrok View Post
    What's the best way to get this stuff back to normal?
    Lower the DPI settings: Personal Settings -> Application Appearance -> Fonts -> Force fonts DPI: 96 DPI (or Disabled).

  4. #4

    Default Re: Switched from Gnome to KDE, and now my system font size (etc) all screwy!

    Thanks for the replies!

    Forcing the DPI did the trick -- it was on "disable" by default, so I set it first to 96, and then to 120, and settled on the latter, as it looks better on my tv/monitor.

    Turns out the issue had nothing to do with switching from gnome, either. I decided to test out KDE in a parallel installation, or else I'd never know what problems were native and what were caused by remnants from the gdm setup, and the font DPI problem presented itself right after I installed the Nvidia proprietary drivers.

    So things are pretty much fixed, except the font is still magnified during the login screen, which isn't a dealbreaker or anything, but any ideas how to force the DPI for that?

  5. #5

    Default Re: Switched from Gnome to KDE, and now my system font size (etc) all screwy!

    Quote Originally Posted by knidsrok View Post

    So things are pretty much fixed, except the font is still magnified during the login screen, which isn't a dealbreaker or anything, but any ideas how to force the DPI for that?
    You can add -dpi 96 to the options of the command starting the X server at different places
    • in the file /etc/X11/xinit/xserverrc
    • in the value of ServerArgsLocal in /usr/share/kde4/config/kdm/kdmrc for kdm (gdm used to take 96 by default)
    • or add the following line in a X system or user resource file which would get parsed *BEFORE* the session manager starts:
      Code:
      Xft.dpi: 96.0
    • Last but not least, you can also try to add this option in the device section of your graphic card in /etc/X11/xorg.conf:
      Code:
      Option	"DPI"	"96x96"

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •