Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: My internal microphone in laptop is not working after update from 11.3 to 11.4

  1. #1
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default My internal microphone in laptop is not working after update from 11.3 to 11.4

    Please help, I don't know what to do. All my attempts to make changes with alsa-mixer failed.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: My internal microphone in laptop is not working after update from 11.3 to 11.4

    Quote Originally Posted by Tux-Tux View Post
    Please help, I don't know what to do. All my attempts to make changes with alsa-mixer failed.
    What desktop are you using ? KDE ? Gnome ? LXDE ?

    When trying to record with a mic, I recommend you test from a terminal, using the command:
    Code:
    arecord -vv -f cd test.wav
    and press <CTRL><C> to stop the recording and then play back test.wav in a media player.

    I also find in openSUSE-11.4 it is helpful to install the application pulse audio volume control 'pavucontrol' and then run 'pavucontrol' at the same time as ones record application (in this case arecord) and tune pulse audio for recording.

    If you still fail after those hints, then please provide more information on your software and hardware audio setup per our stickie in our multimedia section of this forum: Welcome to multimedia sub-area and I'll quote the salient section for you to make it easier to find what you need to provide:


    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script
      Code:
      /usr/sbin/alsa-info.sh
      and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
      .
      Note if for some reason that gives you no website/url/address then run it with the no-upload option:
      Code:
      /usr/sbin/alsa-info.sh --no-upload
      and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.

    .
    ... some clarification on running the script "alsa-info.sh" ... when you run:
    Code:
    /usr/sbin/alsa-info.sh
    you should get something like this (if it asks for an update, select NO):


    followed by this (select the SHARE/UPLOAD option):


    followed by this (its quickest if you simply select 'NO' to seeing the output - you will see it on the web page) :


    followed by this (where in RED is the URL).


    Just post the URL you get (similar to the RED URL in my example, but yours will be different).

    Again, if you can not get that, then run this with the no upload option:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL here.


    Also provide the following:
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • ...
    • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

  3. #3
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Re: My internal microphone in laptop is not working after update from 11.3 to 11.4

    Dear oldcpu, thank you so much for your quick response.
    Unfortunately arecord -vv -f cd test.wav results with a silent data with all my tunings by alsamixer or pavucontrol.
    Code:
    rpm -qa '*alsa*'
    alsa-devel-1.0.24.1-4.7.1.i586
    alsa-plugins-1.0.24-6.1.i586
    alsa-utils-1.0.24.2-3.1.i586
    alsamixergui-0.9.0rc1-749.1.i586
    java-1_6_0-sun-alsa-1.6.0.u25-0.3.1.i586
    alsa-firmware-1.0.24.1-3.1.noarch
    alsa-oss-1.0.17-32.1.i586
    alsa-plugins-pulse-1.0.24-6.1.i586
    alsa-1.0.24.1-4.7.1.i586
    rpm -qa '*pulse*'
    pulseaudio-module-x11-0.9.22-6.11.1.i586
    pulseaudio-module-lirc-0.9.22-6.11.1.i586
    pulseaudio-module-gconf-0.9.22-6.11.1.i586
    pulseaudio-module-bluetooth-0.9.22-6.11.1.i586
    libpulse-browse0-0.9.22-6.11.1.i586
    libxine1-pulse-1.1.19-4.4.i586
    pulseaudio-utils-0.9.22-6.11.1.i586
    pulseaudio-0.9.22-6.11.1.i586
    pulseaudio-module-jack-0.9.22-6.11.1.i586
    pulseaudio-gdm-hooks-0.9.22-6.11.1.i586
    pulseaudio-lang-0.9.22-6.11.1.noarch
    pulseaudio-module-zeroconf-0.9.22-6.11.1.i586
    pulseaudio-esound-compat-0.9.22-6.11.1.i586
    libpulse-mainloop-glib0-0.9.22-6.11.1.i586
    alsa-plugins-pulse-1.0.24-6.1.i586
    libpulse0-0.9.22-6.11.1.i586
    libpulse-devel-0.9.22-6.11.1.i586
    vlc-aout-pulse-1.1.9-3.3.i586
    rpm -q libasound2
    libasound2-1.0.24.1-4.7.1.i586
    uname -a
    Linux linux-393i.site 2.6.37.6-0.5-desktop #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 i686 i686 i386 GNU/Linux
    My alsa-info.sh result is here
    Thank you in advance!

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: My internal microphone in laptop is not working after update from 11.3 to 11.4

    Quote Originally Posted by Tux-Tux View Post
    Dear oldcpu, thank you so much for your quick response.
    Unfortunately arecord -vv -f cd test.wav results with a silent data with all my tunings by alsamixer or pavucontrol.
    .....
    My alsa-info.sh result is here
    Thank you in advance!
    Please do NOT forget ... I need the output of:
    Code:
    cat /etc/modprobe.d/50-sound.conf
    Now while waiting for that, lets look at your mixer settings from the script ....

    "arecord -l" gives this:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
      Subdevices: 2/2
      Subdevice #0: subdevice #0
      Subdevice #1: subdevice #1
    Indicating your mic hardware is hw:0,0 and hw:0,1

    I note this in your mixer:
    Code:
    !!Amixer output
    !!-------------
    !!-------Mixer controls for card 0 [Intel]
    Card hw:0 'Intel'/'HDA Intel at 0xd8a00000 irq 47'
      Mixer name	: 'Intel Cantiga HDMI'
    Simple mixer control 'Front Mic Jack Mode',0
      Items: 'Mic In' 'Line In'
      Item0: 'Mic In'
    Simple mixer control 'Mic',0
      Front Left: Capture 3 [100%] [30.00dB]
      Front Right: Capture 3 [100%] [30.00dB]
    Simple mixer control 'Capture',0
      Front Left: Capture 15 [100%] [22.50dB] [off]
      Front Right: Capture 15 [100%] [22.50dB] [off]
    Simple mixer control 'Capture',1
      Front Left: Capture 15 [100%] [22.50dB] [off]
      Front Right: Capture 15 [100%] [22.50dB] [off]
    Simple mixer control 'Digital',0
      Front Left: Capture 120 [100%] [30.00dB]
      Front Right: Capture 120 [100%] [30.00dB]
    You have Capture 0 and Capture1 muted. Presumably because those are external jacks ? Try unmuting them anyway.

    The next step would be to force a boot configuration for the IDT 92HD88B3 hardware audio codec that may have been misconfigured by alsa, but even IF you provide the output of "cat /etc/modprobe.d/50-sound.conf" that will NOT HELP because there are no hardware audio codecs in the HD-Audio-Models.txt file these model options for the STAC 92HD88 ....

    Try these commands:
    Code:
    arecord -D hw:0,0 -vv -f cd test.wav
    and if that fails this one:
    Code:
    arecord -D hw:1,0 -vv -f cd test.wav
    Again, tune pavucontrol to record the audio. You could also post images of the pavucontrol configuration, input devices (ensure all devices selected in show), and record (ensure all streams shown in show) to this forum via a site such as Fast, Free Image Hosting - ImageBam, so we can check those settings.

    If all that fails, then IMHO you are into bug reporting territory per this guide: openSUSE:Submitting bug reports - openSUSE where you need to write a bug report on openSUSE-11.4 component sound and attach a copy to the bug report of the /tmp/alsa-info.txt file from running:
    Code:
    /usr/sbin/alsa-info.sh --no-upload

  5. #5
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Re: My internal microphone in laptop is not working after update from 11.3 to 11.4

    Dear oldcpu!
    Code:
    sergey@linux-393i:~/ovpn> cat /etc/modprobe.d/50-sound.conf
    
    options snd-hda-intel model=hp
    options snd slots=snd-hda-intel
    # u1Nb.otDuTl8IKL6:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    You'll see model=hp (my experiments), but it cases nothings (nor with this parameter, neither without is - no recording)
    Also please find below my pavucontrol images


    This command arecord -D hw:0,0 -vv -f cd test.wav records silence:
    Another one fails with error:
    Code:
    sergey@linux-393i:~/ovpn> arecord -D hw:1,0 -vv -f cd test.wav
    ALSA lib pcm_hw.c:1401:(_snd_pcm_hw_open) Invalid value for card
    arecord: main:660: audio open error: Нет такого файла или каталога
    Also sometimes after booting I receive the message (not every time and I don't know what it depends on): device STAC92xx Analog is not working... the default device will be used.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: My internal microphone in laptop is not working after update from 11.3 to 11.4

    Quote Originally Posted by Tux-Tux View Post
    Another one fails with error:
    Code:
    sergey@linux-393i:~/ovpn> arecord -D hw:1,0 -vv -f cd test.wav
    ALSA lib pcm_hw.c:1401:(_snd_pcm_hw_open) Invalid value for card
    arecord: main:660: audio open error: Нет такого файла или каталога
    I'm bad ....

    Try instead:
    Code:
    arecord -D hw:0,1 -vv -f cd test.wav

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: My internal microphone in laptop is not working after update from 11.3 to 11.4

    Quote Originally Posted by Tux-Tux View Post
    Dear oldcpu!
    Code:
    sergey@linux-393i:~/ovpn> cat /etc/modprobe.d/50-sound.conf
    
    options snd-hda-intel model=hp
    options snd slots=snd-hda-intel
    # u1Nb.otDuTl8IKL6:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    IMHO unless you specifically know that the model "hp" is for your PC's hardware audio codec, then that test is not worth posting about.

    You SHOULD REMOVE THAT. Its quite possible breaking your mic functionality. It makes no sense to me.

    Reference the screen prints - I don't speak that language so they mean nothing to me. Maybe someone who speaks your language can help ..

    If the above post (with arecord) does not work then you should following this previous recommendation of mine, and I quote:
    Quote Originally Posted by oldcpu View Post
    If all that fails, then IMHO you are into bug reporting territory per this guide: openSUSE:Submitting bug reports - openSUSE where you need to write a bug report on openSUSE-11.4 component sound and attach a copy to the bug report of the /tmp/alsa-info.txt file from running:
    Code:
    /usr/sbin/alsa-info.sh --no-upload

  8. #8
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Re: My internal microphone in laptop is not working after update from 11.3 to 11.4

    Dear oldcpu,
    I've deleted model, now after booting of KDE I receive the message like (my translation) The audio device HDA Intel (STAC92xx Analog) is not working. Will be used default.
    It seams that it's not working. Even
    Code:
    sergey@linux-393i:~/ovpn> arecord -D hw:0,1 -vv -f cd test.wav
    arecord: main:660: audio open error: Нет такого файла или каталога (my translation: no such file or directory)
    Could you please recommend me how to switch alsa / pulse off. I need any simple way to communicate with skype. Thank you!

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: My internal microphone in laptop is not working after update from 11.3 to 11.4

    Quote Originally Posted by Tux-Tux View Post
    Dear oldcpu,
    I've deleted model, now after booting of KDE I receive the message like (my translation) The audio device HDA Intel (STAC92xx Analog) is not working. Will be used default.
    It seams that it's not working. Even
    Code:
    sergey@linux-393i:~/ovpn> arecord -D hw:0,1 -vv -f cd test.wav
    arecord: main:660: audio open error: Нет такого файла или каталога (my translation: no such file or directory)
    Could you please recommend me how to switch alsa / pulse off. I need any simple way to communicate with skype. Thank you!
    Did you try with an external headset mic, as opposed to an internal mic. That likely has a greater chance of working (internal mics are always tricky).

  10. #10
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Re: My internal microphone in laptop is not working after update from 11.3 to 11.4

    The problem is that it worked well in 11.3 and of course I'd like to have it in 11.4. Probably you could recommend me how to switch this sound system off to come back to previous one. I really need something simple. My father is working in 11.3 and we are not able to communicate now as we recently could
    Anyway thank you for your time!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •