Results 1 to 7 of 7

Thread: [SuSE 11.4] Samba won't work

  1. #1
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    507

    Default [SuSE 11.4] Samba won't work

    I want to set up a PDC on my computer using Samba without LDAP, etc...

    The only thing I need is to share folders between the two ridiculous computers here.
    I got a 11.3 laptop and this 11.4 desktop.

    This is the /var/log/samba/log.smbd extract:

    Code:
    [2011/06/11 08:29:35,  0] lib/fault.c:250(dump_core_setup)
      Unable to setup corepath for smbd: Permission denied
    [2011/06/11 08:29:35,  0] smbd/server.c:1134(main)
      smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2010 
    [2011/06/11 08:29:35.951937,  0] passdb/secrets.c:73(secrets_init)
      Failed to open /etc/samba/secrets.tdb
    [2011/06/11 08:29:35.954910,  0] passdb/secrets.c:73(secrets_init)
      Failed to open /etc/samba/secrets.tdb
    [2011/06/11 08:29:35.955027,  0] smbd/server.c:1234(main)   
      ERROR: smbd can not open secrets.tdb
    This is the /var/log/samba/log.nmbd extract:

    Code:
    [2011/06/11 08:27:48.682275,  0] nmbd/nmbd_become_lmb.c:395(become_local_master_stage2)
      *****
      
      Samba name server ANTARES is now a local master browser for workgroup XXXXXXXX.WORLD on subnet
      
      *****
    [2011/06/11 08:28:08.700572,  0] nmbd/nmbd_serverlistdb.c:343(write_browse_list)
      write_browse_list: Can't open file /var/lib/samba/browse.dat.. Error was Permission denied
    I have modified in Yast the User Authentication Source to smbpasswd and specified the correct path to the file...

    This is the /etc/samba/smb.conf extract:

    Code:
    passdb backend = smbpasswd:/XXXXXXXX/smbpasswdfile
    I wasted all the night to try resolve this and now I'm exhausted...

    I erased all the samba related configuration files, uninstalled samba cli/ser samba-yast cli/ser and reinstalled, reconfigured and still have same issue...

    It worked very well with 11.1... (I clean installed 11.4 yesterday)

    Thank you if you have advices to solve this...
    I thought take sources from samba, compile and then see if it works...

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: [SuSE 11.4] Samba won't work

    There is a known problem with nmb and openSUSE 11.4. Check out this thread on the subject.

    Samba set up : nmb is not starting

    And here is a great resource on using Samba:

    openSUSE SuSE Linux HOWTOs and Tutorials by Swerdna

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    507

    Default Re: [SuSE 11.4] Samba won't work

    I certainly wouldn't looked at this post because it was smbd which can't launch ^^

    I remember that AppArmor was disabled on the previous 11.1 system.
    I'll try with AppArmor disabled for this system too.

    I'm in a better condition than this morning, now I'm rested ^^

    Thank you... let's find out a fix !!

  4. #4
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    507

    Default Re: [SuSE 11.4] Samba won't work

    Yep it worked better...
    Thanks a lot !!

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: [SuSE 11.4] Samba won't work

    Yep it worked better...
    Thanks a lot !!
    You are very welcome for the help. For what it is worth I discovered that if you update the kernel version to 2.6.38 or 2.6.39 the problem also goes away without taking any other action though I am not sure if this is a kernel 2.6.37 regression of some sort. Good to hear the rest and help got you going again.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: [SuSE 11.4] Samba won't work

    Quote Originally Posted by jdmcdaniel3 View Post
    You are very welcome for the help. For what it is worth I discovered that if you update the kernel version to 2.6.38 or 2.6.39 the problem also goes away without taking any other action though I am not sure if this is a kernel 2.6.37 regression of some sort. Good to hear the rest and help got you going again.

    Thank You,
    Thanks a zilion, I was looking days on end to solve my smb/nmd problem , uninstalling reinstalling, changing many may config files etc, and switching appamour off solved it, how simple can it be..

    But why is appamour by default on in 11.4 if it creates so much havok !!

    Regards
    cREATRON

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: [SuSE 11.4] Samba won't work

    Quote Originally Posted by creatron View Post
    Thanks a zilion, I was looking days on end to solve my smb/nmd problem , uninstalling reinstalling, changing many may config files etc, and switching appamour off solved it, how simple can it be..

    But why is appamour by default on in 11.4 if it creates so much havok !!

    Regards
    cREATRON
    Running with AppAmour On is thought to be more secure and the problem with Samba was not determined before openSUSE 11.4 was released. Such things do happen.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •