Results 1 to 6 of 6

Thread: When booting directly to XBMC i get "Failed to initialize audio device"

  1. #1

    Unhappy When booting directly to XBMC i get "Failed to initialize audio device"

    Hi

    I have a peculiar problem... I have an OpenSuSE 11.4 (Linux 2.6.37.6-0.5-desktop) with XBMC (10.1) installed.

    During installation of SuSE, I've created a user called "xbmc" and enabled autologin for this user. After XBMC have been installed I added the following to /home/xbmc/.xinitrc - "exec /usr/bin/ck-launch-session /usr/bin/dbus-launch --exit-with-session /usr/bin/xbmc --standalone -fs"... so far so good - everything is perfectly fine...

    ... or at least almost - when trying to play some musik I get the message "Failed to initialize audio device, Check your Audio Settings"... but if I close XBMC, log in to Gnome as root, open a terminal an su to user "xbmc" and start xbmc from commandline it works if I choose "Internal Analog Audio" in System -> System -> Audio Output.

    Now the spooky/funny parts appears... I check the options in Audio Output I see the following:

    With Autologin:

    Defaults
    iec958
    hdmi
    HDA Intel Defaults
    SAA7134 Defaults
    Custom


    When logged in to Gnome, with SU-user=xbmc:

    alsa:default
    Defaults
    Internal Audio Analog Stereo
    Custom


    When returning to auto-login - it stops working again...

    By the way - to be sure that it wasn't a rights-problem, I ended up changing the UID for the "xbmc"-user to "0" to ensure root-privilegies

    Please help a frustrated man...

    Regards
    'Adder

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: When booting directly to XBMC i get "Failed to initialize audio device"

    So I have not had this problem, but I have never used your method to directly run XBMC before.

    During installation of SuSE, I've created a user called "xbmc" and enabled autologin for this user. After XBMC have been installed I added the following to /home/xbmc/.xinitrc - "exec /usr/bin/ck-launch-session /usr/bin/dbus-launch --exit-with-session /usr/bin/xbmc --standalone -fs"... so far so good - everything is perfectly fine...
    How did you come up with this I wonder? Now, I certainly am no expert on XBMC and so what I suggest here may be no better, BUT, why not disable auto login at first, then at the login screen, pick the sessions menu on the bottom left and pick XBMC. Now when you login, you go straight to XBMC. Further, after you have tested this and find that it works, from the same login screen again, hit Ctrl-Alt-F1 and run the Text based YaST and set your auto login there (Ctrl-Alt-F7 takes you back). With the desktop session selected as XBMC and auto login enabled, you should go right into XBMC.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: When booting directly to XBMC i get "Failed to initialize audio device"

    I found the way on XBMC's site (Installing XBMC for Linux - XBMC) - and the reason why I would like to do (i've made the workaround you described just before posting this), is because its way faster to boot the system the other way.

    regards
    'Adder

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: When booting directly to XBMC i get "Failed to initialize audio device"

    I found the way on XBMC's site (Installing XBMC for Linux - XBMC) - and the reason why I would like to do (i've made the workaround you described just before posting this), is because its way faster to boot the system the other way.

    regards
    'Adder
    But the real question is if your audio works properly doing the way I suggest? What is the booting time anyway and how long do you stay like that compared to the time actually using XBMC? I would surely switch back one more time to my way to make sure your way is not the problem with your audio. But in any event, good luck with this problem.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    23,786

    Default Re: When booting directly to XBMC i get "Failed to initialize audio device"

    ... log in to Gnome as root, ..
    I stopped reading here. I guess you understand why. Even if you think you are the perfect man, never making any mistakes and thus there is no objection against you loging in into a GUI as root, take into account that all sorts of people read these threads and that it thus may lead to innocent people to think that this example is something to follow. NEVER log in into the GUI as root. And when you do so nevertheless, NEVER publish it here!
    Henk van Velden

  6. #6

    Default Re: When booting directly to XBMC i get "Failed to initialize audio device"

    Quote Originally Posted by jdmcdaniel3 View Post
    But the real question is if your audio works properly doing the way I suggest? What is the booting time anyway and how long do you stay like that compared to the time actually using XBMC? I would surely switch back one more time to my way to make sure your way is not the problem with your audio. But in any event, good luck with this problem.

    Thank You,
    Hi
    It's a dedicated mediacenter, so It will be in XBMC all the time - and the resources on the box is limited, and without the great performancetests... it will seem that it performs better then its running in it's own GUI environment

    Quote Originally Posted by hcvv View Post
    I stopped reading here. I guess you understand why. Even if you think you are the perfect man, never making any mistakes and thus there is no objection against you loging in into a GUI as root, take into account that all sorts of people read these threads and that it thus may lead to innocent people to think that this example is something to follow. NEVER log in into the GUI as root. And when you do so nevertheless, NEVER publish it here!
    Ease up a little Henk... I've never postulated to be perfect - and I do think it would be clear to all, that it was clear that the login was a part of an errorcorrecting procedure (in fact I did create an "xbmc" user, instead of using "root" to run the "service")... another thing - in an environment with 2 users (root and xbmc) it's hard to use any other user to log into Gnome GUI... due to the fact that the "xbmc" user was locked to the XBMC GUI.

    regards

    'Adder

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •