Results 1 to 9 of 9

Thread: Gnome 3

  1. #1
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    343

    Default Gnome 3

    I originally installed Kde 4 with 11.4 and then later installed the Gnome 3 repo here: Index of /repositories/GNOME:/STABLE:/3.0/openSUSE_11.4, and used Yast to install the Gnome 3 pattern. However when I try to login in to it I get an error box/window that says something like "Oh no. Something has gone wrong and the system was unable to recover. Please log out and try again".

    I'd like to fix it but even if I can't it would be nice to be able to just remove it to clean up the system and recover the space, but I can't deselect the pattern to remove it and I can't just rip it back out by selecting the Gnome 3 repo and deleting everything in it because there are now a gabillion dependencies associated with it that I don't understand.

    Funny how that seems to happen as soon as you install some things.

    Anyway, any suggestions on how to fix it?

    Want anymore information? I will gladly tell you what I can.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Gnome 3

    Hi
    When did you update to Gnome 3.0, it's just switched to 3.0.2 earlier today....

    Did you follow the how to here?
    openSUSE:GNOME 3.0 - openSUSE

    If you remove the repository and do a zypper dup it should rollback to gnome 2.x
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    343

    Default Re: Gnome 3

    Hi, thanks, a few days ago, no, and what?.

    O.K. No really just type that in a terminal as root right? What if I never installed Gnome 2 in the first place? I actually have not done that.

    I'll check it all out.

    Funny thing is I've done this twice. The first time I tried to install Gnome 2 afterwards and even though it seemed to work properly somehow that seemed to screw up Kde. No titlebar/window decorations and the keyboard didn't work all with or without desktop effects, so I reinstalled the entire system.

  4. #4
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Gnome 3

    Scott:

    I had that issue yesterday after installing gnome3 also.

    I moved my .gconf to .gconf.org and .config. to .config.org (and I'm not sure that this step was necessary, you may optionally skip it)
    and then re-installed
    gnome-shell-3.0.1-4.1.i586
    gdm-3.0.0-2.13]
    by using zypper in -f <package> and rebooting. If that doesn't fix it, I'd then mv .config|.gconf to *.org and reboot.

    You may wish to verify those 2 releases by
    Code:
    sudo rpm -qa | grep gnome-shell
    sudo rpm -qa | grep gdm
    as yours may vary from mine.

    HTH.
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Gnome 3

    Hi
    Make sure the repo priority is at 98 and do another zypper dup. I would logout and drop to runlevel 3 do the update.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    343

    Default Re: Gnome 3

    Malcom, thanks. I followed the how to and it works now. Habitual, I wasn't able to use your method because I didn't seem to have those files. I wonder about a couple of things though. The repo I had in Yast was updating periodically but Gnome still never worked. Is the one I'm using now going to as well? What's going on with that and is one of them current and the other one not or are they just maintained by different people. You don't need to answer these questions as I'm sure If I really need to I'll find them out in the eventuality.

    Gnome 3 is really bare. I hope it's just because it's new.

  7. #7
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: Gnome 3

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Make sure the repo priority is at 98 and do another zypper dup. I would logout and drop to runlevel 3 do the update.
    Why the Gnome 3 repo should have priority 98 when 99 is the default value ?

    Yes... i get the same error too...
    Nvidia 9400GT with nvidia driver version 280.13.
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  8. #8
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: Gnome 3

    Back with some details: i`m on Tumbleweed under a 64 bit system and i have used the Tumbleweed repo for Gnome 3 with priority 98 and i get the same thing "Oh no. Something has gone wrong and the system was unable to recover. Please log out and try again".
    Out of curiosity i had installed G3 for the stable repo for 11.4, after i disabled the one from Tumbleweed, and still i get the same thing.
    I had tried different methods including the one mentioned by Habitual, but with no results... Any other ideeas to help me? beside a downgrade to 2.32...
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  9. #9
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: Gnome 3

    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •