Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Toshiba Satellite P200 overheating

  1. #1

    Smile Toshiba Satellite P200 overheating

    Firstly, I apologise in advance as I know this is a common problem but alot of the information on the web relating to it is outdated or too technical for my newbie mind to comprehend any help would be much appreciated!

    I recently installed Ubuntu 11.04 on my Toshiba Satellite P200-1K8 laptop; with Ubuntu the fans were always running at full blast and the laptop would overheat and shut down even though I wasn't using the computer for anything intensive, e.g.just browsing YouTube. I installed openSuse thinking the problem might have been with Ubuntu but in Suse as well the fans seem to be running full blast right from start up and the laptop getting quite hot. I've now learnt this is a generic problem with toshiba satellite laptops and linux, something to do with acpi and possibly the ATI graphics cards? My gpu is an ATI Mobility Radeon 2600 if thats any help. In Windows (which I was last using two days ago) the fans and heat from the laptop were nowhere near this noticeable and I didn't experience this overheating problem just browsing the web.

    Could anyone recommend any fixes to better the heat management of my laptop on Linux (apart from cleaning the fan which I've already tried )?

    Thanks for any help

  2. #2

    Default Re: Toshiba Satellite P200 overheating

    If you think it may be acpi have you considered running it without acpi as a test?

    As root in a terminal type: service acpid stop

  3. #3
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: Toshiba Satellite P200 overheating

    Quote Originally Posted by Ecky View Post
    If you think it may be acpi have you considered running it without acpi as a test?

    As root in a terminal type: service acpid stop
    I don't have my Satellite in front of me so I can't check but the answer, I think, is a boot option (add to your grub menu) like "acpi=linux". That's from memory, but googling for this and similar options might be your quickest route to a solution.
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Toshiba Satellite P200 overheating

    If your fans are running full speed and a laptop is still getting too hot one must consider that your heat sinks inside could be full of dust, which is possible once a laptop is over one year old and in lots of usage. Get you a couple of cans of Duster (cans of compressed air) and blow out the dust from ALL open vents on this Laptop. I suggest two cans because they get cold in use and can freeze up the nozzle. Just switch to the second can and continue blowing out the dust. Once the cans thaw out, they will work just fine again on your next dirty computer.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Smile Re: Toshiba Satellite P200 overheating

    Thanks for all the replies. The problem with the P200 laptop is that its very hard to open up (numerous small screws), in the past I have removed almost every screw I could find and still couldn't open up the chassis to clean the fan. I figured I wasn't experienced enough to be messing around with computer innards that had obviously been designed to be a bit hard to get at and tried to clean the fan through the vents, but I think I may have ended up blowing a good deal of the dust deeper into the laptop >< ... lol. I am guessing the overheating is not purely hardware based as in Windows these problems never occurred, except maybe if I had been playing a 3D game for a long while.

    The most frustrating thing is, I had Ubuntu 10.04 on my laptop in the past (about a year ago) and had the exact same problem, but I remember somehow overcoming it but not exactly how! The old forum threads I find on google relating to this problem don't seem very helpful and I can't find a/the solution anywhere.

    Ecky, I executed the "service acpid stop," there is no noticeable effect afaik. Gminnerup, have you had a similar problem? Can you remember the exact acpi argument? I googled acpi=linux but to no avail unfortunately the only arguments I can seem to find are acpi=off or acpi=force, both of which I'm somewhat unsure to use. For the moment I will keep the laptop on a dinner plate as a makeshift heat sink and I will try cleaning out the laptop fans once more. Thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Toshiba Satellite P200 overheating

    On 06/10/2011 06:06 PM, xenon18 wrote:
    >
    > I am guessing the overheating is not purely
    > hardware based as in Windows these problems never occurred


    you are correct! what you might do is write an email to Toshiba and ATI
    and ask them to pretty please send you the power/heat management.
    graphics and other drivers which are equal in function and capability to
    the drivers they provide to the buyers of their hardware who use MS
    Windows..

    and, wait and see how quickly they send you those..

    in your second note you could just ask them to work closely with the
    Linux driver writers (like they do with the Windows developers) to
    insure Linux users get the same battery life, low noise level, low heat
    output and etc etc etc..

    --
    dd CAVEAT: http://is.gd/bpoMD
    via NNTP openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10
    Acer Aspire One D255, 1.66 GHz Atom, 1 GB RAM, Intel Pineview graphics
    * When your gecko is broken you have a reptile dysfunction! *

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Toshiba Satellite P200 overheating

    First off, you do not need to take the computer case off to blow out the dust, just blow into all of the vents. Second, consider changing the CPU power setup in YaST:

    CPU Speed control exists now in YaST. Why not do the following, open:

    YaST / Software / Software Management, search on Power and install yast2-power-management. Once done, restart YaST.

    Next:

    YaST / System / System Services (Runlevel), select Expert Mode Bullet at the top left:

    Now:

    Find and highlight pm-profiler and then select the button on the bottom right and Enable the pm-profile Service and answer yes to the added services requested.

    Next:

    Select the button on the bottom left and Start the pm-profiler Servrce. You should get a good start with a 0 error return code.

    Now select the finish button on the bottom right and allow your selections to be saved.

    Now:

    YaST / System / Power Management. You can select from three choices with Power Saving doing what I think you are looking for. I would select Powersaving to reduce CPU power usage and perhaps energy creation.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  8. #8

    Default Re: Toshiba Satellite P200 overheating

    I just cleaned out my fans using pressurised air, I was surprised at how much dust came out! My laptop does not seem to be overheating as much anymore and is definitely functional in this state, thanks! I installed the yast2 power manager and tried doing the pm-profiler service thing, it said haldaemon was missing? And (subsequently) there is no Power Management option under YaST/System

    In other news, the window title bars for my programs have suddenly disappeared, meaning I can't drag the windows or close/minimise/maximise them, but I guess that is another topic

  9. #9
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Toshiba Satellite P200 overheating

    I just cleaned out my fans using pressurised air, I was surprised at how much dust came out! My laptop does not seem to be overheating as much anymore and is definitely functional in this state, thanks! I installed the yast2 power manager and tried doing the pm-profiler service thing, it said haldaemon was missing? And (subsequently) there is no Power Management option under YaST/System

    In other news, the window title bars for my programs have suddenly disappeared, meaning I can't drag the windows or close/minimise/maximise them, but I guess that is another topic
    As for the YaST Power Management, you need to follow my steps exactly as this really does work. As for the windows border, make sure you are using the KDE Plasmoid Desktop. When you log into KDE, select the sessions icon on the Bottom Left and select the right KDE desktop to run. If you have activated Compiz, this can also be a symptom of that operation. I would reboot, disable Compiz (only if you enabled it) and make sure you had the right desktop and then go back into YaST and try again for the Power Management.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  10. #10

    Default Re: Toshiba Satellite P200 overheating

    Sorry, I should've mentioned I am using the Gnome desktop. Either way, a reboot cured that problem but I've bookmarked this thread if it were to occur in future. Unfortunately my laptop did overheat again, funnily enough while watching another youtube video perhaps I'll have to stay away from there lol. When I get to the point where I click to enable pm-profile an alert comes up saying:

    To enable service pm-profiler in runlevels 2, 3, 5,
    these services must be additionally enabled,
    because it depends on them:
    haldaemon.
    I click "continue" and then another alert comes up:

    These required services are missing:
    haldaemon.
    I click "continue" and then nothing. Although when I click Start now... in the bottom left the same sequence of alerts comes up but then a return 0 (success) alert comes up immediately after.

    /etc/init.d/pm-profiler start returned 0 (success):
    I exit and save results. Would the power management option be different in Gnome to KDE? There are power management options in the "Control Centre" but no power saving option or anything, more deciding how long the computer idles before sleeping etc

    Thanks for your continued replies, I am following your instructions to the T. I am considering contacting Toshiba for their opinion on the matter as I cannot use my laptop for much more than an hour at a time at the moment unless I switch back to Windows. Any other ideas?

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •