Results 1 to 2 of 2

Thread: Outgoing traffic when using Virtual Interfaces changed in OS 11.4

  1. #1
    Join Date
    Sep 2008
    Location
    Argentina
    Posts
    171

    Default Outgoing traffic when using Virtual Interfaces changed in OS 11.4

    Hello

    There is a big problem with opensuse 11.4 and virtual interfaces.
    Until 11.2 outgoing traffic by default was sent by the eth0 address nevertheless
    which virtual interfaces did exist if any was used.
    Now there seems to be sent by the last interface listed with ifconfig -a

    Example:
    eth0: 10.0.0.1
    eth0:ce 10.0.0.2
    eth0:te 10.0.0.3

    The outgoing address in this case will be 10.0.0.3
    This is very problematic with smtp control etc.

    Is this a know change or should i report a bug?

    Greetings

    Beat

  2. #2
    Join Date
    Sep 2008
    Location
    Argentina
    Posts
    171

    Default Re: Outgoing traffic when using Virtual Interfaces changed in OS 11.4

    Ups sorry
    Problem solved!!!

    My example was not right :-(
    eth0 is in an other subnet as the virtual ones, and to reach hosts in the virtual subnet the last one is used.
    Example:
    ethj0: 10.0.0.1/24
    eth0:ce 192.168.99.1/24
    eth0:te 192.168.99.2/24
    In this case the 192.168.99.2 is used to reach any host in the 192.168.99.x net
    Before 11.4 all interfaces were in the same subnet in 11.4 eth0 is other subnet as the virtual ones.

    Sorry again

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •