Results 1 to 9 of 9

Thread: Yast can't connect to any repository

  1. #1

    Default Yast can't connect to any repository

    Hello,

    after I've installed gnome on top of KDE today (I used the meta pattern opensuse gnome package) yast no longer starts up and gets:
    Code:
    Download (curl) error for 'http://download.opensuse.org/repositories/X11:/RemoteDesktop/openSUSE_11.4/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    for each repository.

    here my
    Code:
    #  | Alias                    | Name                       | Enabled | Refresh | Priority | Type   | URI                                                                         | Service
    ---+--------------------------+----------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------+--------
     1 | 11.4 - VideoLan          | openSUSE-11.4-Update-Debug | No      | Yes     |   99     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.4/                    |        
     2 | X11:RemoteDesktop        | X11:RemoteDesktop          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/RemoteDesktop/openSUSE_11.4/ |        
     3 | ftp.uni-erlangen.de-suse | openSUSE-11.4-Source       | No      | Yes     |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_11.4/          |        
     4 | google-chrome            | google-chrome              | No      | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386                           |        
     5 | openSUSE-11.4-11.4-0     | openSUSE-11.4-11.4-0       | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_TS-L633A                 |        
     6 | repo-debug               | 11.4 - VideoLan            | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.4/repo/oss/              |        
     7 | repo-debug-update        | openSUSE-11.4-Update       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/11.4/                             |        
     8 | repo-non-oss             | openSUSE-11.4-Debug        | Yes     | Yes     |   99     | NONE   | http://download.opensuse.org/distribution/11.4/repo/non-oss/                |        
     9 | repo-oss                 | openSUSE-11.4-Non-Oss      | Yes     | Yes     |   99     | NONE   | http://download.opensuse.org/distribution/11.4/repo/oss/                    |        
    10 | repo-source              | openSUSE-11.4-Oss          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.4/repo/oss/             |        
    11 | repo-update              | google-chrome              | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/
    I turned off a few to see whether it makes any difference but it looks as if none of them can be connected to. My Internet connection is working as I am writing this post with the same machine.

    It worked neither under Gnome nor KDE, I am running opensuse 11.4 KDE 4.5 and whatever gnome is on the standard repos. My kernel is 2.6.37.6-0.5-desktop.

    many thanks in advance
    granit

  2. #2
    Join Date
    May 2010
    Location
    Parkersburg, WV, USA
    Posts
    97

    Default Re: Yast can't connect to any repository

    It would appear that the server is down, at least to the IPv4 world.
    I get the same message when trying to refresh repos.
    2001:67c:2178:8::13: is an IPv6 address but I can't use IPv6.
    Desktop: HP Pavalon customized - OpenSUSE amd64
    Laptop: Compaq Presario V6620US - Arch amd64
    Netbook: EEE1005HA - Arch i686

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast can't connect to any repository

    On 2011-06-09 02:06, DrGranit wrote:
    > Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    >


    That's an IPv6 address. Does your ISP provide to you IPv6? If they don't,
    the current solution is to disable IPv6 from the kernel and up.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Yast can't connect to any repository

    So we all live in different locations with different ISP's, but I am not having this problem and I don't think I am using IPv6. However, I have changed my DNS servers to use Google instead of Time Warner Road Runner. I put the new DNS servers into my router, but it can also be placed directly into a single copy of openSUSE as well.

    Here is a DNS listing you could try:

    Code:
    Google
    
    8.8.8.8
    8.8.4.4
    
    Level 3 Communications (Broomfield, CO, US)
    
    4.2.2.1
    4.2.2.2
    4.2.2.3
    4.2.2.4
    4.2.2.5
    4.2.2.6
    
    Verizon (Reston, VA, US)
    
    151.197.0.38
    151.197.0.39
    151.202.0.84
    151.202.0.85
    151.202.0.85
    151.203.0.84
    151.203.0.85
    199.45.32.37
    199.45.32.38
    199.45.32.40
    199.45.32.43
    
    GTE (Irving, TX, US)
    
    192.76.85.133
    206.124.64.1
    
    One Connect IP (Albuquerque, NM, US)
    
    67.138.54.100
    
    OpenDNS (San Francisco, CA, US)
    
    208.67.222.222
    208.67.220.220
    
    Exetel (Sydney, AU)
    
    220.233.167.31
    
    VRx Network Services (New York, NY, US)
    
    199.166.31.3
    
    SpeakEasy (Seattle, WA, US)
    
    66.93.87.2
    216.231.41.2
    216.254.95.2
    64.81.45.2
    64.81.111.2
    64.81.127.2
    64.81.79.2
    64.81.159.2
    66.92.64.2
    66.92.224.2
    66.92.159.2
    64.81.79.2
    64.81.159.2
    64.81.127.2
    64.81.45.2
    216.27.175.2
    66.92.159.2
    66.93.87.2
    
    Sprintlink (Overland Park, KS, US)
    
    199.2.252.10
    204.97.212.10
    204.117.214.10
    
    Cisco (San Jose, CA, US)
    
    64.102.255.44
    128.107.241.185
    
    logo2 Public DNS Servers
    OpenNIC
    
    202.83.95.227 (au)
    119.31.230.42(au)
    178.63.26.173 (de)
    217.79.186.148 (de)
    27.110.120.30(nz)
    89.16.173.11 (uk)
    69.164.208.50 (us)
    216.87.84.211(us)
    2001:470:8388:10:0:100:53:20 (us)
    2001:470:1f10:c6::2 (us)
    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    May 2010
    Location
    Parkersburg, WV, USA
    Posts
    97

    Default Re: Yast can't connect to any repository

    It's fixed now.
    I didn't do anything, So I don't know whos' end was causing the problem.
    Desktop: HP Pavalon customized - OpenSUSE amd64
    Laptop: Compaq Presario V6620US - Arch amd64
    Netbook: EEE1005HA - Arch i686

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast can't connect to any repository

    On 2011-06-09 06:06, ns89 wrote:
    >
    > It's fixed now.
    > I didn't do anything, So I don't know whos' end was causing the
    > problem.


    Didn't you heard that yesterday was IPv6 day?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7

    Default Re: Yast can't connect to any repository

    BBC News - Web giants promote new IPv6 internet address system

    Well i don't know whether that is the cause, but I was certainly not able to access the repos, and as validly noticed I did use ipv6 to do so.

    When i just tried it it simply worked and I don't feel like i have changed anything related to it. In fact the machine was turned of ever since then.

    Either way it works

  8. #8

    Default Re: Yast can't connect to any repository

    Another possibility is the Proxy Settings (missing or incorrect).
    This was my case.
    You can set it via Yast2/Network Devices/Network Services\Proxy\Proxy configuration.
    You have to check the "Enable Proxy" and "Use the same Proxy for All protocols" fields and fill in the "HTTP Proxy URL" field, e.g. "http://www-proxy.mycompany.gr:8080"

  9. #9

    Default Re: Yast can't connect to any repository

    Quote Originally Posted by ytrapal View Post
    Another possibility is the Proxy Settings (missing or incorrect).
    This was my case.
    You can set it via Yast2/Network Devices/Network Services\Proxy\Proxy configuration.
    You have to check the "Enable Proxy" and "Use the same Proxy for All protocols" fields and fill in the "HTTP Proxy URL" field, e.g. "http://www-proxy.mycompany.gr:8080"

    Thanks to my colleague etgmsks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •