Results 1 to 3 of 3

Thread: Continued ATI graphics card problem

  1. #1

    Unhappy Continued ATI graphics card problem

    I don't know if I'm trying the impossible here - but despite following intructions on various threads outlining potential problems with ATI drivers I can't get things working. I still get the load failure and drop out to the black login screen (no X!).

    I followed the 'Easy Install of ATI proprietary driver in the console' thread and all seemed to go well and according to plan - but stil the black screen.

    I have an old Dell vostro 1000 laptop - installed with an ATI Radeon Xpress 1150 graphics card - and have openSuse v11.0

    When I look at the output from the Xorg.0.log file I see the following: -

    LoadModule "fglrx"
    Loading /usr/lib64/xorg/modules//drivers/fglrx_drv.so
    dlopen /usr/lib64/xorg/modules//drivers/fglrx_drv.so : undefined symbol : miZeroLineScreenKey
    Failed to load /usr/lib64/xorg/modules//drivers/fglrx_drv.so
    UnloadModule "fglrx"
    Failed to load module "fglrx" (loader failed, 7)

    I don't know if this helps or if I can get things going on this laptop - certainly any help would be very much appreciated.

    Regards,

    suse apprentice (hopefully!)

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,138
    Blog Entries
    40

    Default Re: Continued ATI graphics card problem

    Quote Originally Posted by TonyBerzins View Post
    I have an old Dell vostro 1000 laptop - installed with an ATI Radeon Xpress 1150 graphics card - and have openSuse v11.0
    Unfortunately the ATI Radeon Xpress 1150 graphics card was deemed legacy hardware, and NONE of the new AMD graphic drivers will work with it. You need to grab an old driver.

    To quote from the ATI/AMD site from some time back:
    AMD may periodically provide Windows XP and Windows Vista driver updates (for the products listed above) for critical fixes only. No new features will be provided in future driver updates. The Linux ATI Catalyst driver will only be supported in Linux distributions prior to February 2009 for the legacy products listed above.

    Any customers using a combination of a ATI Radeon HD 2000 Series, ATI Radeon HD 3000 Series, or ATI Radeon HD 4000 Series product with any of the legacy products listed above in a single PC system must use the ATI Catalyst 9.3 or earlier driver. All future ATI Catalyst releases made available past the ATI Catalyst 9.3 release will not include support for the legacy products listed above or any of the features associated with those legacy products.
    You can find that old 9.3 driver by looking here: ATI Catalyst™ Proprietary Display Driver

    Note that openSUSE-11.0 is no longer supported, and very few people have it. The graphic structure of openSUSE in versions 11.3 and 11.4 has changed SIGNIFICANTLY since 11.0 so it may be difficult to find people who still remember the old way of doing things.

  3. #3

    Default Re: Continued ATI graphics card problem

    Many thanks for that oldcpu - I'll give the lagacy drivers a go and see what happens. I guess after that it's an upgrade to 11.4 that will be required...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •