Results 1 to 8 of 8

Thread: Permanent display settings are ignored on restart

  1. #1

    Default Permanent display settings are ignored on restart

    The hardware is a Toshiba Satellite 755 with Nvidia graphics. An external monitor is connected via HDMI. The aim is to disable the laptop screen and only use the external monitor. This is no problem with Windows 7. With openSuse 11.4 (64bit), this can also be done via systemsettings. However, after each restart the laptop screen is again enabled and the HDMI only a clone (with the correct resolution), although the settings should have been made permanent.
    Is there a way to fix this?

  2. #2
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default Re: Permanent display settings are ignored on restart

    Which KDE version do you have??

    I think this option does not work with in the version shipped with openSuse
    11.4.

    You may need to upgrade KDE. I have 4.6.3 here and my computer remembers
    this setting.

  3. #3

    Default Re: Permanent display settings are ignored on restart

    Thanks for the tip. My KDE version is 4.6.0. However, the "one-click" install for 4.6.3 on the KDE page is disabled, and adding the KDE repository to yast does not update my installation. So I will have to wait until Suse makes the new version available. Or is there some backdoor to force KDE update from 4.6.0 to 4.6.3?

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,772

    Default Re: Permanent display settings are ignored on restart

    You probably do not do the correct thngs to change to the other repo. Remember that software installation will not change vendor ( to another repo) even if the version numbers there are higher. Try a
    Code:
    zypper dup
    or, when you prefer YaST us the Repository view, select the new repo at left and click on the little text above the list at right that says something like "change packeges to this repo".
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,772

    Default Re: Permanent display settings are ignored on restart

    @tosh755

    BTW, you asked for moving this to the Laptops subforum. I think we better leave it as it is now. You are getting usefull answers and you probably will not take the risc to loose those people by moving your thread.

    Sometimes it is not quite clear where it belongs. I think it is OK here. Could have been in Aplications (because it is a KDE item) also.

    Regards,
    Henk van Velden

  6. #6

    Default Re: Permanent display settings are ignored on restart

    Hello Henk,
    Trying to "change packages" in yast resulted in a lot of unresolved dependencies, but zypper dup did the job. Now I have KDE 4.6.3 and indeed the laptop screen is permanently disabled. It shows only during startup and shutdown, but I can live with that.
    One additional hint: After restarting the laptop, I had to explicitly select the KDE Plasma as session type (Sitzungsart). Otherwise, login failed and I was stuck in a login loop.
    Thanks a lot to you and Fruchtratte!

  7. #7

    Default Re: Permanent display settings are ignored on restart

    I suggested moving this thread to sub-topic "laptop" because graphic cards with an HDMI interface probably are typical for notebooks. So the request to switch off the primary screen will usually come from notebook users, who primarilywould look in that sub-topic.
    Thanks again for the help.

  8. #8

    Default Re: Permanent display settings are ignored on restart

    I just set my laptop to a blank screen when I close the lid and screen displays fine on my monitor. After I have turn my Laptop off and I want to use it again I just turn the laptop on, close the lid and turn on my monitor, works fine

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •