Results 1 to 4 of 4

Thread: Have to re-run vmware-modconfig every time after rebooting in order to run vmplayer

  1. #1

    Default Have to re-run vmware-modconfig every time after rebooting in order to run vmplayer

    I have installed VMPlayer 3.1.4 following the instructions here. It worked fine; I was able to install Windows XP and run it that day.

    My problem is that after shutting down for the night and restarting the next day, I have to re-run the command
    Code:
    sudo vmware-modconfig --console --install-all
    in order to play the vm I've created. I know there's a comment in the thread I pointed to that says re-running the command a second time should fix it permanently, but it didn't for me; I've had to do this three days in a row.

    What do I need to do to fix it so I don't have to re-run that command after rebooting?

  2. #2

    Default Re: Have to re-run vmware-modconfig every time after rebooting in order to run vmplayer

    Sorry, should have specified that I'm using openSUSE 11.4, kernel 2.6.37.6-0.5-desktop, KDE 4.6.0.

    The problem is still there, but I have found out that running
    Code:
    sudo /etc/rc.d/vmware restart
    will also enable vmplayer to work.

    YAST's System Services (Runlevel) screen says that vmware is enabled for runlevels 2.3. and 5, but when I checked the running processes right after logging in, none of the vmware processes were listed. After restarting it (or re-running vmware-modconfig), they are. So it seems that it should load on startup, but isn't for some reason. Any idea where I should look next to figure out why? I found a vmware-installer log in /var/logs, but that's just for the installer.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Have to re-run vmware-modconfig every time after rebooting inorder to run vmplayer

    On 2011-06-09 17:36, dimesio wrote:
    >
    > Sorry, should have specified that I'm using openSUSE 11.4, kernel
    > 2.6.37.6-0.5-desktop, KDE 4.6.0.
    >
    > The problem is still there, but I have found out that running
    >
    > Code:
    > --------------------
    > sudo /etc/rc.d/vmware restart
    > --------------------
    > will also enable vmplayer to work.
    >
    > YAST's System Services (Runlevel) screen says that vmware is enabled
    > for runlevels 2.3. and 5, but when I checked the running processes right
    > after logging in, none of the vmware processes were listed. After
    > restarting it (or re-running vmware-modconfig), they are. So it seems
    > that it should load on startup, but isn't for some reason. Any idea
    > where I should look next to figure out why?


    Try parallel boot "no".

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #4

    Default Re: Have to re-run vmware-modconfig every time after rebooting inorder to run vmplayer

    Quote Originally Posted by robin_listas View Post

    Try parallel boot "no".
    Thanks for the suggestion. I'm pretty sure it would work, but in the meantime I discovered another solution. Checking YAST, I found there were updates to several packages that I hadn't installed, so I installed them, and this morning the vmware modules loaded on startup. I can't say for sure which package fixed it, but one of the updates was to fix a race condition in policykit, so my guess is it was that one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •